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1.Introduction to Comodo Cleaning
Essentials

Comodo Cleaning Essentials (CCE) is a set of computer security tools designed to help users identify and remove
malware and unsafe processes from infected computers.

Major features include:

«  KillSwitch - An advanced system monitoring tool that allows users to identify, monitor and stop any unsafe processes
that are running on their system.

«  Malware scanner - Fully customizable scanner capable of unearthing and removing viruses, rootkits, hidden files and
malicious registry keys hidden deep in your system.

«  Autorun Analyzer - An advanced utility to view and handle services and programs that were loaded when your
system booted-up.

CCE is a lightweight, portable application which requires no installation and can be run directly from removable media such as a
USB key. Home users can quickly and easily run scans and operate the software with the minimum of fuss. More experienced
users will enjoy the high levels of visibility and control over system processes and the ability to configure customized scans from
the granular options menu.

COMODO e

Cleaning Essentials Cptions  Toolz = Help +

Start Scan

Start a scan to unearth and remaove viruses, rootkits, hidden files and malicious registry keys
hidden deep within your system.

Smart Scan Full Scan Custom Scan

When started in aggressive mode, CCE forcibly terminates all the running applications and processes created by currently
logged-in user for fast and efficient scanning.

Guide Structure

This guide is intended to take you through the step-by-step process of organization, configuration and use of Comodo Cleaning
Essentials application.

«  Section 1, Introduction to Comodo Cleaning Essentials, is a high level overview of the solution and serves as an
introduction to the main themes and concepts that are discussed in more detail later in the guide.

Comodo Cleaning Essentials User Guide | © 2012 Comodo Security Solutions Inc. | Al rights reserved 4
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»  System Requirements - Minimum required hardware and software for the application.
«  Downloading Comodo Cleaning Essentials - A brief outline of the download procedure.
»  Starting Comodo Cleaning Essentials - How to run the application.
«  The Main Interface - Description of menus and options in the main interface.
«  Section 2, Scanning your System, explains the various methods of scanning your computer.

«  Smart Scan - Explains how to run a scan on critical areas of your system.
»  Full Scan - Explains how to run a full scan of your system.
«  Custom Scan - Explains how to scan on selected items.

«  Comparison of Scan Types — Provides details on scanners used and the scan sequences followed for different
types of scans in CCE.

»  Section 3, Configuring Comodo Cleaning Essentials - Explains how to configure the overall behavior of the CCE.
«  Section 4, The Tools Menu — Explains how to use the tools in CCE.

* Managing Quarantined Items - How to manage and restore quarantined files.

«  Managing Trusted Vendors — How to add or remove vendors to/from the Trusted Vendor List.

» Importing Antivirus Database — How to import virus database from local storage or from network computer.
«  Checking for Software Updates - How to manually check for program updates.

«  Section 5, Introduction to KillSwitch - is a high level overview of KillSwitch, a powerful built-in system monitoring
tool and serves as an introduction to the main themes and concepts of KillSwitch.

- Starting KillSwitch - How to start the KillSwitch tool.
«  The Main Interface - Description of menus and options in the main interface.

»  Viewing and Handling Processes, Applications and Services - explains how to view the list of currently
running processes, applications and services and handle them.

*  Processes
«  Applications
»  Services

»  Viewing and Handling Network Connections and Usage - explains how to view the details of currently active
network connection and handle it.

«  Network Connections

*  Network Utilization
«  Configuring KillSwitch - Explains how to configure the overall behavior of KillSwitch
- KillSwitch Tools — Explains how to use the tools in KillSwitch.

»  Viewing System Information

»  Repairing Windows Settings and Features

«  Analyzing Program Usage
«  Searching for handles or DLLs

«  Verifying Authenticity of Applications
« Bootlogging and Handling Modules
*  Running Programs from Command Line Interface
«  Viewing KillSwitch Logs
«  Finding Process of Active Window
« Managing Currently Logged-in Users - Explains management of users through KillSwitch.

«  Help and About Details - How to open the online help guide and find the version number and other
miscellaneous details about the application.

«  Section 6, Introduction to Autorun Analyzer - is a high level overview of Autorun Analyzer, a powerful tool to
analyze and handle services and programs that were loaded when your system booted-up and serves as an
introduction to the main themes and concepts of Autorun Analyzer.

«  Starting Autorun Analyzer - How to start the Autorun Analyzer tool.
«  The Main Interface - Description of menus and options in the main interface.
«  Viewing and Handling Autorun Items - Explains how to view the details of services and programs that were
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loaded when your system booted-up.
»  Help and About - Explains how to view the online help and the About dialog of Autorun Analyzer.

«  Section 7, Help and About - How to open the online help guide and find the version number and other miscellaneous
details about the CCE application.

»  Section 8, Using the Command Line Interface — Explanation on how to run various tasks of CCE application from
Windows command line interface

»  Running a Smart Scan from the Command Line Interface — How to run a Smart Scan
*  Running a Custom Scan from the Command Line Interface — How to run a Custom Scan

*  Running a Virus Database Update Task from the Command Line Interface — How to update local virus
database

«  Viewing Help — How to view online help guide of CCE application.

1.1.System Requirements

To ensure optimal performance of Comodo Cleaning Essentials , please ensure that your PC complies with the minimum system
requirements as stated below:
«  Windows 7 (Both 32-bit and 64-bit versions), Windows Vista (Both 32-bit and 64-bit versions) or Windows XP
(Both 32-bit and 64-bit versions)

« 128 MB available RAM
« 210 MB hard disk space for both 32-bit and 64-bit versions

1.2.Downloading Comodo Cleaning Essentials

Comodo Cleaning Essentials is available for 32bit and 64 bit versions of Windows XP, Vista or Windows 7 and can be
downloaded from the following locations:

32 Bit Operating Systems:
http://download.comodo.com/cce/download/setups/cce_2.3.219500.176_x32.zip
64 Bit Operating Systems:
http://download.comodo.com/cce/download/setups/cce_2.3.219500.176_x64.zip

After downloading the Comodo Cleaning Essentials setup files, simply double click on CCE.exe to start using the application. No
installation is required to use CCE, but the latest virus definitions will be downloaded upon first startup.

1.3.Starting Comodo Cleaning Essentials

CCE is a lightweight, portable application which requires no installation and can be run directly from removable media such as a
USB key.

To start the CCE application

«  Navigate to the CCE folder containing the files.

«  Double-click on the @ CCE.exe file.

«  To start CCE in aggressive mode, press and hold 'Shift' key and double click on the file 'CCE.exe'.

In aggressive mode, CCE forcibly terminates all the running applications and processes created by currently logged-in user
before it starts, for fast and efficient scanning.

When you are starting the application for the first time, you will be asked to accept the End-User License Agreement (EULA). It

Comodo Cleaning Essentials User Guide | © 2012 Comodo Security Solutions Inc. | Al rights reserved 6
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is mandatory for you to read and accept the EULA to continue using the application.

cOoMODO

Cleaning Essentials

END USER LICENSE AND SUBSCRIBER AGREEMENT
COMODO CLEANING ESSENTIALS

IMPORTANT - PLEASE READ THESE TERMS CAREFULLY BEFORE DOWMLOADING,
INSTALLING, OR USING COMODO'S CLEANING EZSENTIALS ('PRODUCTS". BY
DOWNLOADING, INSTALLING, OR USING THE PRODUCTS, OR BY CLICKING OM "l
ACCEPT" BELOWY, Y OU ACKNOWLEDGE THAT YOU HAVE READ THIS
AGREEMEMT, THAT YOU UNDERSTAND IT, AMD THAT YOU AGREE TO BE BOUND
BY ITS TERMS. IF ¥OU DO MOT AGREE TO THE TERMS HEREIN, DO NOT
DOWYNLOAD OR UEE THE SOFTYWARE, SUBSCRIBE TO OR USE THE SERVICES,
OR CLUCK OM "l ACCEPT"

This end user license and subscriber agreement is between you "you" or "Subscriber”), as
either an individual or as a business entity, and either:

a. if you are not located in China, Comodo Secunty Solutions, Inc., which has
its principal place of business at 525 Washington Bled. | Suite 1400, Jersey
City, Mew Jersey 07310, or

if wnil are lnrated in China Beiiing Cnmadn Software Develonment Cn | il 4

Accept

2227700170

»  Read the agreement and click 'Accept'. If you do not want to use the application, click 'Exit'.

You need to accept the EULA only when you are starting the application in your computer for the first time. From the next time
onwards, the EULA will not be displayed.

1.4.The Main Interface

Comodo Cleaning Essentials' streamlined interface provides fingertip access and control over all functional areas of the
software.

Comodo Cleaning Essentials User Guide | © 2012 Comodo Security Solutions Inc. | Al rights reserved 7
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COMODO
Cleaning Essentials s = Title Bar
= = controls

Start Scan

Start a scan to unearth and remove virdses, rootkits, hidden files and malicious registry keys
hidden deep within your system.

Scan
Configuration
area

Smart Scan Full Scan Custom Scan

2217700170

Version
Information

The main interface of the application has the following areas:

«  Scan Configuration Area;
«  Title Bar Controls;
«  Version Information.

Scan Configuration Area

The Scan Configuration Area allows you to start scanning your system for potential malware.

Smart Scan - Run scan on memory, autorun entries, hidden services, critical areas like critical registry keys, system
files, system configuration and boot sectors for possible infection by malware, viruses and spyware.

Full Scan - Run a full scan on your system for malware, viruses and spyware.
Custom Scan - Run a scan on areas that you wish for malwares, viruses and spywares in your system.

Title Bar Controls

The top right corner of the main interface contains the links 'Options', 'Tools' and 'Help' that allow you to configure the application
and launch the online help guide.

Options - Allows you to configure various settings in the application.

Tools - Allows you to manage Quarantined items, Trusted Vendor list and virus database. Also contains shortcuts to
open KillSwitch and Autorun Analyzer.

Help - Launches the online help guide

Version Information

At the bottom of the main interface, the version information of the software is displayed.

Comodo Cleaning Essentials User Guide | © 2012 Comodo Security Solutions Inc. | Al rights reserved 8
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2.Scanning Your System

Comodo Cleaning Essentials allows you to perform a quick scan of critical areas in your computer, full system scan
or a custom scan as per your requirements. The Quick Scan a.k.a Smart Scan, checks the critical areas like
Windows Registry, system Files, system memory, autorun entries, hidden services, and boot sectors for possible
infection.

Customized scanning is very useful if you want to scan only a particular file/folder/drive or if you have installed a program and
suspect it may be infected. You can also scan an individual folder or a file you just downloaded from Internet or copied into your
system instantly by dragging and dropping it over the CCE interface.

Refer to the following sections for more details on:
« Smart Scan
*  Full Scan

«  Custom Scan

2.1.Smart Scan

Smart Scan in Comodo Cleaning Essentials allows you to run a quick scan on the critical areas in your system which are highly
prone to infection from viruses, rootkits and other malware. Smart scan scans and cleans the system memory, autorun entries,
hidden services, boot sectors and other critical areas like crucial registry keys in Windows registry, system files and system
configuration. These areas are responsible for the stability of your computer and keeping them clean and sanitized is essential
to keep you healthy and running.

Scanning the critical areas of your system can be executed instantly, but scanning for hidden services and drivers can be
executed only after a system restart.

Hidden services are executed by malicious attempts like a spyware through key logger, rootkits, buffer overflow or Denial of
Service (DoS) attacks. These attacks will be running silently in the computer and enable hackers to steal your identity and
confidential information like your credit card details.

Hence, on completion of a Smart scan, CCE will require a system restart to scan for hidden services.
On completion of scanning, you can:
Clean the detected threats or move them to Quarantine and later remove them;
Exclude an application you consider as safe from the threat list;
Report the threat as a False Positive to Comodo.
To start a Smart scan
1. Click the '‘Smart Scan' from the CCE main interface.

Comodo Cleaning Essentials User Guide | © 2012 Comodo Security Solutions Inc. | Al rights reserved 9
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Start Scan

Start a scan to unearth and remove viruses, rootkits, hidden files and malicious registry keys
hidden deep within your system.

Smart Scan Full Scan Custom Scan

The application will check whether any updates are available for the virus database before commencing the scan. If available, it
will first update the local virus database.

COMODO —L

Cleaning Essentials Tools + Help «

Updating virus signature database...

Keep virus signature database up to date sa that COMODO Cleaning Essentials can detect
and remove latestviruses and roaotkits.

Flease wait while the virus datahase is being updated.
This might take a few minutes. .

It is advised that you always let the application to update the database as scanning with your virus database up-to-date detects
even the zero-hour threats. However, if you do not want the database update at this moment, you can skip this step by clicking
'Skip'.

The application will start scanning the critical areas of your system and the progress will be displayed.

Comodo Cleaning Essentials User Guide | © 2012 Comodo Security Solutions Inc. | Al rights reserved 10
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Scanning Files

CAWINDOWSisystem32isl_anet.acm

@ Ohjects Scanned: 8515 @ Start Tirne: 132011 12:59:40 PM

4z Threat(s) Found: 2 x Dwration: 00:00:29

Pause

During the course of scanning, if you want to see details on the threats detected so far, click Threats Found link. A results
window with the threats identified thus far will be displayed.

On completion of scanning, The 'Scan Finished' dialog will be displayed.

COMODO —L

Cleaning Essentials Toolz + Help

Scan Finished

@ Ohjects Scanned: 53814 @ Start Tirne: 132011 12:59:40 PM

A4# Threat(s) Found: 7 x Dwration: 00:00:50

2. Click 'Next' to view the results.

Comodo Cleaning Essentials User Guide | © 2012 Comodo Security Solutions Inc. | Al rights reserved 11
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Results

Threat Mame COperations

=] Malware@#3ilzv3kedlog3
L cowINDows\Deletevolume|\Deletevalume sxe Clean
=] CAWINDODWS DeleteYolume.zip Clean

Lo Malware@#3ilz¢3kedlbg3
L c\wINDOWS\Deletevalume. zip| Deletevalume  exe
=] Exploit@#2975xfk8s2pgl
I: Co | WINDOW S system32heicar_comieicar,com
CHOINDOW S system32heicar_comieicar . com
=] Malware@#33iwbvbgyzmoq
L cowInDows|system3?\eicar.com
|=|Malware@#Z27s8ewords1vr
L CIWINDOWS\syskem32 eicars. cam

217700170

« If malicious executables are discovered on your system, the 'Results' window displays the list of those items
(Viruses, Malware and so on).

Tip: You can sort the scan results by alphabetical order by clicking the "Threat Name' column header. Similarly you can sort the
scan results based on the risk level by clicking the 'Risk’ column header.

The 'Results' window allows you to quarantine and later remove, ignore the threat if it is a safe file or to submit it as a false
positive to Comodo if you are sure about the authenticity of the file. The default operation is 'Clean’, that means CCE will clean
the threat if a disinfection routine is available for it, else, will move it to quarantine.

cCOMODO

Cleaning Essentials

Results

Threat Mame
-] Application.Win32.LeakTest.~T92@91644
rojant, =}

22217700170

- Toclean a threat, click on the entry under the Operations column and select 'Clean’. The file will be
disinfected or moved to quarantine upon applying the operation. You can later remove the file from your
system from the 'Quarantined Items' interface. Refer to Managing Quarantined ltems for more details.

- Toignore a threat if you consider the file is safe, click on the entry under the Operations column and select
'Ignore’.

Comodo Cleaning Essentials User Guide | © 2012 Comodo Security Solutions Inc. | Al rights reserved 12
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- Toreport threat as a false-positive result, click on the entry under the Operations column and select 'Report'.
The file will be sent to Comodo. Experts in Comodo will analyze the file and add it to whitelist, if found safe.

- To apply a common operation to all the entries in the list, click on the Operations column header and select
the required action.

COMODO —

Cleaning Essentials Tools + Help «

Results

Threat Mame Operations

|=] Application.Win32.LeakTest.~TS2@91644
L E:wirus samplesi TrojanSimulatar| TSSery . exe Clean Al

Report Al

2217700170

3. Click 'Apply' to apply the selected operations to the threats. The selected operations will be applied...
COMODO =

Cleaning Essentials Toole + Help +

Apply Operations

47

10000 0

2217700170

... and your system will restart to check whether the operations are applied correctly and start scanning your system for hidden
services and drivers.

Comodo Cleaning Essentials User Guide | © 2012 Comodo Security Solutions Inc. | Al rights reserved 13
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COMODO Cleaning Essentials(28)

Your computer will now be restarted in order to verify that all selected
threats are cleaned, and continue ko scan for hidden services,

Yes | | MNa

4. Save all your work in the other windows and click Yes to restart your computer. If you plan to apply the operations at a
later time, click No. The clean operations will be executed on the next restart of the computer.

Upon the restart, the application will scan for hidden processes and if it detects any, will clean them and display the resullts.

COMODO —

Cleaning Essentials Tools + Help +

Threat Marme Operation
=] Application.Win32.LeakTest.~TS2@91644
L CIWINDOWS|\ Trojan| TSServe. exe Clzan
: =] Rootkit.HiddenService -
L HEEY_LOCAL_MACHIMEYVSYSTEMCurrentControlSet| Services\apsfg Clzan

22217700170

2.2.Full Scan

It is essential to run a full scan of your system periodically to detect any malware or viruses. During a full scan, CCE scans all
areas including all partitions of hard disk drive, system memory of your computer to identify threats from viruses, malware,
spyware and so on. Before commencing the scan, the application will restart your system in order to identify any hidden services
or drivers created by rootkits, key loggers and so on. Hence before starting a full scan, save all your work and close all the
other programs.

On completion of scanning, you can:
Clean the detected threats or move them to Quarantine and later remove them;
Exclude an application you consider as safe from the threat list;
Report the threat as a False Positive to Comodo.

To start a Full scan

1. Click the 'Full Scan' from the CCE main interface.

Comodo Cleaning Essentials User Guide | © 2012 Comodo Security Solutions Inc. | Al rights reserved 14
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COMODO

Cleaning Essentials

Start Scan

Start a scan to unearth and remaove viruses, rootkits, hidden files and malicious registry keys
hidden deep within your system.

Smart Scan Full Scan Custom Scan

The application will ask your permission to restart the computer to perform rootkit scanning.

COMODO Cleaning Essentials(26)

&5 the part of the scan process, your computer will now be restarted in
ardet ka perfarm the roakkit scanning,
Would yiou like to restart it now?

Yes ] [ Mo

Arootkit is a type of malware that is designed to conceal the fact that the user's system has been compromised. Once installed,
they camouflage themselves as (for example) standard operating system files, security tools and APIs used for diagnosis,
scanning, and monitoring. Rootkits are usually not detectable by normal virus scanners because of this camouflage. However,
CCE features a dedicated scanner that is capable of identifying rootkits and, if any, the hidden files and the registry keys stored
by them.

The restart dialog window will start a count down from 30 and if you do not choose either 'Yes' or 'No' option, the system will
automatically restart when the count down reaches 0.

»  Click Yes to restart the system to perform the rootkit scanning.
« Ifyou click No, the full scan function will not be performed.

Note: The full scan will be performed only if you select Yes to restart the system to perform rootkit scanning.

After the system restart, the application will check whether any updates are available for the virus database before commencing
the scan. If available, it will first update the local virus database.

Comodo Cleaning Essentials User Guide | © 2012 Comodo Security Solutions Inc. | Al rights reserved 15
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Updating virus signature database...
Keep virus signature databhase up to date so that COMODO Cleaning Essentials can detect
and rermove latestwiruses and rootkits.

Flease wait while the virus datahase is being updated.
This might take a few minutes..

It is advised that you always let the application to update the database as scanning with your virus database up-to-date detects
even the zero-hour threats. How ever, if you do not want the database update at this moment, you can skip this step by clicking

'Skip".
The application will start scanning your system and the progress will be displayed.

cCOMODO

Cleaning Essentials

— »

Tools + Help «

Scanning Files

CASystermn Yalume Informatiom_restore{ SBAANC C4-5584-4 B5-9A40-01 4FATATTDRANRP 2
1A0000268.inf

@ Ohjects Scanned: 158633 @ Start Tirne: 12172011 11:23:53 AM

4# Threat(s) Found: 399 x Dwration: 00:08:31

Pause

During the course of scanning, if you want to see details on the threats detected so far, click Threats Found link. A results
window with the threats identified thus far will be displayed.

On completion of scanning, the 'Scan Finished' dialog will be displayed.
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COMODO =L

Cleaning Essentials Tools + Help +

Scan Finished

@ Ohjects Scanned: 134059 @ Start Tirne: 12172011 11:23:53 AM

A4# Threat(s) Found: 492 x Dwration: 00:36:18

217700170

2. Click 'Next' to view the results.

COMODO —L

Cleaning Essentials Tools + Help «

Results

Threat Mame

=] TROJANSIM.~Bim1 5027638
L E:wirus samplesi TrojanSimulatar| TSSery . exe Clean

|=] C:\Documents and Settings' Administrator',Desktop... Clean
L‘j ApplicUnwnti@# Zfafof6uZvxbw

L C\Documents and SetkingsiAdministratorDeskkopl,. ..

|=] ApplicUnwnt@&3bk20E53p8215

I C:Swstem Yolume Information)_restore{SEAADCCE-555..,

I C:Swstem Yolume Information)_restore{SEAADCCE-555..,

L C:iDocuments and SettingsiAdministratoriDeskiopicpil ...

=] ApplicUnwnt@# 1 Tozjz1489i8z

I C:Swstem Yolume Information)_restore{SEAADCCE-555..,

I C:Swstem Yolume Information)_restore{SEAADCCE-555..,

L C:iDocuments and SettingsiAdministratoriDeskiopicpil ...

|- ApplicUnwnt@# 1mc1h28baizh4

Operations

22217700170

- If malicious executables are discovered on your system, the 'Results' window displays the list of those items
(Viruses, Malware and so on).

Tip: You can sort the scan results by alphabetical order by clicking the "Threat Name' column header. Similarly you can sort the
scan results based on the risk level by clicking the 'Risk' column header.

The 'Results' window allows you to quarantine and later remove, ignore the threat if it is a safe file or to submit it as a false
positive to Comodo if you are sure about the authenticity of the file. The default operation is 'Clean’, that means CCE will clean
the threat if a disinfection routine is available for it, else, will move it to quarantine.
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COMODO L

Cleaning Essentials Tools + Help +

Results

Threat Mame
=] TROJANSIM.~Bim1 5027638
samples! TrojanSimulator! ]

=] % Documents and Settings' Administrator',Desktop... Ignore

L) applicUnwnt@# 2Fafof6uzvxbw Essgrt

L ci\Documents and Settings|AdministratariDesktop!,. ..

=] ApplicUnwnt@#3bkZ20E53p8215
- Ci3wstem Yolume Information)_restore{SEAADCCE-558,, Clean
- Ci3wstem Yolume Information)_restore{SEAADCCE-558,, Clean
L CiDocuments and SettingstAdministratoriDeskiophcpil_... Clean
=] ApplicUnwnti@# 1 Tozjz1489i6z
I C:Swstem Yolume Information)_restore{SEAADCCE-555.., Clean
I C:Swstem Yolume Information)_restore{SEAADCCE-555.., Clean
L C:iDocuments and SettingsiAdministratoriDeskiopicpil ... Clean
|- ApplicUnwnt@# 1mc1h28baizh4

217700170

« Toclean a threat, click on the entry under the Operations column and select 'Clean’. The file will be
disinfected or moved to quarantine upon applying the operation. You can later remove the file from your
system from the 'Quarantined Items' interface. Refer to Managing Quarantined Items for more details.

- Toignore a threat if you consider the file is safe, click on the entry under the Operations column and select
'Ignore’.

« Toreport threat as a false-positive result, click on the entry under the Operations column and select 'Report'.
The file will be sent to Comodo. Experts in Comodo will analyze the file and add it to whitelist, if found safe.

«  To apply a common operation to all the entries in the list, click on the Operations column header and select
the required action.

COMODO — L

Cleaning Essentials Tools + Help +

Results

3.

Threat Mame

|=) TROJANSIM.~B@ 18027888

L E:'wirus samples TrojanSimulator T35er exe

=] % Documents and Settings' Administrator',Desktop...

L) applicUnwnt@# 2Fafof6uzvxbw

Operations

Ignore all
an Al
Repart All

L ci\Documents and Settings|AdministratariDesktop!,. ..

=] ApplicUnwnt@#3bkZ20L53p8215
- I F_

Svstem wolume Informat store{SEAANCCE-555,,
CiiDocuments and Settings'AdministratoriCeskboptopil_...

|=) ApplicUnwnti@# 1 7ozjz1489i82

C:15vstem Yolume Information)_restore{SEBAADCC4-555. .,

E Cii3ystem Wolume Informationt_restore{SBAADCCY-553, .,
C:\Documents and SettingsiAdninistratoriDeskiopicpil ...

|- ApplicUnwnt@# 1mc1h28baizh4

Click 'Apply' to apply the selected operations to the threats. The selected operations will be applied...
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cCOMODO

Cleaning Essentials Toole + Help +

Apply Operations

2671343

1000000 00000004000 1
Finished.

... and your system will restart to check whether the operations are applied correctly and start scanning your system for hidden
services and drivers.

COMODO Cleaning Essentials(26)

Your computer will now be restarked in order to werify that all selected
threats are cleaned, and conkinue to scan For hidden services,

Yes ] [ Mo

The restart dialog window will start a count down from 30 and if you do not choose either 'Yes' or 'No' option, the system will
automatically restart when the count down reaches 0.
«  Click 'Yes' to restart your computer.

« If you plan to apply the operations at a later time, click No. The clean operations will be checked and scan
for hidden services will be resumed on the next restart of the computer.

... and your system will restart to check whether the operations are applied correctly and start scanning your system for hidden
services and drivers.
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cOMODO

Cleaning Essentials

Analyzing...

00T 1T

CASystem Volume Information'_restore{8BAADCC4-5584-4285-9540-014FATATTDBY)}
\RP1EWAO00183T data

217700170

The results will be displayed.

COMODO L

Cleaning Essentials Tools + Help +

Threat Mame | Operation

=] TROJANSIM.~Bim1 5027638 o —
L E:\wirus samplest TrajanSimulatar| TS5ery. exe Clean

|=] ApplicUnwnti@#3bk20t53p8215

I C:Swstermn Yolume InFormation)_restore{SEAAD. .. Clean

I C:Swstermn Yolume InFormation)_restore{SEAAD. .. Clean

L C:\Documents and SettingsiAdministratoriDeskt,.. Clean

ApplicUnwnt@#1Tozjz1489i8z

I C:Swstermn Yolume InFormation)_restore{SEAAD. .. Clean

I C:Swstermn Yolume InFormation)_restore{SEAAD. .. Clean

L C:\Documents and SettingsiAdministratoriDeskt,.. Clean

ApplicUnwnt@# 1mclh28baizh4

I C:Swstem Yolume Information)_restore{SEAAD... Ignore

C:15vstem Yolume Information)_restore{SEAAD... Ignore

C:15vstem Yolume Information)_restore{SEAAD... Ignore

C:15vstem Yolume Information)_restore{SEAAD... Ignore

CHiDocuments and SettinosiddministratoriDeskE. .. Tanore

2.3.Custom Scan

The custom scan feature allows you to check for viruses in any particular file/folder or drive. You may have just downloaded
some files from Internet and not sure whether it is free from malware or not. The custom scan feature in CCE allows you to
select a file or folder to check for malware or viruses. The custom scan feature is a useful and flexible complement to
periodically running a 'regular' full scan of your system.

Custom Scan is relatively agile scan method. You can choose what would you want to scan, and where would you want to scan.

The system will require a restart to scan for hidden services and drivers only if you choose to scan memory, critical areas, scan
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for hidden registry objects and services and hidden files and folders. Else no restart is required.
On completion of scanning, you can:
Clean the detected threats or move them to Quarantine and later remove them;
Exclude an application you consider as safe from the threat list;
Report the threat as a False Positive to Comodo.
Comodo Cleaning Essentials allows you to:
- Start a Custom Scan on selected folder(s)/file(s) with configuration of scan options
« Instantly scan a file or folder
Starting a Custom Scan
1. Click the 'Custom Scan' from the CCE main interface.

CcCOMODO —

Cleaning Essentials Options  Toolz + Help

Start Scan

Start a scan to unearth and remove viruses, rootkits, hidden files and malicious registry keys
hidden deep within your system.

Smart Scan Full Scan Custom Scan

22217700170
The Custom Scan Setting dialog window will be displayed.

COMODO — L

Cleaning Essentials Options  Tools = Help +

@ Custom Scan Options

] Mermory

[ Don't scan forviruges

= [ ¥ My Computer
Local Disk{C:1)

[C] Critical areas and boot sector New Volume(E:\)

[ Hidden registry objects and services

[ Hidden files and folders

Add File... H Add Folder.. H Femove

2217700170
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You can select which options you prefer for the custom scan and also choose which specific files, folders or drives are to be
included in the scan in the Scan Target area.

2. Choose the Scan Options

«  Memory - When selected, CCE scans the system memory during the start of any custom scan.

«  Critical areas and Boot Sector - When selected, CCE scans the Program Files folder and WINDOWS
folder of the Operating System of your computer and the Boot Sector of your hard disk drive during the start
of any custom scan.

- Hidden registry objects and Services - When selected, all the hidden registry objects will be scanned by
CCE during the start of any custom scan.

«  Hidden files and folders - When selected, CCE scans hidden files and folders in the drives that are
selected in the Scan Target area.

»  Don't scan for viruses - When selected, CCE will not check for viruses in the target areas as specified by
the above options. This option is only for scanning the above said areas and not on any target areas in your
hard disk drive. Hence, the target selection area will become inactive and grayed out.

Note: If this option is selected:
«  CCE won'tinvoke AV engine entirely.
«  You must choose at least one of other options:
i. Memory
ii. Critical areas and Boot Sector
iii. Hidden registry objects and Services
iv. Hidden files and folders

3. Choose the scan target area(s). By default, all the drives in your system will be selected for custom scan.

COMODO —

Cleaning Essentials Options  Toolz + Help

@ Custom Scan Options

[ Mermory

[] Don't scan forviruses

= [ ¢ My Computer

[C] Critical areas and boot sectar
[ Hidden registry objects and services

] Hidden files and folders

Add File... H Add Folder... H Femove

To add file(s)

»  Click the "Add Files'.
«  Browse to the required file and click 'Open’
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e T cucknn Music Player
“J [ cucknn

Recent

r

Deszkiop

Y

%

ty Documents

Wy Carmputer

File name: | Cuckoo Music Player j
‘g Files of type: | Al Files[*." =l

My Metwork [[] Open as read-only

The selected file will be added to the custom Scan Target area.

COMODO L

Cleaning Essentials Optionz Toolz + Help +

@ Custom Scan Options

[ Mermory

[ Don't scan forviruges

=% My Computer
“[J5e# Local Disk(C:1)
[O5e Mew YolumelE:)
. . i . =03 Custom
M Hidden registry objects and services {ﬁ E:\Downloaded FillestCuckoo\Music PlayersiCL

[C] Critical areas and boot sector

[ Hidden files and folders

m ] i

Add File... H Add Faolder... H Remaove ]

« You can add more files and folders for a simultaneous custom scan. Repeat the process to add more files.
To add Folder(s):

»  Click the "Add Folders'".
- Browse to the required folder and click 'OK'.
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Browse For Folder

Select and add a Folder For custom scan.

My Documents q
= ¢ My Computer

‘ﬂ, 314 Flappy (A0

S Local Disk {C:)

b CD Drive (D)

[= “e= Mew Volume (E:)

29 pownloaded Files
G’ Conkral Panel
I shared Documents

P v NS TP -

el " s 2

[ Make Mew Folder l [ (04 l [ Cancel l

The selected folder will be added to the custom Scan Target area.

COMODO i

Cleaning Essentials Options  Tools = Help +

@ Custom Scan Options

[ Mermory

] Don't scan forviruses

=0 d My Computer
- [J%e Local Disk{C:h)
o [Jeee New YalumedE:1)

. . . ) =03 Custar
[ Hidden registry objects and services {2 Er\Downloaded Files)

[[] Critical areas and hoot sectar

[ Hidden files and folders

Add File... H Add Folder... H Remave

«  You can add more files and folders for a simultaneous custom scan. Repeat the process to add more files.

4. Click 'Scan' to run the custom scan. The selected file(s)/Folder(s) will be scanned with the scan options and the
progress will be displayed.
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cCOMODO

Cleaning Essentials Toole + Help +

Scanning Files

EiDownloaded FilesWWallbreaker zip[yallbreakeri'allBreaker exe

@ Objects Scanned: 89 @ Start Time: 1202011 5:06:30 P

A4# Threat(s) Found: a0 x Dwration: 0o:00:02

Pause

During the course of scanning, if you want to see details on the threats detected so far, click 'Threat(s) Found' link. A results
window with the threats identified thus far will be displayed.

The Results

On completion of scanning, the 'Scan Finished' dialog will be displayed.

cOMODO

Cleaning Essentials

— x

Toolz = Help -

Scan Finished

@ Ohjects Scanned: 116925 G} Start Time: 12Mi2011 4:56:51 P

4# Threat(s) Found: 53 1 Duration: 00:01:04

5. Click 'Next' to view the results.
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cCOMODO

Cleaning Essentials

Results

Threat Marme | Risk. | Operations

|=] E:\Downloaded Files'Delete¥olume.zip Clean
L-|Malware@#3ilz¥3kedibg3
L E:\Downleaded Files\Deletevalume. zip| Delet¥alum. .,
= Malware@#33iwbvbgyzmoqg
L E:\Dowrloaded Filesteicar.com
=] Exploit@#2975xfk8s2pql
I: E:'\Downloaded Fileseicar_comieicar.com

E:\Downloaded Files\sicarcomZieicar_com'eicar,com
|=|Malware@#Z27s8ewords1vr
L E:\Dowrloaded Files\sicarcom®|sicar_com.zip
= Malware@#3ilzvy3kedlog3
L E:\Downloaded FilesiDeleteVolumeiDeletelolume. exe

=] E:Downloaded Filesh eicarcom2.zip
L‘j Malware@ 2 7sBewoxds1vr

22217700170

- If malicious executables are discovered on the scanned areas, the 'Results' window displays the list of those
items (Viruses, Malware and so on).

Tip: You can sort the scan results by alphabetical order by clicking the "Threat Name' column header. Similarly you can sort the
scan results based on the risk level by clicking the 'Risk' column header.

The 'Results' window allows you to quarantine and later remove, ignore the threat if it is a safe file or to submit it as a false
positive to Comodo if you are sure about the authenticity of the file. The default operation is 'Clean’, that means CCE will clean
the threat if a disinfection routine is available for it, else, will move it to quarantine.

COMODO L

Cleaning Essentials Tools + Help «

Results

Threat Mame Operations

=] E:\Downloaded Files'Delete¥olume.zip Clean
L‘j Malware@#3ilzv3kedlog3
L E:\Downloaded Files\DeleteVolume, zip| Deletevaolur. ..
=] Malware@#33iwbvbgyzmoq
loaded Files)gi

=] Exploit@#2975xfk8s2pql Ignore
Clean

Repott
E:\Downloaded Filles)eicarcom2eicar_carmieicar.com Clean

=] Malware@#2Z 7sBewoxds1vr

L E:\Downloaded Fillesieicarcom2eicar_com. zip Clean
-I|Malware@# 3ilzv3kedlbg3

L E:'\Downloaded FilesiDeleteVolume\DeleteVolume. exe Clean

I: E:'\Downloaded Filesheicar_com’eicar.com

=] E:\Downloaded Files' eicarcom2.zip Clean
Lo Malware@#27sBewoxds1vr

217700470

- Toclean a threat, click on the entry under the Operations column and select 'Clean’. The file will be
disinfected or moved to quarantine upon applying the operation. You can later remove the file from your
system from the 'Quarantined Items' interface. Refer to Managing Quarantined ltems for more details.

« Toignore a threat if you consider the file is safe, click on the entry under the Operations column and select
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'Ignore’.

- Toreport threat as a false-positive result, click on the entry under the Operations column and select 'Report'.
The file will be sent to Comodo. Experts in Comodo will analyze the file and add it to whitelist, if found safe.

- To apply a common operation to all the entries in the list, click on the Operations column header and select
the required action.

COMODO L

Cleaning Essentials Toolz + Help

Results

Threat Marme Operations -
H E:\Downloaded Files', Delete¥olume.zip Ignare Al
—|Malware@#3ilzv3kedleg3
L E:\Downloaded Files\DeleteVolume, zip| Deletevaolur. .. Report 4l
=] Malware@#33iwbvbgyzmoq
L E:\Downloaded Filesieicar.com
|- Exploit@#£297 5afk8s2pql
I: E:'\Downloaded Fileseicar_com’eicar.com
E:\Downloaded Filles)eicarcom2eicar_carmieicar.com
=] Malware@#2 7sBewoxds1vr
L E:\Downloaded Filesieicarcomz'eicar_com.zip
-]|Malware@# ilzv3kedleg3
L E:'\Downloaded FilesiDeleteVolume\Deleteolume. exe
-] E:\Downloaded Files' eicarcom2.zip
Lo Malware@#27sBewoxds1vr

22217700170

6. Click 'Apply' to apply the selected operations to the threats. The selected operations will be applied.
COMODO =

Cleaning Essentials Tools + Help «

Apply Operations

4043

0000

If you have chosen at least anyone of the scan options from:

e Memory;

»  Critical areas and Boot Sector;

- Hidden registry objects and Services;
»  Hidden files and folders.

your system will restart to check whether the operations are applied correctly and start scanning your system for hidden
services and drivers.
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COMODO Cleaning Essentials(26)

Your computer will now be restarted in order to verify that all selected
threats are cleaned, and continue ko scan for hidden services,

Yes | | MNa

The restart dialog window will start a count down from 30 and if you do not choose either 'Yes' or 'No' option, the system will
automatically restart when the count down reaches 0.
«  Click 'Yes' to restart your computer.

« Ifyou plan to apply the operations at a later time, click No. The clean operations will be checked and scan
for hidden services will be resumed on the next restart of the computer.

Your system will restart to check whether the operations are applied correctly and start scanning your system for hidden
services and drivers.

cCOMODO

Cleaning Essentials

Analyzing...

10 000000000040 4
Chagystern Yolume Informationi_restore{SBAADC C4-5534-42B5-94A40-01 4FATATTD RS}

\RP12A0001837.data

The results will be displayed.
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cOMODO

Cleaning Essentials

Threat Mame | Operation

=] Malware@#33iwbvbgyzmoq o -
L E:\Dowrloaded Filesteicar.com Clean

|=] Exploit@#2975xfk8s2pql o -
I: E:\Downloaded Files)eicar_comieicar.com Clean

E:\Downloaded Fillesieicarcom2eicar_comieicar... Clean
|=|Malware@#Z27s8ewords1vr o -
L E:\Downloaded Filesieicarcom2eicar_cam. zip Ignore
= Malware@#3ilzvy3kedlog3 o -
L E:\Downloaded FillesiDeleteVolumeiDeletetaluni... Ignore
|=] ApplicUnwnt@#347d2s3h2ul74
L E:\Downloaded Filesi Jumper| Jumperijunper. exe  Ignore
|=] ApplicUnwnt@#35ue Smwcsmjuh i
L E:\Dowrloaded Files\PCFlankiPCFlankipeflank.dl... Ignare
|=) ApplicUnwnt@#2618c 74ekkfgd ]
L E:\Downrloaded Files\Spycar_tests\HKCU_Run.exe Ignare
-1 ApplicUnwnti@# 1 7al6i7icikdo

217700170

Instantly Scan Folder or File

You can scan a folder or file you just downloaded from Internet / copied in to your system of items in a removable storage device
like a pen drive by dragging and dropping it on to the CCE interface.

To instantly scan an item

Drag the item from its parent folder and drop it on to the CCE Interface
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cuckoo music converter

File -~ Edit - “Miew - Favorites - Tools: - Help :ﬁ.

eBack - .\_J ‘L'_@ pSEarch EE*_'L Folders '

address | C:\Documents and Settings JDh Smith\My DocumentstDownloadsh cuckoo music converter . G0

j Al
Folders read me
@ Deskiop cuckoo_converter Text Dacument

20 kB
= @ My Documents
= 153 Downloads

29 cuckon music COMOD0

= My Music Cleaning Essentiz's
| f] Iy Pictures
# 1§ My Computer Start Scan
& Mg My Mebwork Places

Recycle Bin

Smart Scan Full Scan Custom

The folder/file will be scanned immediately.
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cCOMODO =

Cleaning Essentials Tool: + Help w

Scan Finished

(%) Object(s) Scanned: (O start Time: 1052012 2:39:02 PM

4# Threat(s) Found: n 2 Duration: 00:00:01

DETE e S Finish

23219500176

If any threats are found, the results will be displayed. Refer to The Results section for more details.

2.4.Comparison of Scan Types

Scanners
The following table gives the descriptions of scanners used in Comodo Cleaning Essentials:

Scanner Description

Basic Local Antivirus Scanner

FLS File Lookup System. The FLS attempts to establish the trustworthiness of a file by running three
sequential scans. First, a file is checked against the local Trusted Vendors List (TVL). If the file is not
present on the TVL then it passes onto Cloud Vendor Verification (CVV). If the CVV test yields no results it
passes onto Comodo’s cloud based AV scanner.

CAMAS Upload untrusted executables to COMODO Automated Malware Analysis System (CAMAS) for inspection
(available if enabled in Options)

Memory Scans running processes and modules

Hidden file Scan for hidden files and directories

Hidden key Scan for hidden keys and values

Hidden service Scan for hidden services and drivers (requires restart)

Critical areas Scan critical registry keys, system files and system configuration
MBR Scan boot sector (Available if enabled in Options)

Scan Types

The following table gives the sequence of scanners employed while scanning various areas for different scan types. The symbol
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*> ‘indicates a sequential process. For example, ‘Basic > FLS’ means that the item is first checked using the Basic (local) AV
scanner. Only if the file is not identified as malware by the Basic scan will the item pass onto the next type of scan — ‘FLS'.

Scan Options Smart Scan Full Scan Custom Scan

(Scanners are the same as Full Scan)

Memory Basic>FLS Basic>FLS>CAMAS>Memory|Optional. Scope: all running modules
Scope: all running modules Scope: all running modules

Critical areas and Critical areas>MBR Critical areas>MBR Optional. Scope: entire areas

boot sector Scope: entire areas Scope: entire areas

Hidden registry Hidden key>Hidden service Hidden key>Hidden service |Optional. Scope: entire registry

objects and Services | geqne: autorun registry entries |Scope: entire registry

Hidden files and Hidden file Hidden file Optional. Scope: files in all drives

folders Scope: autorun files Scope: files in all drives

Virus Basic>FLS Basic>FLS Optional. Scope: Customizable
Scope: autorun files Scope: files in all drives

3.Configuring Comodo Cleaning
Essentials

CCE can be configured according to user preferences by clicking the 'Options' from the title bar. You can manage various
functions such as scanning suspicious MBR entries, connection to CAMAS (Comodo Automated Malware Analysis System) for
submitting suspicious files and more.

To access the Options interface, click 'Options' from the title bar controls.

Comodo Cleaning Essentials User Guide | © 2012 Comodo Security Solutions Inc. | Al rights reserved 32



COMODO

Creating Trust Online®

=

x

coOMODO -

Cleaning Essentials Cptionz  Toolz + Help «

Start Scan

(L e

O (1 e

Options

~MER. Scanner -
[C] 5can Far suspicious MBR modifications

[C] report all MER maodifications

. =

~Wirus Scanmer -

[[] Release any kernel hooks before the scan

Heuristics Scanning Level Lo -
Do not scan files larger than 40 ME
~CAMAS .

[#] Scan unknown processes in memary with CAMAS

CAMAS timeout 300 Secondis)

~Setkings -

[[] Create a Windows restare paint before performing the scan

Log Level all -

Language Default - English {United Stat -«

. -

(a4 ] [ Cancel

MBR Options

«  Scan for suspicious MBR modifications - When selected, CCE will automatically scan MBR (master boot record)
for unknown or suspicious changes made to it.

«  Report all MBR modifications - When selected, CCE will record MBR modifications, if any, in the log file.

Virus Scanner Settings

« Release any kernel hooks before the scan - When selected, hooked kernel hooks will be released before any
scanning process. This option is for advanced users only. Unhooking kernel hooks will deactivate any other security
products installed in your system and may impair the stability of your system and/or can incur permanent data loss.
Select this option only if you are an advanced user and have knowledge on the risks of the process.

»  Heuristics Scanning/Level - CCE employs various heuristic techniques to identify previously unknown viruses and
Trojan horses. 'Heuristics' describes the method of analyzing the code of a file to ascertain whether it contains code
typical of a virus. If it is found to do so then the application recommends it for quarantine. Heuristics is about detecting
virus-like behavior or attributes rather than looking for a precise virus signature that matches a signature on the virus
blacklist.

This is a quantum leap in the battle against malicious scripts and programs as it allows the scan engine to 'predict' the
existence of new viruses - even if it is not contained in the current virus database.

The drop-down menu allows you to select the level of Heuristic scanning from the four levels:

«  Off - Selecting this option disables heuristic scanning. This means that virus scans only uses the 'traditional'
virus signature database to determine whether a file is malicious or not.
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«  Low - 'Lowest' sensitivity to detecting unknown threats but will also generate the fewest false positives. This
setting combines an extremely high level of security and protection with a low rate of false positives.
Comodo recommends this setting for most users.

«  Medium - Detects unknown threats with greater sensitivity than the 'Low' setting but with a corresponding
rise in the possibility of false positives.

«  High - Highest sensitivity to detecting unknown threats but this also raises the possibility of more false
positives too.

» Do not scan files larger than - This box allows you to set a maximum size (in MB) for the individual files to be
scanned during manual scanning. Files larger than the size specified here, are not scanned. Default = 40 MB

CAMAS Settings

CAMAS - CAMAS (Comodo Automated Malware Analysis System) is a cloud based analysis system where the submitted files
will undergo a thorough inspection by our cloud virus scanning and behavior monitoring systems to try to establish whether they
contain malicious code. If the file exhibits malicious behavior, it will be added to the global blacklist. Once the global lists have
been updated, any other users that have the same file on their machines will receive an almost instant verdict as to the files
safety.

«  Scan unknown processes in memory with CAMAS - When this check box is selected, any unknown process or
processes in memory will be automatically submitted to CAMAS.

- CAMAS timeout - This box allows you to set the time (in seconds) for which the files will be submitted to CAMAS. If
the timeout is exceeded then CCE will stop attempting to contact the CAMAS servers and it is possible that no result
will be returned to you.

Miscellaneous Settings

«  Create a Windows restore point before performing the scan - When selected, CCE will create a Windows restore
point before embarking on the scanning process. Should problems occur after wards, you will be able to restore your
system to the state just before your started the scan.

«  Log level - This drop down box allows you to select options for CCE event logs. There are two main types of log file -
KillSwitch logs and CCE (scan) logs . The following options apply to both types of log:
- Disable - If you select this option, CCE will not create any log files.

- Threats - If this option is selected, CCE will generate log reports containing files that it has detected as
threats.

«  All - If this option is selected, CCE will generate log reports for all files that it have been scanned and will
record all events. The log file will contain system information, cleanup results, details about the file path,
whether it is malicious, the action taken and whether the action has been implemented.

Logs are saved in the folder <folder containing CCE files>\Data\CCE\Logs:
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To view the logs:

«  Double-click or right click and open the Logs folder. The folder will contain logs stored as time stamped text
files.

Or
»  Click Tools > Browse Logs...

Select Language- CCE is available in several languages and the default language is English (US). If you want to
change the language, select your language from the drop-down menu.

»  Click 'OK" for the settings to take effect .

4. The Tools Menu

The "Tools' menu enables you to manage quarantined items and local trusted vendors list and view logs. It also

allows you to configure for importing virus database updates from a local storage or from other computer or a server
in your network.

The tools menu contains shortcuts to open KillSwitch and Autorun Analyzer, valuable tools for optimizing your system
performance.

The tools menu can be accessed by clicking "Tools' from the title bar.
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Cleaning Essentials Options  Tools + Help +

Cuarantined Ikems. ..
Start Scan Manage Trusted Vendars. ..

Start & scan to unearth and remowve viruses, rootkits, hidden files and malicious registry  Import Vires Database
hidden deep within your system.
Browse Logs,..

Check For Updates. ..

Cpen Killswitch
Cpen Aukorun Analyzer

Smart Scan Full Scan Custom Scan

19500176

The "Tools' menu has the following options:
«  Managing Quarantined Items - Enables to manage the items moved to quarantine by various scans.
«  Managing Trusted Vendors - Enables you to add and manage the vendors in the local Trusted Vendor List
- Importing Antivirus Database - Enables you to import virus database from your local storage or a network location.
+  Browse Logs - Enables you to view the log of events recorded by the application.
«  Checking for Updates — Enables you to check whether updated version of the application is available.
«  Open KillSwitch - Starts the KillSwitch utility

«  Open Autorun Analyzer - Starts the Autorun Analyzer utility.

4.1.Managing Quarantined Iltems

The quarantine facility removes and isolates suspicious files into a safe location before analyzing them for possible infection.
Any files transferred in this fashion are encrypted- meaning they cannot be run or executed. This isolation prevents infected files
from affecting the rest of your PC. If a file cannot be disinfected, then it provides a reliable safe-house until the virus database is
updated- neutralizing the impact of any new virus.

All the files cleaned using CCE are moved into Quarantine. You can later analyze these files and take the following measures:
« Ifthe file could not be identified by you as safe, you can remove it from your system;
« Ifthefile is safe and came from a trustworthy source, you can restore it to the original location.

To access the 'Quarantined ltems' interface, Click "Tools' > '‘Quarantined Items'.
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Item Location Dake) Time

ApplicUrwnb@# 1 7oziz148%i82z i Svstem Waolume Information.,. 01 Dec 11 12:11
TROJAMNSIM, ~B@ 18027535 E:lwirus samples) TrojanSimulat, ., 01 Dec 11 12:11

Exploit@#z975xfkas2pal E:\Downloaded Files\eicarcom.,, 01 Dec 11 17:00

Exploit@#z975xfkaszpgl E:\Downloaded Files\eicar_co,., 01 Dec 11 17:00
ApplicUnwnt@#30k20t53p8215  C:\System Yolume Information, .. 01 Dec 11 12:11 Clear Al
ApplicUrwnb@# 3bkz0r53pS215 i Syskemn Wolume Information.,. 01 Dec 11 12:11
Malware@#33iwbvboyemog E:\Downloaded Files\eicar.com 01 Dec 11 17:00
ApplicUrwnb@# 1 7oziz148%i8z - CSyskem Yolume Information.,. 01 Dec 11 12:11
ApplicUnwnb@# L 7ozjz145%i8z  CDocuments and Settingstad,,, 01 Dec 11 12:11
ApplicUrwnb@a#3bk20r53pa215  CHiDocuments and Settingstad,., 01 Dec 11 12:11

Close

Column Descriptions

« ltem - Indicates which application or process propagated the event;
«  Location - Indicates the location where the application or the file is stored;
«  DatelTime - Indicates date and time, when the item is moved to quarantine.

From this interface you can:

»  Delete a selected quarantined item from the system
*  Restore a quarantined item
+  Delete all quarantined items

To delete a quarantined item from the system
»  Select the item and Click 'Delete’.
This deletes the file from your system permanently.
To restore a quarantined item to its original location

«  Select the item and click 'Restore".

If the restored item does not contain a malware, it operates as usual. But if it contains a malware, it will be detected as a threat ,
during the next scan and moved to quarantine if you perform 'Clean’ operation.

To remove all the quarantined items permanently

«  Click 'Clear All'.
This deletes all the quarantined items from your system permanently.

Note: Quarantined files are stored using a special format and do not constitute any danger to your computer.
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4.2.Managing Trusted Vendors

In Comodo Cleaning Essentials, there are two basic methods in which an application can be treated as safe. Either it has to be
part of the 'Safe List' (of executables/software that is known to be safe) OR that application has to be signed by one of the
vendors in the 'Trusted Software Vendor List'.

From this point:
« |F the vendor is on the 'Trusted Software Vendor' List, the application will be trusted and allowed to run.

Software publishers may be interested to know that they can have their signatures added, free of charge, to the 'master' Trusted
Software Vendor List that ships to all users with CCE. Details about this can be found at the foot of this page.

To access the 'Trusted Software Vendors' interface, Click "Tools' > 'Manage Trusted Vendors'.

Trusted Software Yendors o x
Wendaors (Signer Mame in the Cade Signing Certificake) |DeFined By | 3 ddd
0823706 B.C. LTD COMODO £
OInfinita s.r.l. COMODo
1 &1 Internet Ltd COMODO
1 mal 1 Software GmbH COMODO
1 mal 1 Software GmbH - Flatcast COMODO
1und 1 Internet AG COMODS
1&1 Inkternet A COMODO
121 Mail & Media GmbH COMODO
10inG Inc. COMODO
11com? design & media GmbH COMODO
1234 MicroTechnologies Inc. COMOD0
128 Consulking COMOD0
12izhosks AG COMODo
1ZGhosts Inc. COMODO
12Pay Ltd COMODo
15 Million Elephants, L3C COMOD0
170 Systems, Inc, COMODO
¥ Maotes Music Company IISER. -

Column Descriptions
«  Vendors -1 The vendor that has signed the software;

»  Defined By - Indicates whether the vendor was added to Trusted Software Vendor List by Comodo (as the
vendor is globally whitelisted) or by the user.

»  Click here to read background information on digitally signing software
«  Click here to learn how to Add / Define a user-trusted vendor

- Software Vendors - click here to find out about getting your software added to the list

Background

Many software vendors digitally sign their software with a code signing certificate. This practice helps end-users to verify:
i. Content Source: The software they are downloading and are about to install really comes from the publisher that
signed it.

ii. Content Integrity: That the software they are downloading and are about to install has not be modified or
corrupted since it was signed.

In short, users benefit if software is digitally signed because they know who published the software and that the code hasn't
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been tampered with - that are are downloading and installing the genuine software.

The 'Vendors' that digitally sign the software to attest to it's probity are the software publishers. These are the company names
you see listed in the first column in the graphic above.

However, companies can't just 'sign' their own software and expect it to be trusted. This is why each code signing certificate is
counter-signed by an organization called a "Trusted Certificate Authority'. 'Comodo CA Limited' and 'Verisign' are two examples
of a Trusted CA's and are authorized to counter-sign 3rd party software. This counter-signature is critical to the trust process and
a Trusted CA only counter-signs a vendor's certificate after it has conducted detailed checks that the vendor is a legitimate
company.

If a file is signed by a Trusted Software Vendor and the user has enabled 'Trust Applications that are digitally signed by Trusted
Software Vendors' then it will be automatically trusted by CCE (if you would like to read more about code signing certificates,
see http:/lwww.instantssl.com/code-signing/).

One way of telling whether an executable file has been digitally signed is checking the properties of the .exe file in question. For
example, the main program executable for CCE is called 'cce.exe’ and has been digitally signed.

»  Browse to the (default) installation directory of Comodo Cleaning Essentials.

»  Right click on the file cce.exe.

«  Select 'Properties' from the menu.

«  Click the tab 'Digital Signatures (if there is no such tab then the software has not been signed).
This displays the name of the CA that signed the software as shown below:

CCE Properties

| General | Yersion | Eu:umpatibilit_l,l| Digital Signatures | Summary |

Signature lizt

M arme aof signer: E-mail address: Timestamp

Comodo Securty ... Mot available Tuesday, Hovember ...

Dretailz

Click the 'Details' button to view digital signature information. Click 'View Certificate' to inspect the actual code signing certificate.
(see below).
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Digital Signature Details | § Certificate
General | advanced eneral | Details | Certification Path |
Digital Signature Information
This digital signature is Ok, D a am——

This certificate is intended for the following purpose(s):

Signer information ”
*Ensures software came from software publisher

Name: |Comodo Security Solutions, Inc, +Protects software From alberation after publication
E-mail: [miat available
Signing time: [Tuesday, Movember 23, 2011 8:15:03 AM

* Refer to the certification authority's statement For details,

Wiew Certificate }
Issued to: Comodo Security Solutions, Inc,
Zountersignatures
Issued by: UTN-USERFirst-Object
Mame of signer: E-mail address: Timestamp
COMODO Time 5... Mok available Tuesday, Mavemnber ...
valid from 4/3/2009 to 4/3/z2012
[Install Certificate...] [ Issuer Statement l

It should be noted that the example above is a special case in that Comodo, as creator of 'cce.exe’, is both the signer of the
software and, as a trusted CA, it is also the counter-signer (see the 'Countersignatures' box). In the vast majority of cases, the
signer or the certificate (the vendor) and the counter-signer (the Trusted CA) are different. See this example for more details.

Adding and Defining a User-Trusted Vendor

A software vendor can be added to the local ‘Trusted Software Vendors' list by reading the vendor's signature from an
executable file on your local drive.

Read from a signed executable, .,

Click the add button on the right hand side and select 'Read from a signed executable.... Browse to the location of the
executable your local drive. In the example below, we are adding the executable 'YahooMessenger.exe'.
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Look in: | = Messenger w | @ ?’ - v
T [J)cache @intl L’-ﬂ yacsui,dll L’-ﬂ YPagerChecks
L%é [logs L)":'] kdu_w32R.dll =Y ahooMessenger L)":'] ypagerps.dll
My Fecent [CMedia L“?ﬂ libexpat, dil L“?-ﬂ yalertcentert, dll L“?-ﬂ YPluginR.egisti
Documents  |[Z3)Profiles login | %) vPFoundation. di ystats_B
== [Ciresources | =] modules L“lﬂ YCPSSL.dI L“lﬂ wui.dll
@ [hskins L.J‘f'] nsprd . dil Lﬂ YHTTP.dIl Lﬂ ycupl, dil
Desktop avthost |%] Photashare.dl | %] ¥Image.di %] rwacvver il
i__{ﬂ core_video.dll Pluginkey_pub.pem L.)i'] YIniDorm.dll
. i | default [Z)rEe.di [Z) vlog.di
'—} filker1.enc |2 rmc_audio.dll |2 yrndm_audio.di
™ | FIFl_bg | %] prnc_wideo. dil |2 wrndrn_video. dll
My Ddcuments éftﬁn.dll sb éml.du
1@generic_messenger é sh L’-ﬂ ymsdhk, dil
Q'! %] idalb. i Sdunwise 1] ymsglite. dl
. I% INSTALL L’-ﬂ yacscom, dil E‘.’msgr_tra'y'
ky Computer
s | .
‘g File name: |Yahu:u:uM gzsenger V| [ Open l
My Metwork,  Files of lype: &l Files 7.7 v| [ cancel |
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After clicking 'Open’, CCE checks that the .exe file is signed by the vendor and counter-signed by a Trusted CA. If so, the vendor
(software signer) is added to the Trusted Veendor list (TVL):

E|E| Trusted Software Yendors

Digital Signature Details

General | Advanced | Yendors {Signer Mame in the Code Signing Certificate) Defined By
|- Digital Signature Information xs0; xBase Sofbware Onbwikkeling COMoDO
| This digital signature is 0K, *Solutions Consulting Services LLC COMODO

XTAC Limited COMODD
. . i ¥-tech Data Syskems, Inc, COMODD

Signer infFormation
XTempo Software COMoDO
Mame: [ahoot Tnc. wtehets LLC COMODD
E-mail: |Nc-t o xTrader Platform COMODO
¥tralex Syskems Py Lbd COMODD
Signing time: |Wednesday, August 19, PEND 6:57:03 Ak ¥tranormal Technology Inc COMODO
Xtreeme GmbH COMoDO
¥treme Deskkops, LLC COMODD
¥vid Jolutions GbH COMOD0
Countersignatures xwebznetiowebz COMoDO
- - - AN ¥-YWire Technology COMODO
Mame of signer: E-mail address: Timestamp \ Wytis Softwiare (Australia) Pry Lbd COMODO
VeriSign Time St... Mot available wednesday, August ... jl $ytech Systems Corporation COMODO
Y an Corporakion COMOD

( ‘ahoo! Inc, )] IISER
il

In the example above, CCE was able to verify and trust the vendor signature on YahooMessenger.exe because it had been
counter-signed by the trusted CA 'Verisign'. The software signer 'Yahoo! Inc." is now a Trusted Software Vendor and is added to
the list. All future software that is signed by the vendor "Yahoo! Inc." is automatically added to the Comodo Trusted Vendor list.

The Trusted Vendor Program for Software Developers

Software vendors can have their software added to the default Trusted Vendor List that is shipped with CCE. This service is free
of cost and is also open to vendors that have used code signing certificates from any Certificate Authority. Upon adding the
software to the Trusted Vendor list, CCE automatically trusts the software and does not generate any warnings or alerts on
installation or use of the software.

The vendors have to apply for inclusion in the Trusted Vendors list through the sign-up form at
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http://internetsecurity.comodo.com/trustedvendor/signup.php and make sure that the software can be downloaded by our
technicians. Our technicians check whether:

»  The software is signed with a valid code signing certificate from a trusted CA;
»  The software does not contain any threats that harm a user's PC.
before adding it to the default Trusted Vendor list of the next release of CCE.

More details are available at http://internetsecurity.comodo.com/trustedvendor/overview.php.

4.3.Importing Antivirus Database

CCE is configured to periodically check Comodo servers to see whether a virus database update is available for download.

As an alternative to downloading from Comodo servers, you can import the virus database updates from local storage or from
any of the other computers in your network that uses the same database. This can help accelerate update deployment across
large networks of endpoints and reduce the bandwidth consumption.

Example Scenarios:

- Ifyou also have Comodo Internet Security (CIS) installed and it is configured to regularly receive database updates
then you can configure CCE to collect it’s updates from your CIS folder. To do this, you just need to point CCE to the
CIS folder that contains the (updated) bases.cav file. See instructions below.

- Similarly, if you are connected to a local network, you can import the updated database from any network folder that
contains the latest bases.cav (for example, from another computer that has a (fully updated) CCE or CIS installed)).

To import virus database

«  Click Tools > Import Virus Database.

cCOMODO

Cleaning Essentials

l:::lrjtiljn:z: Toalzs + ] -

Quarantined Ikems...
Start Scan Manage Trusted Yendors. ..
Start a scan to unearth and remowve viruses, rootkits, hidden files and malicious registn T e RN N BE &t
hidden deep within your system.

Browse Logs...
Check for Updates. ..

Open KillSwitch
Open Autarun Analyzer

The Windows Open dialog will open.
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Lok ir | I scanners hd | QO F &
Ty ( EI bases.cav smark,cav
ﬁ Eramre cay unarch.cay
My Fecent dosmnz. cav unpack. cay
Documents dunpack.cav white, cav
= exkra.cav
| L§ Fileid.cav
Desktop gunpack,cay
heur,cav
o MME ., Cay
’_j pe3s.cav
My Documents -
sCripk. cav
: scrkemu, cav
iy Cornputer
File name: | A | [ Open ]
- .
g Files of type: | Cav Databaze [".cav] b | [ Cancel ]
My N-etlwu:urk []Open as read-only

«  Navigate to the folder containing the virus database file like bases.cav and select the file

Tip: If you are importing the database from your CIS installation, the bases.cav will be available in the folder <installation
drive>:\Program Files\COMODO\COMODO Internet Security\scanners.

«  Click 'Open'.
The database file will be immediately imported to CCE.

4.4.Checking for Software Updates

CCE is configured for automatic periodic checking of availability of updated version of the software. If an updated version is
available you will be prompted to download the new version.
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COMODO cleaning Essentials

Check for Updates

A newer version is available.

The updater checks for updates using Internet Explorer's
connection settings.

Download Close

«  Clicking 'Download" will launch your default browser to download the latest version.
You can manually check whether any updates are available from the Tools menu of the application.
To manually check for the software updates
e Click '"Tools' > 'Check for Updates'
COMODO

Cleaning Essentials Options Toals +  Help =

Quarantined Ikems. ..
Start Scan Manage Trusted Yendors. ..

Start a scan to unearth and remowve wiruses, rootkits, hidden files and malicious registny  Import Wirus Database
hidden deep within your system.

Browse Logs...,

Check for Updates. ..

Open KillSwitch
Qpen Autarun Analyzer

The application will connect to Comodo servers and check for the availability of updates.
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COMODO cleaning Essentials
Check for Updates

Checking for updates, please wait...

The updater checks for updates using Internet Explorer's
connection settings.

« Ifany updates are available, you will be prompted to download the latest version.

COMODO Cleaning Essentials
Check for Updates

A newer version is available.

The updater checks for updates using Internet Explorer's
connection settings.

Download Close

»  Clicking 'Download" will launch your default browser to download the latest version.
«  If no updates are available, you will be notified on that.

cCOMODO
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COMODO cleaning Essentials

Check for Updates
Your product is currently up-to-date.

The updater checks for updates using Internet Explorer's
connection settings.

5.Introduction to KillSwitch

KillSwitch is an advanced system monitoring tool that allows users to quickly identify, monitor and terminate any
unsafe processes that are running on their system. Apart from offering unparalleled insight and control over computer
processes, KillSwitch provides you with yet another powerful layer of protection for Windows computers.

The unsafe processes addressed by KillSwitch are often triggered by malware that has been introduced onto your system.
These harmful programs can gain entry onto your system in many different ways. For example, you may encounter malware by
visiting a malicious website, by double clicking an attachment in a unsolicited e-mail message or on clicking on a deceptive pop-
up window. Once installed, most malware will embed itself into your system as a resident program then attempt to initiate an
attack. These attacks can take a variety of forms and include operating system exploits and scripts that could turn your computer
into a zombie PC or allow the easy theft of your private data. Worst still, many of these processes are so well hidden they are
completely invisible to the average user. This is where KillSwitch comes in.

KillSwitch can show ALL running processes - exposing even those that were invisible or very deeply hidden. It allows you to
identify which of those running processes are unsafe and to shut them all down with a single click. You can also use KillSwitch to
trace back to the malware that generated the process.

When started in aggressive mode, KillSwitch forcibly terminates all the running applications and processes created by currently
logged-in user and enables the user to analyze the processes that were invoked automatically, in order to identify the harmful
processes invoked by malware and hence to identify the malware.

The KillSwitch section of this guide is broken down into the following sections:
« Introduction to KillSwitch
- Starting KillSwitch
«  The Main Interface
- Viewing and Handling Processes, Applications and Services
«  Processes
- Stopping, Starting and Handling the Processes
«  Viewing Properties of a Process
«  Applications
« Handling the Applications
«  Services
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»  Stopping, Starting and Deleting the Services
- Viewing and Handling Network Connections and Usage
*  Network Connections
» Inspecting and Closing Network Connections
»  Network Utilization
«  Configuring KillSwitch
+  KillSwitch Tools
«  Viewing System Information
«  Repairing Windows Settings and Features
«  Analyzing Program Usage
«  Searching for Handles or DLLs
«  Verifying Authenticity of Applications
«  Boot Logging and Handling Loaded Modules
*  Running Programs from Command Line Interface
«  Viewing KillSwitch Logs
»  Finding Process of the Active Window
«  Managing Currently Logged-in Users

*  Help and About Details

5.1. Starting KillSwitch

KillSwitch can be started by the following ways:
«  From the Comodo Cleaning Essentials interface
«  From the folder containing Comodo Cleaning Essentials files

« By replacing Windows Task Manager with KillSwitch

5.1.1. From the Comodo Cleaning Essentials Interface

»  Click Tools > Open KillSwitch from the title bar controls of the main interface of Comodo Cleaning Essentials.

- To open KillSwitch in aggressive mode, press and hold 'Shift' key and click Tools > Open KillSwitch

cCOMODO =l =

Cleaning Essentials Options  Tools = Help «

Doarantined Ikems, ..
Start Scan Manage Trusted Yendors. ..

Start 3 scan to unearth and remove viruses, rootkits, hidden files and malicious registy]  Impart Yirus Database
hidden deep within your system.

Erowse Logs...

Cpen KillZwitch

Open Autorun Analyzer

The KillSwitch main interface will be opened.
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5.1.2. From the Folder Containing Comodo Cleaning Essentials Files

«  Navigate to the folder containing the Comodo Cleaning Essentials files
«  Double click on the file 'KillSwitch.exe' from the Windows Explorer window.

«  Toopen KillSwitch in aggressive mode, press and hold 'Shift' key and double click on the file 'KillSwitch.exe'".

File  Edit  Miew  Faworites  Tools  Help
B 5 A -
@ Back - &/ L@ 7 ! Search [1_- Folders '
Address \[Fi': Cilece_2.2.217700,170_x324CCE 3 ‘ o
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The KillSwitch main interface will be opened.

5.1.3. Replacing Windows Task Manager with KillSwitch
KillSwitch can be configured to replace Windows Task Manager. Doing so will mean that KillSwitch can be opened by:
e Pressing Ctrl + Alt + Del and clicking Task Manager;
«  Right-clicking on the Task Bar and selecting 'Task Manager' from the pop-up menu;
»  Pressing Ctrl + Shift + Esc;
»  Clicking 'Start' > 'Run’ and typing the command 'taskmgr'.

»  Pressing holding the 'Shift' key while opening KillSwitch in any of the above said methods will open KillSwitch in
aggressive mode.

To replace Task Manager with KillSwitch, you first need to start the application by one of the methods explained above, click
'Options' from the title bar and enable 'Replace Task Manager'.
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For more details, refer to the description of 'Replace Task Manager with KillSwitch' in the section 'Configuring KillSwitch'.

5.2.The Main Interface

KillSwitch's streamlined interface provides access to all important features and options of the application at finger tips.

= COMODO KillSwitch

File Menu bar | B ETEE

Tab Structure
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and version information

The interface is divided into six main areas:
*  The File Menu bar;
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»  Tab Structure;

« Main display Pane;

«  Graphical Reports Pane;
+ Tool Bar,

- Status Bar.

The File Menu Bar

The file menu bar displays the controls for executing various tasks and configuring the overall behavior of the application.
Menu Option Description

KillSwitch Contains options related to handling unsafe processes, saving current
state and switching power state of your system.

Kill All Unsafe Processes Stops all the currently running processes that are identified as unsafe by
KillSwitch.

Note: By stopping a running process you will lose any unsaved data
being used by the application that generated the process. Save data in
all running applications before selecting this option.

Suspend All Unsafe Process Temporarily halts all the currently running processes that are identified
as unsafe by KillSwitch in their current states. Suspended processes
can be resumed by right clicking on the process in the process tab and
selecting 'Resume’ from the context sensitive menu.

Save Current View Opens the 'Save as' dialog to save the currently displayed list in the
main display area as a .csv file.

Save Opens the 'Save as' dialog to save the data in all display panes as a
.csv file.

Shutdown Enables you to switch the power state of your computer. Hovering the
mouse cursor options opens a sub-menu containing the following
options:

e Shutdown;
*  Power-off;
e Restart;

- Sleep;

»  Hibernate;
e Lock;

e Log-off;

Exit Closes the KillSwitch application.

Options Contains 'Options' that enable you to configure the overall behavior of
the application. Refer to the section 'Configuring KillSwitch' for more
details.

View Contains options related to display nature of the application.

System Information Opens the System Information panel that shows the graphical

representations and statistics of the usage/history of your system
resources. Refer to the section 'Viewing System Information' for more
details.

Show Only the Unsafe Images in Displays only the program images identified as unsafe by KillSwitch
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Memory

currently loaded to system memory in the main display area.

Hide Safe Processes

Displays only the items identified as unsafe by KillSwitch in the main
display area, relevant to the tab selected. This is useful to identify the
unsafe objects just at-a-glance.

Opacity

Enables you to set the transparency of KillSwitch window. The choices
range from 10% to full opaque, in the intervals of 10.

Refresh Now

Updates and refreshes the KillSwitch window.

Update Speed

Enables you to set the interval at which KillSwitch automatically
refreshes itself and updates the details in the main display area. The
choices range from fast (0.5 seconds) to Very Slow (10 seconds)

Update Automatically

KillSwitch automatically refreshes and updates the details displayed in
the main display area only if this option is selected. If you want to view
the details fetched at a specific moment and wish to keep it without
updates for some time e.g. for analysis purposes, you can temporarily
disable this option.

Performance Graphs

Switches the display of the performance graphs at the right hand side
of the main interface.

Toolbar

Switches the display of the tool bar containing shortcuts to utilities at the
bottom of the interface.

Select Columns

Opens Select Columns interface that enables you to configure the
columns to be displayed in different screens of KillSwitch. Refer to the
section 'Column Selection' for more details.

Tools

Contains shortcuts for important utilities and options for handling
processes, objects and dll files collectively, shortcuts for running
command line interface programs and so on. Refer to the section 'The
Tools Menu' for more details.

Autorun Analyzer

Opens the Autorun Analyzer utility to view and handle services and
programs that were loaded when your system booted-up.

Quick Repair

Opens the 'Quick Repair' interface to troubleshoot and and repair
important Windows settings and features. Refer to Repairing Windows
Settings and Features for more details.

Program Usage Analyzer

Open the 'Program Usage Analyzer' window that displays a summary of
usage of all the programs installed in your computer by different users.
Refer to Analyzing Program Usage for more details.

Find Handles or DLLs

Opens a 'Filter' dialog that enables you to make a quick search to
identify the Handles, DLLS that are triggered or loaded to system
memory or mapped files , by entering the name of the object. Refer to
the section Searching for Handles or DLLs for more details.

Verify File Signature

Enables you to check whether applications/programs installed and files
stored in your system are trusted and digitally signed to confirm the
authenticity of them. Refer to 'Verifying Authenticity of Applications'
for more details.

Enable Boot Logging Instructs KillSwitch to log all modules loaded from next boot onwards
and show them in its window automatically. Refer to Boot Logging and
Handling Loaded Modules for more details.

Run Opens the Windows 'Run’ dialog for executing command line interface

programs with default limited user privileges. Refer to Running
Programs from Command Line Interface for more details.
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Run as Administrator Opens the Windows 'Run’ dialog for executing command line interface
programs with administrative privileges.

Browse Logs Open the KillSwitch logs saved in Data\KillSwitch\KS Logs sub- folder
inside the folder that contains the CCE files. Refer to Viewing
KillSwitch Logs for more details.

Users Enables to manage the status of user(s) that have currently logged-on
to the system. Refer to 'Managing Currently Logged-in Users' for
more details.

Help Contains options to get help and support on usage of the product and to
view the 'About' dialog. Refer to Help and About Details for more
details.

Search Opens online Comodo Cleaning Essentials help guide.

About Opens KillSwitch 'About' dialog that contains the version, license and
copyright information and an option to diagnose the KillSwitch
installation in your system.

Tab Structure

The Tabs area contains a set of tabs for selecting the items you wish to view in the main display area and to control them
through context sensitive menu.

Tab Items Displayed

System Displays the currently running processes, Applications and services that are currently running in
your system, under respective collapsible panes.

Processes | Displays the currently running processes in your system

Applications | Displays the currently running Applications in your system

Services Displays the Windows Services started along with your system

Network Displays the currently running processes involved in network connections and the network usage,
under respective collapsible panes.

Network Displays the currently running processes that are involved in network connection activities.
Connections

Network Displays a graphical representation of network traffic through the network adapters running on
Utilization | your computer.

Main Display Pane

The main display pane displays the list of items like Processes, application, Services and so on as per the selected tab with
required details on each entry as a table. Right clicking on an entry opens the context sensitive menu with the options relevant to
the items displayed.

Graphical Reports Pane

The pane displays dynamic graphical representations of your CPU usage, I/0 activity and physical memory usage and network
usage of your system. You can switch the display of this pane On and Off by selecting/deselecting the option 'Performance
Graphs' under 'View' menu in the File Menu bar.

The Tool Bar
The Tool bar displayed beneath the Main Display pane contains shortcut icons to important utilities of KillSwitch.
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Icon Description

Opens Autorun Analyzer utility to view and handle services and programs that were loaded when your
system booted-up.

Opens the 'Quick Repair' interface to troubleshoot and and repair important Windows settings and
features. Refer Repairing Windows Settings and Features for more details.

5
[

Open the 'Program Usage Analyzer' window that displays a summary of usage of all the programs
installed in your computer by different users. Refer to Analyzing Program Usage for more details.

Starts the Find Window utility that allows the user to find process related to active application window or
window components. Refer to Finding Process of the Active Window for more details.

e
4

L~

Opens a 'search' dialog that enables you to make a quick search to identify the Handles, DLLS that are
triggered or loaded to system memory or mapped files , by entering the name of the object. Refer to the
section Searching for Handles or DLLs for more details.

Opens the Windows 'Run’ dialog for executing command line interface programs with default limited user
privileges. Refer to Running Programs from Command Line Interface for more details.

Opens the System 'Information' panel that shows the graphical representations and statistics of the
usage/history of your system resources. Refer to the section 'Viewing System Information' for more
details.

The Status Bar

The status bar at the bottom of the interface displays the current CPU usage, currently logged-in user name and the version of
KillSwitch that you are using.

5.2.1. The System Tray Icon

KillSwitch displays an icon in the system tray at the bottom right corner of the screen. The icon displays a dynamic graphical
representation of the CPU usage history or |0 activities as configured through Options > CPU History in tray Icon or Options >
/0 History in Tray Icon, as shown below.
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Refer to Configuring KillSwitch for more details.

Right clicking on the system tray icon opens a context sensitive menu that contains the following options:

*  Shutdown; Shukdown

»  System Information; Systerm Infarmation. ..
* Open KillSwitch; Open KillSwitch

«  Close KillSwitch. Close KillZwitch

> | 12:56 PM

«  Shutdown - Enables you to switch the power state of your computer. Hovering the mouse cursor options opens a sub-
menu containing the following options:

Shutdown
Pawweroff
Restart e Shutdown;

Sleep *  Power-off;
Hibernate «  Restart;

Lock »  Sleep;
Lagaff Shutdown «  Hibernate;
System Information, .. «  Lock:

Open Killswitch «  Log-off.
Close Killswitch

&) 1258 PM

- System Information - Opens the System Information panel that shows the graphical representations and statistics of
the usage/history of your system resources. Refer to the section 'Viewing System Information' for more details.

«  Open KillSwitch - Opens the KillSwitch main interface window.

«  Close KillSwitch - Exits the KillSwitch application.
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5.3.Viewing and Handling Processes, Applications and Services

The main display pane of the application window displays the list of currently running processes, applications and services, on
selecting the 'System' tab from the tab structure. The Processes, Applications and the Services are listed in their respective
collapsible windows. Right-clicking on each entry opens context sensitive menu that enables various actions like
starting/stopping the processes/services, viewing properties of the processes.

Click the links below for detailed explanations on the windows displayed under the System tab.
«  Processes;
«  Applications;

«  Services.

5.3.1. Processes

The Processes window is displayed open by default and it shows all the processes that are currently running in your system as a
table in the main display pane. To open the Processes window from closed state, click the down-arrow at the right of the
'Processes' stripe.

«  The processes can be viewed in tree view or as a list.

«  The new processes started and the processes that are stopped, processes identified as suspicious and hidden are
highlighted with different colors. The highlighting colors can be set through Configuring KillSwitch > Configure
Highlighting.

- Right clicking on a process opens a context sensitive menu that enables you to perform various operations like stop,
restart, set priority, view properties, etc, on the process. You can even select multiple process (by holding the 'Ctrl' key
while selecting the processes) to execute these actions.
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The table below describes the columns that are displayed by default. You can add or remove the columns as per your
requirement. Refer to Column Selection for more detailed explanation on this.

Process Table - Descriptions of Columns

Description

Name Displays the name of the processes. Clicking on the column header enables sorting the entries in tree
structure, ascending or descending alphabetical order of the processes names.

PID Displays the Process Identification number. Clicking on the column header enables sorting the entries
in ascending or descending order of the PID numbers.

Rating Displays the result of analysis on each process by KillSwitch using different scanners such as
CAMAS. Processes are indicated as 'Safe' or 'Unsafe’ as per the analysis. Clicking on the column
header enables sorting the entries based on the rating.

Signer Displays the name of the Software vendor that has signed the software, which invoked the process.
Clicking on the column header enables sorting the entries based on the ascending or descending
alphabetical order of the names of the signers.

CPU Displays the CPU usage of the process as a portion of overall CPU usage by the process in
percentage. Clicking on the column header enables sorting the entries based on the CPU usage.

Working Set Shows the number of page files in the virtual memory, referenced by the process. Clicking on the
column header enables sorting the entries based on working set.

Background Note: The working set of a process is the collection of information referenced by the
process periodically. This collections are stored as page files in the secondary memory, such as the
portion of the hard disk partitions allotted as virtual memory.

User Name Displays the user that has initiated the process.

Description Describes the nature of the processes.

»  Placing the mouse cursor over a process displays a tool-tip that contains the details of the process.

E mspaint, exe 1184 Safe Microsoft Wind. .. 636 KB SMITHSCOMPUTERY. .. Paint
= £ 1o S 2,028 KB SMITHSCOMPUTERY. .. OpenOffice.arg 3.2
e LE C:\Program Files\OpenOffice. org 3\program|swriter . exe ! ! . . c
B 54,928 KB SMITHSCOMPUTERYL. .. OpenCiffice.org 3.2

Column Selection

The Processes window displays the details on each process under eight columns. If you are an advanced user and wish to view
more details on each process, you can configure the columns by adding or removing them.

To add or remove columns in Processes window:
«  Click View > Select Columns
Or

« Right click on the table header and select 'Select Columns' from the context sensitive menu.
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The 'Select Columns' dialog will appear. The dialog contains six tabs to configure the columns to be displayed for different
categories of information on each process.

Select Columns x

Process Performance Process Mematy
Process Image Madule Service Handles

Select the columns that will appear on the Process view of

Killswitch,
Process Mame [ Session 1D
[ PID (Process Identifier) [ Carmrmand Line
[+ User mame [+ Wersion
[+ Descripkion [+ DEP Status
[ Campany Mame [ wirtualized
[ werified Sigrer [ Image Path
[ Rating [ Irkergrity Lewvel

K ] [ Cancel

Refer to the sections below for more details on each tab:
*  Process Image
«  Process Performance

«  Process Memory

*  Module
«  Service
* handles
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Process Image

The Process Image tab allows you to select the columns to be displayed in the Process window, to provide the basic
information about the process and its image file. You can also configure to display the command line, Data Execution Prevention
(DEP) status and so on of the image file.

Select Columns x

Process Performance Process Memory
Process Image Module Service Handles

Select the columns that will appear on the Process view of

Kill5witch.
Pracess Marme [ Session I
[ PID (Process Identifier) [ Command Line
[ User Mame [ Yersion
[ Descripkion [+] DEP Status
[ Compary Marne [ wirtualized
[ Werified Sigrer [ Image Path
[+ Rating [ Intergrity Lewvel

(] 4 l [ Cancel

»  Select the columns to be displayed by selecting the respective checkboxes
»  Click OK for your configuration to take effect.

Process Performance

The Process Performance tab allows you to select the columns to be displayed in the Process window, to provide the detailed
statistics and performance information like CPU usage, I/0 activity and so on. This data will be useful to track the resource
overhead of a process at a granular level.
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Select Columns x

Process Image Maodule SErvice Handles
Process Performance Process Mernory
Select the columns that will appear on the Process view of
Killswitch,
[ CPU Usage [C] CPU Time
[T Handle Count [ Threads
[C] Base Priarity [] Skart Time
[[] Conkesxt Swikches [C] Contesxt Swikch Delka
[C]oPU Cycles [C] ZPU Cyeles Delta
[[] Read Count [[] read Bytes
[[1 Read Count Delka [[1 Read Bytes Delka
[] write Count [] werite Bytes
[C] Write Count Delka [C] Write Bytes Delka
[C] Okher Count [C] Other Bytes
[] other Count Delta [] Other Bytes Delka
[C] Tatal Ifo Count [C] Takal IfC Bytes
[] Tatal 1fr Count Delka [] Tatal Ijo Bytes Delta
Ok ] [ Cancel

«  Select the columns to be displayed by selecting the respective checkboxes
«  Click OK for your configuration to take effect.

Process Memory

The Process Memory tab allows you to select the columns to be displayed in the Process window, to provide granular details
on memory usage of each process.
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Select Columns x

Process Image Module = = Handles
Process Performance Process Memory

Select the columns that will appear on the Process view of

Kill5witch,

[+ Fage Fault [] Page Faulk Delta

[] Private Bykes [[] Peak Private Bytes

[T wirtual Size [] Memory Priority

[C] Warking Set [[] Peak Warking Set Size
[[] Paged Poal [[] Mon-paged Paal

[ GDI Object [7] USER. Objects

K ] [ Cancel

«  Select the columns to be displayed by selecting the respective checkboxes
«  Click OK for your configuration to take effect.
Module

The Module tab allows you to configure the columns to be displayed under the 'Modules' tab in the 'Properties’ dialog of a
process. For more details on the Properties dialog and the Modules tab, refer to the section Viewing Properties of a Process
> Modules.
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Select Columns x

Process Performance Process Mematy

Process Image Module Service Handles

Select the columns that will appear on the Module view of
Kill5witch,

fame
[+ Rating
[+ Base Address
[+ Size
[ Descripkion
[ Compary Marne
[+ Yersion
[+ File Mame
[ Type
[ Sigrier

K ] [ Cancel

«  Select the columns to be displayed by selecting the respective checkboxes
«  Click OK for your configuration to take effect.

Service

The Service tab allows you to configure the columns to be displayed in the Services window. Refer to the section Services >
Select Columns for more details.

Handles

The Handles tab allows you to configure the columns to be displayed under the 'Handles' tab in the 'Properties' dialog of a
process. For more details on the Properties dialog and the 'Handles' tab, refer to the section Viewing Properties of a Process
> Handles.
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Select Columns x

Process Performance Process Mematy

Process Image Maodule Service Handles

Select the columns that will appear on the Handle view of
Kill5witch,

Type
[C] Mame
[C] walue
[[] object
[[] references
] Handles
[ Access

K ] [ Cancel

«  Select the columns to be displayed by selecting the respective checkboxes
«  Click OK for your configuration to take effect.

Next: Stopping, Starting and Handling the Processes

5.3.1.1. Stopping, Starting and Handling the Processes

The 'Processes' window allows you to stop, suspend, restart, set priority, view properties and so on of individual processes, by
right clicking on the processes and selecting the option from the context sensitive menu.

Tip: KillSwitch can identify all unsafe processes and objects and then, according to your preference, Kill or Suspend them all at
once. To do this, click 'KillSwitch' from the file menu bar and select the required option.

«  Right click on a process to open the context sensitive menu.
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Window b o:
Set affinity. .

Sek Priority F i
Kill Process Del

kil Process Tree  Shift-+Del
Force Terminake

Delete

Restart

Suspend

Debug

Create Durmp »

Properties. ..
Search Online

Send to COMODO »

«  Window - Allows you to position/re-size the process' window, if one was found. If the process does not have any
visible windows, the menu is disabled. The options available are:

Window » Bring to Fronk
Set AfFfinity, .. Restore
St Priotiky » Minimize
»  Bring to Front; kil Process Del Maxirnize
* Restore; Kill Process Tree  Shift+Del Close
e Minimize; Force Terminate
»  Maximize; Delete
e Close. Restart
Suspend

«  Set Affinity - Enables you to view and modify the process' processor affinity (the CPU to which the process is
allocated) in a in a symmetric multiprocessing operating system e.g. to reduce cache related problems.
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Processor Affinity X

The Processar Affinity setking cankrals whick CPUs the pracess will
be allowed bo execute on.
CPL G CPU 16 CPLU 24
CPL S CPU 1Y CPL 25
CPLU 10 CPL 15 CPL 26
P11 P19 CPUEY
P 1E CPL 20 CPLES
CPUS CPU 13 CPU 21 CPU 29
CRU 6 CPU 14 CPU 22 CPU 30
P F P15 P E3 P31
4 l [ Zancel

Background Note:

In a symmetric multiprocessing operating system, each task (process or thread) in the queue is assigned with a tag indicating
its preferred processor so that it is allocated to the preferred processor during allocation time.

Some remnants of a process may remain in one processor's cache from the last execution. Scheduling the same process to
run on the same processor next time will increase the efficiency of the process, when compared to running on another
processor. For example, an application which does not use multiple threads, such as some graphics-rendering software is run
on multiple instances, allocating it to the same processor will reduce the performance-degradation due to cache misses and
increase the overall system efficiency.

Note: This option is not available when multiple processes are selected.

«  Priority - Enables you to sets the priority for the process. The available options are:

+  Real Time; o
) Set AFFinity. ..

«  High;
Set Priorit 3 ime:

«  Above Normal; v Realtime: 24

< Normal Kill Process el High:13

«  Below Normal; Kill Process Tree  Shift+Del Above Mormal: 10

e ldle. Faorce Terminake v  Mormal:s
Delete Below Maormalié
Restart Idle: 4

«  Kill Process - Terminates the selected process(es). KillSwitch can, except under extraordinary circumstances, be able
to terminate any process, including ones protected by rootkits or security software.

«  Kill Process Tree - Terminates the selected process and its descendants (child processes).

«  Force Terminate - Terminates the selected process(es) forcibly. This option suits for closing any programs that are
under 'Not Responding' status.

»  Delete - Deletes the selected (running or suspended) process(es) from the disk. KillSwitch can delete any process,
including ones protected by rootkits or security software. You will be asked for confirmation before deleting a process.
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Your computer will need a restart for this action to take effect.

Warning: Deleting a process will permanently remove the application that has triggered the process.

*  Restart - Restarts the selected process with the same command line arguments and working directory.

- Suspend - Suspends the selected process(es). KillSwitch can suspend any process, including ones protected by
rootkits or security

- Debug - Starts the debugger, for the selected process. This is useful for the software developers and testers, to debug
the applications that are newly installed in their systems.

«  Create Dump File - Enables you to create a crash dump file for the process. This operation does not actually cause
the process to crash or terminate. The available options are:

«  Create Minidump... - Creates a
Suspend small dump file containing only
essential data.

Debug

— »  Create Fulldump... - Creates a full
UGS B ' TR VLTI dump containing all the data.
Properties, .. Create Full Dump...

- Properties - Opens the properties dialog of the selected processes. Refer to the section Viewing the Properties of a
Process for more details.

«  Search Online - Opens the default web browser of your system with the search engine specified and searches for
information on the process on the web.

«  Send to COMODO - Submits the application that has triggered the process for analysis to Comodo, as False Positive
(if identified as suspicious by KillSwitch) or as Suspicious file as selected from the sub-menu. You can submit the files
which you suspect to be a malware. The files will be analyzed by experts and added to global white list or black list
accordingly in order to benefit all the users of Comodo security products world wide.

Properties...

Search Online

Send to COMODO [ Repart False Positive

Feport Suspicious

5.3.1.2. Viewing Properties of a Process

To view the properties dialog, just double click on the process in the main display pane or right click on the process from the
main display pane and select 'Properties' from the context sensitive menu. 'Properties' is used to cover the large amount of
information that surrounds each process. Because the amount of data is so large, the 'Properties' interface is broken down into
11 separate tabs, each containing important information and functionality related to the particular process.
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B swriter.exe: 2988 Properties

Environment
Image

Image File

A |

Handles Skrings
R.ating Performance

Openidffice.org 3.2

irerncFFire Ara

Threads Modules Ilzage
Performance Graph Security

Further details are available on each tab by clicking the following links :

+ Image;
+ Rating;
«  Performance;

«  Performance Graph;

«  Security;

+  Environment;
+ Handles;

«  Strings;

*  Threads;

*  Modules;

« Usage.

Note: The 'Usage' tab will be displayed only for the processes at the first level of the process hierarchy. For the branch
processes in the process tree, the 'Usage' tab will not be displayed and hence the 'Properties' dialog will contain only 10 tabs.

Image

The 'Image’ tab displays the basic information about the process and its image file. You can also view its command line, Data
Execution Prevention (DEP) status, terminate the process and so on. The dialog also allows you to make the Window of the
parent application of the process active and to terminate the process.
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B swriter.exe: 2988 Properties

Ervironment Handles Skrings Threads Modules Ilzage
Irnage Fating Perfarmance Petfarmance Graph SEcLriky
~Image File -

i Opendffice.org 3.2
CpenOffice. org
Version: 3.02.9476

Signer:
Image File Mame:

C:\Program Filest OpenOffice,arg 3programisoffice, exe
Command Line:

"\ Program Files\OpenidFfice.org Jiprogramiswriter .exe” -0 "CHDocuments and £
Current Direckary:

Ci\Documents and SettingsiUser A4y Documents),

Parent: swriter, ecoel 18047 ——
User: SMITHSCOMPUTER User &

Started: 2011-12-07 10:00:46 Kill Process
Comrment:

Data Execution Protection (DEP) Status; Disable

Close

i

- Terminate - Clicking 'Terminate’ stops the process. You will be asked for confirmation before stopping the

process.
COMODO KillSwitch

\?() Are wou sure ko berminate soffice, exe?

BTN

Click here to go back to list of properties.

Rating

The 'Rating' tab displays a list of scanning tests performed by KillSwitch on the process through its native scanner, CAMAS and
the results pertaining to each scan.
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M swriter.exe: 2988 Properties

Ervironment Handles Skrings Threads Modules Ilzage
Irage F.ating Perfarmance Perforrmance Graph Security
Scanner R.ating

Basic Safe

FLS Safe

Camas IIndetected

You can see the following scan results:

Scan
Result
Basic File scanner of local AV enaine To ensure the most accurate scan results, please
9 update the AV database prior to running an AV scan.
FLS Cloud based file scanner -
Cloud based verification of a file's digital signature -
Local verifier of trusted vender Local check that the Checks that th?’ f".e has a Q|g!tal signature. If it does,
L . then checks this signature is in the trusted vendor
creator of the file is on the trusted vendor list list
CAMAS oo Use private communication protocol to send the file
File is uploaded to Comodo Automated Malware to CAMAS for analysis. Public CAMAS URL:
Analysis System (CAMAS) for inspection .
http://camas.comodo.com

The Rating list shows the final rating only according to the priorities. The priority of scan results are the following (High to low):
1. Basic.Malware

FLS.Malware

FLS.Safe

CAMAS .Detected

CAMAS.Malware

CAMAS.Suspicious

CAMAS.SuspiciousP

CAMAS.SuspiciousPP

FLS.Unknown

© o N o o A~ W N
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10. FLS.Absent
Click here to go back to list of properties.

Performance

The 'Performance’ tab displays the statistics and performance information like CPU usage, I/0 activity, Memory usage etc. This
data can help advanced users track the resource overhead of a process at a granular level.

B swriter.exe: 340 Properties - 0O X
Environment Handles Skrings Threads Modules Isage
Image Fating Performance Petformance Graph SECLFiky

~ZPL I
Priority a 10 Priariky
Kernel Time 00:00:00.062 Reads 1
ser Time 00:00:00.015 Read Delka 0
Tatal Time 00:00:00,078 Read Bytes Delka 0
Context Switches 135 Writes 1]
- g Wyrite Delta 0
~\irkual Memory -
. Wrike Bykes Delka 0
Private Bykes 572,00 KB
Ckher 210
Peak Private Bytes 576.00 KB
Cther Delka 0
Wirtual Size 24,30 ME
Other Bytes Delka 0
Pealk Virtual Size 32,53 MEB
P Fault Sla - ’
SR ~Cither .
Page Faulks Delka 1]
i | Handles 20
~Phrysical Mernary - | &G0l Handles 4
Mernoty Priority T IUSER Handles 0
Warking Set 1.91 ME = 2
WS Private &.06 ME
W5 Shareable 4.00 GE
Peal Working Set 1.91 ME
P

Click here to go back to list of properties.
Performance Graph

The 'Performance Graph' tab displays three graphs relating to the process' performance - CPU Usage, Private Bytes, and 1/0
activity. This window helps the advanced users to track the resource overhead of a process pictorially. You can hover your
mouse over the graphs to view details.
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Il swriter.exe: 340 Properties

Ervironment Handles Skrings Threads Modules Ilzage
Image R.ating Performance Perfarmance Graph Security

CPU Usage Hiskory

Private Bytes Histary

Private Bykes: 572,00 KB
2011-12-07 12:04:46

I/ Byhes Hiskorsy

Close

Click here to go back to list of properties.

Security

The 'Security' tab displays the primary tokens of the process. The primary token of a process is an object which describes
security attributes such as the user, groups and privileges.
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Ervironment Handles Skrings Threads Modules
Irage F.ating Perfarmance Petformance Graph
zef: SMITHSCOMPUTER\User &
Session: 0 Wirtualized: MfA&
aroup Flags
SMITHSCOMPUTER \Maone Mandakaory
Everyone Mandakaory
BUILTIM) Administrators Caner
BUILTIM|Users Mandakary:
MT AUTHORITYINTERACTIVE Mandakaory
MT AUTHORITY Authenticated Users Mandakaory:
S-1-5-21-1214440339-445539723-652003,,, Logon ID
L AL Mandatory
] m
SID: 5-1-5-21-1214440339-448539723-682003330-1003
Privilege Flangs
SeChangeratifyPrivilege Default Enabled
SeSecurityPrivilege Disabled
SeBackupPrivilege Disabled
SeRestorePrivilege Disabled
SeSystemtimePrivilege Disabled
SeshutdownPrivilege Disabled
SeRemoteshutdownPrivilege Disabled
SeTakeDwnershipPrivilege Disabled
SeDebugPrivilege Disabled
SeSystemEnyvironmentPrivilege Disabled
SesystemProfilePrivilege Disabled
SebrafileSinnlaPrareccPrivilens Nizahlad

Usage
Securiby

Close

Click here to go back to list of properties.

Environment

COMODO

Creating Trust Online®

The 'Environment' tab displays the process' environment variables, which are the variables accessible to process describing the

operating system environment. Environment variables are normally inherited by child processes.
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Il swriter.exe: 340 Properties

Imange R.ating Performance Petrformance Graph SECUriky
Ervsironrment Handles Skrings Threads Modules Isage
Wariable Yalue
ALLUSERSPROFILE ChDacuments and Sektingsial Lsers
APPDATA C:Documents and SettingsiUser Aapplication D,
CLIEMTMAME Console

CommonProgramFiles C:\Program FileshCommon Files

COMPUTERMAME SMITHSCOMPUTER

ComSpe: CW IRDOW St system 32 crmd . exe

FP_MO_HOST CHECK MO

HOMEDRIVE i

HOMEPATH \Cocuments and SettingsiUser &

LOGOMNSERVER NSMITHICOMPUTER,

MNUMBER._OF _PROCESSORS z2

Q5 Wwindows T

Path C:\Program FileshOpenOffice.org 34\ WINDO,
PATHEXT COM; EXE; BAT: .CMDy WES; WEE;. 15; . J5E; WS, ..
PROCESSOR,_ARCHITECTURE xG6

PROCESSOR_IDEMTIFIER %36 Family & Model 37 Stepping 5, Genuinelntel
PROCESSOR_LEVEL 2]

PROCESSOR,_REVISION 2505

ProgramFiles C:\Program Files

SESSIONMAME Console

SwskemDrive C:

SystemRook Cw TRDOWS

TEMP CADOCIME 1Y UISER Aee 1\ LOCAL S 1) Temp

THP 2\ DOCUME 1 USER Ae 1\ LOCALS~1) Temp
USERDOMATIM SMITHSCOMPUTER

USERNAME User 4

IJSERPROFILE CDocuments and SettingsiUser A

windir C i INDOW'S

#

Click here to go back to list of properties.

Handles

The 'Handles' tab displays the process' handles - resources it has opened. A handle refers to the value used to uniquely identify
a resource,such as a file or a registry key, accessed by the process or the application.
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[# Hide unnarmed handles

Image R.ating Performance Petrformance Graph SECUriky
Ervironment Handles Strings Threads Maodules Usage
Type Mame Waule Ohject
kKevedEvent WK ernelObisck s\ CrikSecOukOf MemaryEvent Mg OxE1008
Direckory " nownDills 0«8 OxE1913
File CDocuments and SektingsiUser &My Documents Oxc OxG1FET
File o TMDOW S WINSx S, x 86 _Microsoft WZ90,CR.., 0x10 Dx8250C
Direckary Chwindows 0x14 OxE1863
ke YREGISTRYMACHIME Ox24 0xE1753
Windowskation  CyWwindows\WindowSkations!Wingtal Dx2c Oxa20FS
Deskkop YDeFault 0x30 0x82521
WindowStation  CWindows) WindowStations | winStal 0x34 Ox220FE
Directory: 1BasehamedObjects 033 0xE18AE
Semaphore 1BaseMamedObiectsishel {A45F 1AZZ-A340-11. ., D30 DxEzs510
File O IO S WINSx S x 36 _Microsoft, Windows, . . Dt OxB2376
Mukant '\BaseMamedObjects) ShimCacheMutex Qe OxB23C3
Seckion 1BasehamedObiectstshimsharedMemary x50 0xE1653
Process soffice.exe (1972) 0x54 QxEz2300
Thread soffice.exe (19720 2016 0x58 0x32510

Close

i
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Tip: The columns displayed in Handles interface can be configured to display the details as required. Refer to Column
Selection > Handles for more details.

«  Hide unnamed handles - Selecting this option removes the handles that do not have a name from the list of

handles displayed.

«  Right-clicking on an handle opens a context sensitive menu that enables to you to close or view the properties of

the handle.

Mutant
Seckion

Thread

'I,BéseNamedOEjects'l,SHimCEcheMutex
BaseMamedObijecks\ ShimsharedMemaor
soffice.exe (19721

soffice.exe (19720 2

Close Handle Del

Properties. ..

eedc QxgZ23C3
x50 0xE1655

«  Close Handle - Closes the Handle. Closing a process handle does not terminate the associated process or
remove the process object.

«  Properties - Opens the 'Properties' dialog of the Handle. Also double clicking a handle opens its 'Properties'

dialog.
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Handle Properties x

~Basic =
Marme: soffice, exe (1972)
Handle Value: 0
Twpe: Process

Description:  Conkains threads, an address space, and handles,

Object Address:  0x823006A5

" -

~References Cuoka Charges ———
References: 12 Paged: 0
Handles 3 Mon-Paged: 0

Click here to go back to list of properties.

Strings

The 'Strings' tab displays a list of ASCII and Unicode strings that are loaded to the process. You can choose to extract the
threads loaded to Process image or Process memory.
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Image R.ating Performance Petrformance Graph SECUriky
Ervironmment Handles Strings Threads Modules Isage

Printable strings Found in the scan:

Result A

IThis program cannok be run in D05 mode,
Rich

ek

" .rdata

@, daka

JFSFC

SYWHDE

50@

Ef;

S@@F;

i@EEF;

(a0f]

Ef;

aiaf;

bl

b, L@

PS55]

2@ @

S0 i@

00

SE3m

i

b0

[ylu ] k-
4 1] F

@ Irmage @& Mermaory Save ] [ Find ]

«  Select ‘Image’ or ‘Memory’ to extract and view the strings from Process Image or the Process Memory respectively.
«  Click 'Save' to save the displayed list of strings as a text file.

Threads

The 'Threads' tab displays a list of threads of the process, including their symbolic start addresses. You can click on a thread to
view more information, or double-click a thread to view its call stack and modules.
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H PaintDotMet.exe: 1404 Properties

Image R.ating Performance Petformance Graph SECUriky
Ervironment Handles Strings Threads Maodules Usage
TID CSwitches Delka Skart Address Pricrity 3
395 mscoree. dll! CorExelain Marmal

357z mscorwks, dNClrCreateManagedIn.., MNaormal

1552 2 mscorwks, diNCorExitProcess+0x2,., Highest

B gdiplus . dlll zdipGetYisibleClipBound. .. Mormal

1520 rscobwks, dilCarExitProcess+0x2,.. Mormal

3Irz0 mscorwks, diNCorExitProcess+0x2,.. Mormal

4016 mscorwks, diNCorExitProcess+0x2,.. MNormal i
2580 nkdll. dil'REueueworkItem+0x233  Mormal i
3336 mscorwks, dillCreatedssemblyMam. .. Mormal

2997 2 mscorwks, dilCreatefssemblyiamm, .. MNormal

3144 69 mscorwks, dilCorExitProcess+0x2... Mormal

2316 mscorwks, dll CorExitProcess+0x2,,, Mormal

3276 KERMEL3Z dlll CreateThread+0x22  Marmal

1756 RPCRT4.dIN_RpcBCacheFree+0:x,.. MNarmal

1680 67 mscorwks, dilCorExitProcess+0x2... Mormal

1172 66 mscorwks, dll CorExitProcess+0x2,,, Normal ?
171E FC raceorsle AT arF kD me e e L2 Bloera=l

] m F
Thread 10 646 Stack ] [ Module
Skarted: 2011012)7 10:2:58
Skate: Wait:WrlserRequest Base Priority: g
kKernel Time: 00:01:02,046 Dwnamic Prioriby: 13
User Tire: 00:03:24, 265 I Priority:
Conkext Switches: 4239530 Memory Priority: 0

kil ] [ Suspend ]
#

Handling Threads

«  Stack - Analyzes the thread and displays a list of stacks in the thread.

Stack - Thread 580 X

MName

ntkrnlpa. exe! ZwyieldExecution+0x 2570

ntkrnlpa, exe! MY aitForSingleObject+0x9a
ntkrnlpa.exe!KeReleaseInstackiZueuedSpinLockFromDpolevel+0xb74
nkdll, dilMKiF askSystemiZall et

kernel3z, dliwaitFarsingleObjeck+0x12

swriter, exe+0x1197

swriter, exe+0x1404

kernel3z. dlllRegisteraitForInputIdle+0x49

O s L= O

Copy l [ Close

«  Module - Opens the 'Properties' dialog of the module that has invoked the process.
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swriter Properties

General | Version | Compatitiliyy | Summary|

=

| Zriker |

Typeof file:  Application

Descrption:  OpenOffice arg Wiker

Location: C:%Program FileshOpenQffice.org 3hprogram
Size: 233 KB [305.152 bytes]
Size on dizk: 300 KB [307.200 butes)

Created: kaonday, Februan 01, 2000, 10:54:40 P
odified: bonday, Februar 01, 20010, 10:54:40 PM
Aoceszed: Today, December OF, 2011, 11:54:55 AM

Attributes: [ |Read-only [ Hidden

] l [ Cancel

«  Kill - Terminates the thread. Terminating the thread does not terminate the associated process or remove the process
object.

«  Suspend - Suspends the thread.

Click here to go back to list of properties.

Modules

The 'Modules' tab displays the modules loaded by the process. Modules are the dynamic link library (DLL) files that are loaded
to the system memory by the selected process. Double clicking on a Module opens the 'Properties’ dialog of it.
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Il swriter.exe: 340 Properties

Image R.ating Performance Petrformance Graph SECUriky
Ervironment Handles Strings Threads Modules Usage
F.aking Base Address Size Descripkion
FE10000 292,00 KB GDI Clienk DLL
Cx00ZEQQQ0 260,00 KB

RPCRT4.dI Safe 0x77E7F0000 534.00 KE Remote Procedure
SHLUWAPT, Il Safe O 77FG0000 472.00 KB Shell Light-weight |
swriker, exe Safe 00400000 305,00 KB OpenOffice,arg W
sorttbls.nls Safe 000330000 24,00 KB

SHELL3Z.dIl Safe O 90000 3.09 ME Windows Shell Con
ADVAPTIZ. I Safe O 77000000 620,00 KB Advanced Window
kernel3z.dl Safe O 200000 A534,00 KB Windows NT BASE
rswort. dil Safe Qx77C10000 352.00 KB ‘Windows MT CRT [
chype.nls Safe Q00370000 12,00 KB

locale.nls Safe 000290000 260,00 KB

Secur32.dl Safe 07 7FEDDOO 63,00 KB Security Support P
comckl3z.dll Safe Q77300000 1.01 ME User Experience C
JSERZZ.dIl Safe Ox7E410000 550,00 KB Windows xP USER
comckl3z ., dll Safe 050090000 616,00 KB Common Conkrols |
unicade.nls Safe Q00270000 35,00 KB

apphelp. dil Safe 7 7E40000 136,00 KB Application Compa
kil dll Safe O 900000 F00,00 KE MT Laver DLL
rSCR20, dll Safe Ox78520000 652,00 KE Microsoft® C Runt

] 1] r
[C] Hide Safe

#

Tip: The columns displayed in Handles interface can be configured to display the details as required. Refer to Column
Selection > Module for more details.

» Hide Safe - Removes DLL modules identified as safe by KillSwitch and displays only unknown and unsafe modules.
Handling the Modules

Double clicking on a Module name opens the Properties dialog of the module.
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RPCRTA. dll Properties X

Image | Rating | Strings

Description:  Remoke Procedure Call Runkime

Comnpanty: Micrasaft Corporation

Wersion: 5.1.2600,5512 (xpsp.030413-2108)

Sigriet: Microsoft Windows Corponent Publisher

Image File Mame: | CHAMWINDOMW S system32\RPCR T4, dl E]
Process: swiriter, exel 340)

Base Address: 0= 7 FEFOOO0

Mapped Size: 534.00 KB

Mapping Type: DLL

Close

The dialog provides complete details of the DLL module under the three tabs 'Image’, 'Rating' and 'Strings' tabs.

Right-clicking on a module listed opens a context sensitive menu that enables you to perform various actions like unloading the
module from the memory.

sortkey,nls Safe Qx002E0000 260,00 KB
RPCR T, dll Safe Q7 FEFOO00 554,00 KE Remote Procedure
SHLWAPT, Al Safe O 7 7FE0000 472,00 KE Shell Light-weight |
= == 308,00 KB OpenOffice, org W
sorttbls. s Delete 0o 24.00 KB
SHELL32.dI search Online 0o 8.09 MB Windows Shell Con
ADVAPTIZ. I oo 620,00 KB Advanced Window
kernel3z. dl Send ko COMODD oo A534,00 KB \Windows MNT BASE
mswcrt, dil o Containing Fald ] 352,00 KB Windows MT CRT L
chype.nls RER -Ontaining Foider 0o 12,00 KB
locale.nls Properties oo 260,00 KB

»  Delete - Removes the selected module from your computer. You will be asked for confirmation before deleting the

module.
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Warning: Deleting some critical modules of an application may render the application unusable.

«  Search Online - Opens the default web browser of your system with the search engine specified and searches
for information on the module on the web.

- Send To Comodo - Submits the module for analysis to Comodo as Suspicious or False Positive. The files will be
analyzed by experts and added to white list or black list accordingly.

«  Open Containing Folder - Opens the folder in which the module is stored, in Windows Explorer window.
- Properties - Opens the 'Properties' dialog of the module.

Click here to go back to list of properties.

Usage
The 'Usage' tab displays how often the parent application of the process has been used by the user and its previous run time.

M swriter.exe: 2988 Properties - 0O X
Imange Fating Perfarmance Petfarmance Graph SECLriky
Environment Handles Strings Threads Modules Usage

Jsage: Cccasionally
Lask run time: 2011/12/07 09:55
A

Click here to go back to list of properties.

5.3.2. Applications

The 'Applications' window shows all the applications that are currently running in your system as a table in the main display
pane. To open the 'Applications' window from closed state, click the down-arrow at the right of the 'Applications' stripe.

«  The processes can be viewed as a list .

«  The new applications started and the applications that are closed are highlighted with different colors. The highlighting
colors can be set through Configuring KillSwitch > Configure Highlighting.

«  Right clicking on an application opens a context sensitive menu that enables you to perform various operations like
maximizing/minimizing application windows, close an application and access the process invoked by the application.
You can even select multiple applications (by holding the 'Ctrl' key while selecting the processes) to execute these
actions.
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Options  Wiew  Tools  Users
n|u| 1
Processzes (24) i \_"
Applications (7} | A 1
Caption Process ID Thread ID Status
E COMODO KillSwitch 272 544 Running
aDieseI locomotive - Wikipedia, the free encyclopedia - Microsoft Internet Explorer 792 1444 Running
Diesel The Devious - Friend of Thomas.odt - Opencffice, org Writer 364 872 Running
aHDwStuFFWDrks "How Diesel Locomokives Work” - Microsoft Internet Explorer 79z 1828 Mot responding
)My Pictures 1554 1416 Runring
:e Printers and Faxes on 192,168,111,111 1564 744 Running
w Z0M Locomotive - Paink 1096 1280 Running
l 1] | 3
Services (247) (v)

"ot
CPU Usage: 50,00% S S PUTERY User &

Applications Table - Descriptions of Columns

Description

Caption Displays the names of the applications. Clicking on the column header enables sorting the entries in
ascending or descending alphabetical order of the application names.

Process ID Displays the Process Identification number of the process invoked by the application. Clicking on the
column header enables sorting the entries in ascending or descending order of the PID numbers.

Thread ID Displays the Thread Identification number of the process invoked by the application. Clicking on the
column header enables sorting the entries in ascending or descending order of the Thread ID
numbers.

Status Displays the current execution status of the application.

Next: Handling the Applications

5.3.2.1. Handling the Applications

The 'Applications’ window allows you to bring the application window active, minimize/maximize the application window, close
the application and to access the process invoked by the application, by right clicking on the application and selecting the option
from the context sensitive menu.
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«  Switch to - Brings the application active, minimizing the KillSwitch window.

«  Restore - Restores the minimized application window from the Windows task bar to its last state.
¢ Minimize - Minimizes the application window to the Windows task bar.

«  Maximize - Maximizes the application window.

«  Close - Exits the application.

«  Go to Process - Opens the 'Process' window with the process invoked by the application highlighted. This is useful
when you want to terminate or suspend the process associated with the application. Refer to Stopping, Starting and
Handling Processes for more details.

5.3.3. Services

The Services window is displayed open by default and it shows all the Windows Services/drivers loaded in your system as a
table in the main display pane. It also allows your to start, stop, restart or delete them as required. To open the Services window
from closed state, click the down-arrow at the right of the 'Services' stripe.

- The services associated with the processes/applications are indicated by 7 icon.

«  The drivers are are indicated by “ icon.

- Right clicking on a Service opens a context sensitive menu that enables you start, stop, restart or delete it. You can
even select multiple services (by holding the 'Ctrl' key while selecting the services) to execute these actions.
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The table below describes the columns that are displayed by default. You can add or remove the columns as per your
requirement. Refer to Column Selection for more detailed explanation on this.

Services Table - Descriptions of Columns

Description

Name Displays the name of the Service. Clicking on the column header sorts the entries in ascending or
descending alphabetical order of the names.

Display Name Shows the name by which the service is indicated in the Windows System Configuration Utility.
Clicking on the column header sorts the entries in ascending or descending alphabetical order of the
display names.

Type Displays the type of the service, viz. shared processes (in svchost.exe instances), Own processes
(processes on their own), or drivers. Clicking on the column header sorts the entries in ascending or
descending order of the types.

Status Displays the status of the service, i.e. whether it is running, stopped or disabled. Clicking on the
column header sorts the entries in based on their status.

Start Type Indicates how the service can be started, i.e. whether it automatically starts with Windows, started on
demand or disabled. Clicking on the column header sorts the entries in based on their start types.

Column Selection

The Services window displays the details on each process under five columns. If you are an advanced user and wish to view
more details on each service, you can configure the columns by adding or removing them.
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To add or remove columns in Services window, right click on the table header and select 'Select Columns' from the context
sensitive menu.

T COMODO KillSwitch

Options  Wiew Tools  Lsers  Help

B4 5ystem _E-I?_r'-le.'.--.u_lrl::. #, Loaded Modules

Procezzes (23) L \_v' 1
‘ Applications (6) ":\_"::'
Services (246) (m)
Mame Display Mame | celact Columns. tus Skart Type 3
._;ru':.f\.biasdsk Abiosdsk L&- e pped Disabled =
__J_:aabp“rBDnS abp4&0nS N Drriver Stopped Disabled
L PRCFI Microsoft ACPT Driver Driver Funning Book Start
BCPIEC ACPIEC Diriver Stopped Disabled
adpu160m adpula0m Diriver Stopped Disabled

The 'Select Columns' dialog will be displayed with the 'Services' tab opened.

Select Columns x

Process Performance Process Memory
Process Image Maodule Service Handles

Select the columns that will appear on the Service view of
KillSwitch.

Mame
[ Display Mamne
M Type
[ Status
[+ start Type
CIPID
[C] Binary Path
[C] Error Contral
[C] Group
[[] Load Crder

(o] 4 ] [ Cancel

«  Select the columns to be displayed by selecting the respective checkboxes
«  Click OK for your configuration to take effect.

Next: Stopping, Starting and Deleting the Services
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5.3.3.1. Stopping, Starting and Deleting the Services

The 'Services' window you to start, stop and delete the services, by right clicking on the service and selecting the option from the
context sensitive menu.
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[T rnmsr
Skop
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Copy Chrl4+C

- Go to Process - Switches the display to the 'Processes’ window and highlights the process associated with the
service. This is useful when you want to terminate or suspend the process associated with the service. Refer to
Stopping, Starting and Handling Processes for more details.

- Start - Starts the selected service. This option is available only for the services with 'Stopped' status.

- Continue - Resumes the suspended/paused service. This option is available only for the services with 'Paused'
status.

- Pause - Suspends the running service. This option is available only for the services with 'Running' status.
- Stop - Halts the running service. This option is available only for the services with 'Running' status.
»  Restart - Restarts the running service. This option is available only for the services with 'Running' status.

»  Delete - Deletes the selected (running, stopped, paused or disabled) service(s) from the disk. KillSwitch can delete
any service, including ones protected by rootkits or security software. You will be asked for confirmation before
deleting a service.

Warning: Deleting a critical service may render your computer unusable. Use this option only if you are an advanced user with
thorough knowledge on services.

- Start Type - Enables you to define when and how a particular service is to be started. Hovering the mouse cursor over
Start Type will open a sub-menu with the options:
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Hovering the mouse cursor over Start Type will open a sub-menu with the options:
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« Disable - The service will be disabled from running.
- Boot Start — The service will be loaded by the boot loader and will started when the system is booted.
- System Start - The service will be started during kernel initialization automatically.

«  Auto Start - The service will be started automatically upon each restart of the computer and will run even if
the user is not logged-in.

- Demand Start - The service will be started only on demand by an application.
»  Copy - Copies the row of the selected service(s) from the list of services into your clipboard.

5.4.Viewing and Handling Network Connections and Usage

The main display pane of the interface displays all the network connections that are currently running in your system as a table
and a graphical representation of your network utilization, on selecting the 'Network' tab from the tab structure. The Network
Connections and the Network Utilization are displayed in their respective collapsible windows. Right-clicking on each entry in
the Network Connection opens context sensitive menu that enables you to access the process associated with the connection

and to close the connection.
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Click the links below for detailed explanations on the windows displayed under the 'Network' tab.
*  Network Connections;

»  Network Utilization.

5.4.1. Network Connections

The 'Network Connections' window is displayed open by default and it shows all the network connections that are currently
running in your system as a table in the main display pane. It also allows you to inspect and close a connection from the right
click options. To open the 'Network Connections' window from closed state, click the down-arrow at the right of the ‘Network
Connections' stripe.

- The new connections that are started and the connections that are stopped are highlighted with different colors. The
highlighting colors can be set through Options > Configure Highlighting.

» Right clicking on a connection opens a context sensitive menu that enables you to view the process associated with
the connection, and close the connection.
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Network Connections Table - Descriptions of Columns

Column Description
Protocol Shows the connection protocol. Clicking on the column header sorts the entries in based on the
protocols.
Local Address Shows the local address of the connection. Clicking on the column header sorts the entries in

ascending or descending numerical/alphabetical order of the addresses.

Note: The host names are displayed only if the option 'Resolve addresses for Network Address' is
enabled under 'Options' menu. Else only the IP addresses are displayed.

Local Port Displays the local port number through which the connection is established. Clicking on the column
header sorts the entries in ascending or descending order of the port numbers.

Remote Address Shows the address of the remote host of the connection. Clicking on the column header sorts the
entries in ascending or descending numerical/alphabetical order of the addresses.

Note: The host names are displayed only if the option 'Resolve addresses for Network Address' is
enabled under 'Options' menu. Else only the IP addresses are displayed.

Remote Port Displays the port number of the remote host through which the connection is established. Clicking on
the column header sorts the entries in ascending or descending order of the port numbers.

State Shows the status of the connection. Clicking on the column header sorts the entries in based on the
status of each connection.

Next: Inspecting and Closing Network Connections

5.4.1.1. Inspecting and Closing Network Connections

The 'Network Connections' window allows you to inspect a connection for trouble shooting and closing a connection if required,
by right clicking on the connection and selecting the option from the context sensitive menu.
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Metwork Utilization

«  Go to Process - Switches the display to the Processes window and highlights the process associated with the
connection. This is useful when you want to terminate or suspend the process associated with the connection.

«  Close - Closes the network Connection.

«  Copy - Copies the row of the selected connection from the list of connections into your clipboard.

5.4.2. Network Utilization

The Network Utilization window provides a graphical overview of how much network traffic is being used over time by the
network adapters running on your computer. Placing the mouse cursor over the graph displays a tooltip with further details.

The window also displays the details of the network adapter beneath the graph.

To open the 'Network Utilization' window, click the down-arrow at the right of the 'Network Utilization' stripe.
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Network Utilization Table - Descriptions of Columns

Column Description
Adapter Name Shows the name of the network adapter.
Input Utilization Shows the incoming traffic utilization in percentage.
Output Utilization Shows the outgoing traffic utilization in percentage.
Link Speed Shows the connection speed of you computer with the network.
Status Displays the traffic flow operation status through the network connection.
GUID Shows 32 character Globally Unique Identifier of the connection.

5.5. Configuring KillSwitch

The 'Options' menu in the file menu bar enables granular configuration of the overall behavior of the KillSwitch application.
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«  Always on Top - If selected, KillSwitch application window is always maintained on top of all the other application
windows on your computer display.

+ Replace Task Manager - If selected, any attempt to start Windows Task Manager, (e.g. press Ctrl + Alt + Del > Click
‘Task Manager' or right-click on the Task Bar and select 'Task Manager' from the pop-up menu) will start KillSwitch
instead. To re-enable Windows Task Manager when Ctrl + Alt + Del is pressed (or 'Task Manager' is selected by
another method), simply deselect this option.

«  Hide When Minimized- If selected, KillSwitch will automatically hide itself when it is minimized. You can double-click
on the system tray icon to reopen the application.

«  Confirm Kill/Delete/Suspend/Restart — Makes KillSwitch to display a confirmation dialog whenever you attempt to
terminate, delete, suspend or restart a process, application, service or a network connection. An example is shown

below.
COMODO KillSwitch

\?f) Are wou sure wou wank ko kerminate the selected processes?

o (o

»  CPU History in Tray Icon - KillSwitch displays a system tray icon at the bottom right corner of the screen. The icon
enables to open or close the application, shutdown your system and so on. On selecting this option, the icon will
display a dynamic graphical representation of the CPU usage history in your computer. Refer to the section 'The
System Tray Icon' for more details.

« /0 History in Tray Icon — Makes the system tray icon to display a dynamic graphical representation of the
input/output activities of your computer.

«  Resolve Network Address - If enabled, KillSwitch retrieves the host names for all the network connections for display
in the 'Local Address' and 'Remote Address' columns in the 'Network Connections' window. If not enabled, only the
IP addresses of the local host and the remote host will be displayed.

- Threats Log Level - Allows you to select the option for creating log reports. Hovering the mouse over 'Threats Log
Level' displays a sub-menu with the three options:
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» Disable - Instructs KillSwitch to not to generate log reports.

- Threats - Instructs KillSwitch to generate log reports containing files that it has detected as threats.
«  All - Instructs KillSwitch to generate log reports for all the files that it has scanned.

«  To view the logs, click Tools > Browse Logs...

« Run KillSwitch as Administrator - Irrespective of the privileges of the currently logged-in user account, all the
operations of KillSwitch that require administrative privileges will be executed.

«  Configure Symbols - KillSwitch uses the symbols from program database files to resolve the names of functions
from running processes to find the start addresses and stack locations of threads, for displaying under the Threads tab
of the Process — Properties dialog. If you have relocated the pdb files, you can specify the new path of the file through

this option.
Configure Symbols X

o~ Symbiols -

Killswitch uses symbaols ko resalve Function names when displaying
thread start addresses and thread stack locations on the thread tab
of process properties dialog.

Symbals path:

(] 4 ] [ Cancel

- Configure Highlighting - KillSwitch highlights:
- the processes that are started, stopped, identified as suspicious or hidden processes in the 'Process'
window;
- the applications that are started or closed in the 'Applications' window;
- the services that are started and stopped in the 'Services' window;
- the network connections that are started and stopped in the Network Connection window.

in different colors. The 'Configure Highlighting' option enables you to select the colors that are to be used for
highlighting for different events. Also the option enables you to change the look and feel of the graphs such as
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under the Network tab of the main interface, Performance Graphs in the Process Properties dialog.

Clicking on the Configure Highlighting option will open a 'Colors' dialog.
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- Highlighting - You can set the colors for highlighting the starting and terminating processes, services
applications and network connections in the KillSwich interface from the 'Highlighting' area in the colors
dialog.

« Rating - You can set the colors for highlighting the processes and services identified as suspicious, hidden
or unknown from the 'Rating' area in the colors dialog.

«  Graph - The Graphs area allows you to select the colors of the line in the graphs indicating the
history/usage information on:

«  CPU usage by Kernel
»  CPU usage by User initiated applications and processes
« 1/0O Read Only
e |/O Write
«  Physical Memory Usage
«  Private Bytes
«  Network Input
«  Network Output
To change the color of a desired line

1. Click on the color patch beside the required parameter. The 'Color' window will be displayed with the default color
selected.
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2. Choose the color for highlighting or the graph line. You can do this by two ways:

«  Directly choose the color from the palate; or
«  Click on 'More Colors..." to add a custom color to the palate and select it.
3. Click OK.
The highlighting and/or graph lines will be displayed with the colors you have chosen.

« Language - KillSwitch is available in several language. Hovering the mouse cursor over 'Language' in the 'Options'
menu displays the list of languages. You can select the language for application from the list.

5.6.KillSwitch Tools

KillSwitch contains a set of utilities that help you in carrying out various activities like handling processes, objects and dll files
collectively, troubleshooting and repairing important Windows settings, checking installed programs and their usages, verifying
authenticity of installed programs and many more.

The utilities can be accesses from the Tools menu in the file menu bar and the shortcut in the tool bar beneath the main display
pane.

«  To access the utilities in the Tools menu, click on the Tool in the file menu bar.
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Applications (9)

Capkion

«  To access the utilities from the Tool bar, click on the respective icon in the tool bar.

Driver Stopped Disabled

Driver Skopped Disabled
Acoustic Echo Ca,,. Driver Stopped Demand Skark
Driver Funning Swstern Stark
P Bus Filker Drriver Running Eiook Skart

S B Driver Stopped Disabled

UTER\User A

Icon Description

Opens Autorun Analyzer utility to view and handle services and programs that were loaded when your
system booted-up.

Opens the 'Quick Repair' interface to troubleshoot and and repair important Windows settings and
features. Refer Repairing Windows Settings and Features for more details.

X

i
4

Open the 'Program Usage Analyzer' window that displays a summary of usage of all the programs
installed in your computer by different users. Refer to Analyzing Program Usage for more details.

Starts the Find Window utility that allows the user to find process related to active application window or
window components. Refer to Finding Process of the Active Window for more details.

i S
W
- I

Opens a 'search’ dialog that enables you to make a quick search to identify the Handles, DLLS that are
triggered or loaded to system memory or mapped files , by entering the name of the object. Refer to the
section Searching for Handles or DLLs for more details.

;{J }
.
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Opens the Windows 'Run’ dialog for executing command line interface programs with default limited user
privileges. Refer to Running Programs from Command Line Interface for more details.

Opens the System 'Information’ panel that shows the graphical representations and statistics of the

details.

usage/history of your system resources. Refer to the section 'Viewing System Information' for more

Click the links below for detailed explanations on KillSwitch Utilities:

«  Viewing System Information;

»  Repairing Windows Settings and Features;

»  Analyzing Program Usage;

«  Searching for Handles or DLLs;

«  Verifying authenticity of Applications;

«  Enable Boot Logging;

*  Running a Command Line Interface program;

*  Running a Command Line Interface program as Administrator;
«  Browsing KillSwitch Logs.

5.6.1. Viewing System Information

The system information pane displays the dynamic graphical representations of your CPU usage, 1/O activity and physical
memory usage of your system, along with the detailed statistics on current usage of various system resources.

»  To view the System Information pane, Click 'View' > 'System Information'.

T COMODO KillSwitch

Marme Hide Safe Processes
= E?E?tem Idle Pro Opaity |
|: [P inkerrupts
Fopcs @ Refresh Mo F5
=1 5vstem Ipdate Speed 3
L= =
irEe.zE »  Performance Graphs
I— [esrss.e
| 5 +  Toolbar
Select Columns. .. |

«  Alternatively, click the 'System Information' icon from the tool bar.

The 'System Information' pane will be opened with the current resource usage details of your system.
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Graphical Reports

«  CPU - Shows a dynamic graphical representation of the usage of CPU over time. You can hover your mouse over the
graph to view details. In multiprocessor operating system, you can make the pane to display individual graph for each
CPU by selecting the check box 'Show one graph per CPU' at the bottom left of the interface.

« 1/0 - Shows a dynamic graphical representation of Input/Output activities of the computer over time. You can hover
your mouse over the graph to view details.

«  Physical Memory - Shows a dynamic graphical representation of the usage of physical system memory over time.
You can hover your mouse over the graph to view details.

«  Network - Shows a dynamic graphical representation of how much network traffic is being used over time by services
and applications running on your computer. You can hover your mouse over the graph to view details.

Statistical Reports

- Totals - Displays a detailed statistics on the number of processes, threads and handles running on the computer.

«  Commit Charge- Displays a statistics on virtual memory allocated to programs and the operating system in KB. As the

memory is copied to the paging file(s) in you hard disk drive , the value listed under Peak may exceed the maximum
physical memory.

»  Physical Memory - Displays a statistics on the total physical memory, also called RAM, installed on your computer in
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KB.
- Total - Represents the amount of total Physical Memory.
« Available - Represents the amount of free memory that is available for use.
«  System Cache - Shows the current physical memory used to map pages of open files.
- Kernel Memory - Shows a statistical report on memory used by the operating system kernel and device drivers in KB.

«  Paged Physical - Memory that can be copied to the paging file from physical memory, thereby freeing the
physical memory. The physical memory can then be used by the operating system.

«  Paged Virtual - Memory that can be copied to the paging file from virtual memory.
«  Non-paged - Memory that remains resident in physical memory and will not be copied out to the paging file.

- Paging - Shows a statistical report on the page faults, The page fault is the direct access to the page that is mapped
in the virtual memory but not loaded in the physical memory.

«  CPU and /0 - Shows a statistical report on the CPU activities and Input/Out put activities of your computer.

Check Boxes

«  Show one graph per CPU - Displays individual graphs for each processor in a multiprocessor operating system.
Hence this option will be enabled only in multiprocessor operating system environment.

B System Information

10,93% (K: 9.37%, LI 1,56%)
2011-12-12 12:06:41

5.6.2. Repairing Windows Settings and Features

KillSwitch allows you to quickly troubleshoot and repair very important Windows settings and features which are other wise hard
to reach. This feature greatly benefits users at beginner level. If crucial Windows settings go wrong, they can be fixed only
experienced and skilled geeks. But with KillSwitch even inexperienced users can troubleshoot and fix those problems with a few
clicks.

To check start repairing the Windows settings and features

1. From the "Tools' menu, click 'Quick Repair...".
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Mame

ﬁ CQuick Repair. ..

|| =1 [ 5ystem Idle Process @ Find Handles or DLLs... Chel+F
(=] Interrupts [} Werify File Signature
="|DPCs
i = Enable Boaok Logaing
T 5stem

= Run... Ckrl+R,

Run as Adminiskrator

Browse logs. ..

N
«  Alternatively, click the Quick Repair icon % from the Tool bar.

The Quick Repair dialog will appear with a list of features that can be repaired and their current status.
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Quick Repair X

Select items to repair;
= Localuser | Name Shatus

Global Profie || EE¥Cmd Console Ok
SYSTEM || g Context Menu O
LOCAL ||| @ control Parel K
SERVICE || msconfig ok
EE;:I;EER K| i My Computer oK
Uiser & _ lf Regedit Ok
Administrator || N OF,
[|[] gA5earch O
QTask Manager Ik
|5y Folder Options Ik
e Hidden Drive Ik
'§ Explorer Ok
(| !Safe Mode O

[ [} Security Center Changed
||| SgDNS oK
& IE Proxy K
Hasts ok
[FExe File QK
#Internet Options (04
) Security Tab O
B UAC OK,

[+ Select Al T ] [ —

Comodo Cleaning Essentials User Guide | © 2012 Comodo Security Solutions Inc. | Al rights reserved

99



Creating Trust Online®

Comodo Cleaning Essentials___;___U.ser'Gt]'ia_é / COMODO

=

You can change the profile from the left hand side pane so as to switch the display of the statuses of the features as per the
selected administrator's/user's profile.

2. Select the checkboxes beside the items you wish to troubleshoot and repair.

Note: The checkboxes will be active only for the items that require fixing. If you want to select all the items that need fixing,
check 'Select All'.

3. Click Repair. KillSwitch will automatically fix the errors in the settings of the selected item. A completion dialog will

appear.
COMODOD KillSwitch *

1 ) Repair complete!

5.6.3. Analyzing Program Usage

The Program Usage Analyzer displays usage details of programs and Windows components installed on your system along with
other details such as their last run time. Usage details can be viewed on a per user basis - useful when you want to analyze
overall usage when deciding which programs to keep or remove when optimizing your computer.

To view the Program Usage Analyzer pane

«  From the 'Tools' menu, click 'Program Usage Analyzer'.

FF COMODO KillSwitch

Mame < i Program Usage Analyzer... >
....... -

| (=) [T System Ide Proc b Eind Handles or DLL. .. Chtldfe—
[Inkertupts [J Verify File Signature
FoPcs

Enable Boot Logging

..... s, o ™ PRun... Chrl4+R

Run as Administrator

Browse [ogs. ..

_f:f-'*!: ~
I.
«  Alternatively, click the 'Program Usage Analyzer' icon * from the Tool bar.

The Program Usage Analyzer dialog will appear with all the programs as the user profile of the currently logged-in user.
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Mame Path sage Lask run time Stakus | *
E adobe Reade. .. C\Program Filesiadobe\Reader 9.0Reader... Yery Rarely 2011012012 10135

3 Character Map  CHWINDCWS\systern32icharmap, exe Meser or &lm,,, 2011/12/09 11:32 =
@ Comodo Dragon C:\Program Files\ COMODOYDragontdragon. ... Regularly 2011/11/23 16:44

@CDdeD Dragon :\Program Files\ COMODODragonuninstall, .. Mever or &lm.,. 201171101 10:21

WFireFDx C:\Program FilestMozilla Firefoxfirefox.exe  Regularly 2011012112 0953

OGDDQIE Talk, C:\Program Files\Googlel Google Talklgooale, .. Never or Alm,.. 2011012/08 12:23

féInternet Expl... Z:\Program Files\Internet Explorerliexplore... Regulark 2011/12/12 11:30  Running

@0 Micrasoft (R) ... CHWINDOWS! Syskem32\WScript exe Mever or Alm,,, 2011/12/02 1527

% Microsoft Ma,.. CYWINDOWSsystem 32 mme, exe Mesver or &lm,., 2001/06/17 10:12

3 Motepad CWIRDOWS sy stem 32\ MOTEPAD EXE Very Rarely 2011012012 12:12  Running
ﬁ@penOFFice.D... Z:\Program Files\Opendffice.org 3\program. .. Mever or Alm... 2011711710 10:32 hd
4 m 3

Scan Folders

[# <Program Files=

B cwindovss [ Include missing programs
indows

[C] Cther Folders

Program Usage Analyzer - Descriptions of Columns

Column Description
Name Shows the name of the program/application. Clicking the column header sorts the entries in
alphabetical order of the names.
Path Shows the installation path of the program/application.
Usage Shows the frequency of usage of the program/application.
Last Run Time Shows the date and time at which the program was executed last time.
Status Shows the current running status of the program/application.

- To view the usage of the program by other users, select the user profile from the ‘User' drop-down.
- Tofilter the entries based on their installation paths, select the folders for scanning from the 'Scan Folders' area.

«  Toinclude programs/Windows components which were uninstalled from your computer, select 'Include missing
programs' and click 'Run Scan'.

«  Right clicking on an entry enables you to open the installation folder of the program and to access the process invoked
by the program.
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«  Open Containing Folder - Opens the installation folder of
the program in Windows Explorer. sk Syskem Confi.. S

< Goto Process - Highlights the process associated with the LJRunaDLLas ... CiWINDOW

program in the 'Processes’ window. This is useful when you | Wy Paint £ WINDDWSW
want to terminate or suspend the process associated with the '
program. Refer to Stopping, Starting and Handling

Processes for more details. This option will be available only
for the programs that are currently running. y

Cpen Conkaining Folder

Goko process

5.6.4. Searching for Handles or DLLs

The 'Find Handles or DLLs' tool enables you to search for specific handles, DLLs and mapped files of the currently running
processes by entering their names.

To search for a specific handles, DLLs and mapped files

*  From the 'Tools' menu, click 'Find Handles or DLLs'".

Y COMODO KillSwitch

Wbtk ‘ Autorun Analyzer
Procesze:z (23 #2 Quick Repair...

Marmne

L L Esvc O FindHandles or DLLs... Chrl+F >
[lsass.exe [y wen

=] ' explorer.exe

Enable Boaok Logging

& iexplore, exe

[ KillSwitch, exe O Run... Chrl+R
rspaink. exe Fun as Administrakor
Browse logs, ..

-

-# 1
[
«  Alternatively, click the Find Handles or DLLs icon & from Tool bar.
The 'Find Handles or DLLs' dialog will open.

Handle or DLL substring: | | [ Search H Cancel l

Process PID Type Handle ar DLL

=There are no ikems to show =

«  Enter the name of the object you wish to search, in the Filter text box. The entered string can be a sub-string of the
object name. The search key is not case-sensitive

«  Click 'Find".
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The results window will contain the process(es) associated with the object, the type of the object and its handle as a table.

Handle or DLL substring: | explorer [ Search ] [ Cancel ]
Process PID Type Handle or DLL -
iexplore, exe 3620 DLL C:\Program Files\Internet Exploreriieprosey . dil
igxplore, exe 3620 DLL C:Program FilestInkernet Exploreriiexplore . exe
igxplore, exe 3620 DLL C:\Documents and Settings\aividharaniLocal Sett, .
igxplore, exe 3620 DLL C\Program FilestInternet Explorerxpshims, dl
iexplore, exe 2412 Handle \REGISTRYYIUSERYS-1-5-21-1708537763-746137...
igxplore, exe 2412 Handle \REGISTRYUSER1S-1-5-21-1708537768-746137...
igxplore, exe 3940 Handle \BaseMamedObjeckstC:_Documents and Settings. ..
igxplore, exe 2417 Handle YREGISTRY\MACHIMNENSOFTWARE MicrosaftInt, ..
iexplore, exe 3940 Handle \REGISTRYYIUSERYS-1-5-21-1708537763-746137... |
igxplore, exe 3940 Handle C:Dacurnents and Settingsiaividharaniapplicatio. . =
igxplore, exe 3940 Handle \REGISTRYYJSER1S-1-5-21-1708537768-746137...
igxplore, exe 2412 Handle YREGISTRYUSERYS-1-5-21-1708537768-746137..,
iexplore, exe 2412 Handle \REGISTRYYIUSERYS-1-5-21-1708537763-746137...
igxplore, exe 2412 Handle \REGISTRYUSER1S-1-5-21-1708537768-746137...
igxplore, exe 2412 Handle YREGISTRY\MACHIMENSOFTWARE Microsaft Int, ..
igxplore, exe 2417 Handle |BaseMamedObjecks!Internet Explorer Immukabl, ..
iexplore, exe 2412 DLL C:\Program Files\Internet Exploreriieprosey. dll
iexplore, exe 2412 DLL C:\Program Files\Internet Exploreriexplore.exe
igxplore, exe 2412 DLL C:\Documents and Settings\agividharaniLocal Sett, .
iexplore, exe 2412 DLL C:\Program FilestInternet Explorerxpshims . dl L,

#

Handle or DLL search results window - Descriptions of Columns

Column Description

Process Shows the name of the process triggered by the handle or the DLL. Clicking the column header sorts
the entries in alphabetical order of the process names.

PID Process Identification number of the process. Clicking the column header sorts the entries in
numerical order of the PIDs.

Type Shows whether the process is triggered by Handle or DLL.

Handle or DLL Shows the Handle or the DLL that has triggered the process along with its storage location.

5.6.5. Verifying Authenticity of Applications

A software application can be treated 'Trusted' if it is published by a Trusted Software publisher/vendor. To prove the authenticity
of their executables, software publishers digitally sign their software using a code signing certificate obtained from a Trusted
Certificate Authority (CA). If you would like to know more about this process, refer to Background details later in this section.

To check whether an application/program installed in your computer is digitally signed:

«  From the "Tools' menu, click 'Verify File Signature...
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r® COMODO KillSwitch

itch  Options  Wiew

€ Autorun Anslyzer

Processes (18) 42 Quick Repair...
Mame ¥ Program Usage Anakyzer, .

=I [ 5ystem Idle Process =@ Find Handles or DLLs..,  ChrT
: Z]Interrupts < [J  Werify Filz Signature >
DR Cs
= W
[T 5wstem

L "'“"!c o EYE :ﬂ Run,.. CtrI+R

Run as Adminiskrakor

Browse logs. ..

The 'Verify Signatures' dialog will be opened.

I Verify Signatures X

File Mame Signer

=There are no ikems to show >

[ Include files in subfalders Select Files ] [Sele-:l: Falder

el

You can check the authenticity of a specific executable or make KillSwitch to scan a folder to identify all the .exe, .dll, .msi and
.sys files in it and verify their authenticity.

- To check the authenticity of specific file, click 'Select Files'...
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__J “Fcuckon Music Player:

ﬁ-_ Cuckoo Music Editor

ky Documents

by Computer

File name: | Cuckoo Musgic Plaver L!
Files of type: Signable Files [ sps: exe:” dll7 mei] L! Cancel

My Metwork [C] Open as read-orly

Gﬁf

...and navigate to the folder containing the files of the program and select the binary/executable file.

«  To scan a folder for binaries and verify their signatures, click 'Select Folder'...

Browse For Folder ? X

|5 ComPlus applications -
29 Cuckoo MP
|53 Inkernet Explorer
I3 Messenger
I3 microsoft frontpage
I3 Microsoft Sikverlight
I3 Mowie Maker

i =
|5 MSM Gaming Zone
(= w1 amm e h
l m 3
Make Mew Folder l [ Ik l [ Zancel

A

... and navigate to the folder. KillSwitch will identify the .exe, .sys, .msi and .dll files in the selected folder. If
you want KillSwitch to check the files in the sub-folder(s) of the selected folder, select 'Include files in
subfolders'.

KillSwitch will immediately scan the files and if signatures are present, displays the signer information under the Signer column
else, leaves the column blank.
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Bl Verify Signatures [(Verification completed) X

File Mame Signer

[ Include files in subfolders Select Files l [Select Falder

&)

Background

Many software vendors digitally sign their software with a code signing certificate. This practice helps end-users to verify:

»  Content Source: The software they are downloading and are about to install really comes from the publisher that
signed it.

»  Content Integrity: That the software they are downloading and are about to install has not be modified or corrupted
since it was signed.

In short, users benefit if software is digitally signed because they know who published the software and that the code hasn't
been tampered with - that are are downloading and installing the genuine software.

The 'Vendors' that digitally sign the software to attest to it's probity are the software publishers. These are the company names
you see listed in the first column in the graphic above.

However, companies can't just 'sign’ their own software and expect it to be trusted. This is why each code signing certificate is
counter-signed by an organization called a ‘Trusted Certificate Authority'. '‘Comodo CA Limited' and 'Verisign' are two examples
of a Trusted CA's and are authorized to counter-sign 3rd party software. This counter-signature is critical to the trust process and
a Trusted CA only counter-signs a vendor's certificate after it has conducted detailed checks that the vendor is a legitimate
company.

If a file is signed by a Trusted Software Vendor and the user has enabled 'Trust Applications that are digitally signed by Trusted
Software Vendors' then it will be automatically trusted by Comodo Internet Security (if you would like to read more about code
signing certificates, see http://www.instantssl.com/code-signing/).

One way of telling whether an executable file has been digitally signed is checking the properties of the .exe file in question. For
example, the main program executable for Comodo KillSwitch is called 'KillSwitch.exe' and has been digitally signed.

- Browse to the folder containing the Comodo Cleaning Essentials files

« Right click on the file KillSwitch.exe.

«  Select 'Properties' from the menu.

«  Click the tab 'Digital Signatures (if there is no such tab then the software has not been signed).

This displays the name of the CA that signed the software as shown below:
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KillSwitch Properties

| General | Yersion | Compatibiity | Digital Signatures | Sumrmary |

Signature lizt

Mame of signer: E-mail address: Timesztamp

Comodo ity ... Mot available Tuesday, Hovember ...

Dretailz

Select the certificate and click the 'Details’ button to view digital signature information. Click 'View Certificate’ to inspect the
actual code signing certificate. (see below)

Digital Signature Details [ Certificate

General | Advanced | eneral | Details | Certification Path |

Digital Signature Information
This digital signature is OF, Certificate Information

This certificate is intended for the following purpose(s):

Signer information "
=Ensures software came from software publisher

Mame:; |Comod0 Security Solutions, Inc, +Protects software from alteration after publication
E-mail; Mot available »

et 1
Signing time: |Tuesdary, Movember 29, 2011 &:15:10 AM

* Refer to the certification authority's statement For details,

‘ Wiew Certificate ’

Issued to:  Comodo Security Solutions, Inc,

Counkersignatures
Issued by: UTN-USERFirst-Object
Mame of signer: E-mail address: Timestamp
COMODO Time 5... Mot available Tuesday, Mowvember ...

yalid from 4/5/2009 to 4/3/2012

’Install Certificate...] ’ Issuer Skatement ]

It should be noted that the example above is a special case in that Comodo, as creator of 'KillSwitch.exe', is both the signer of
the software and, as a trusted CA, it is also the counter-signer (see the 'Countersignatures' box). In the vast majority of cases,
the signer or the certificate (the vendor) and the counter-signer (the Trusted CA) are different.

5.6.6. Boot Logging and Handling Loaded Modules

The Boot logger feature records all the modules loaded when your system boots. These include items like drivers, system files,
DLLs, executables and so on. KillSwitch displays these modules along with their attributes and a trust rating under a new
'Loaded Modules' tab after your system has rebooted. This functionality allows you to check whether unsafe (or even just
unwanted) modules are being loaded. In extreme cases, it will allow you to detect and delete malicious boot items installed by
spyware, key loggers, rootkits or other malware.
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To configure for Boot Logging:

1. From the "Tools' menu, click 'Enable Boot Logging'.

r* COMODO KillSwitch

CillSwitch  Oplions

Wiga

g Syskerm _Dmr"_i Mebwark, '. Bukorun Analyzer
Processes (18) 42 Quick Repair. ..
Marme i Program Usage Analyzer..,
(=) Fswstem Idie Process | @ Find Handles or DLLs...  Chrl+F
| et L PSR —
DPCs
i = Enable Eoot Logging
=1 Gvstem
|-__—_! [smss.exe T ==
" i (== Run as Administrakor
- B winlogon, exe
. Browse logs. ..

KillSwitch will request a restart of your computer to log all the modules that are loaded during the next re-boot

COMODO KillSwitch

KillSwitch is configured o log loaded modules during next boaot,
Do wou wank bo restart swskem now?

ves ][

2.

Save all your work and click 'Yes'. Your system will re-start. Upon restart, KillSwitch will be started automatically and
show all the loaded modules loaded to your system.
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-

Mame Path Load Timels) Rating Descripkion
Iu:ucalspl.u:lll U INDOW S sy skem 32 localspl.dll 41,2810 5afe Local Spoole
pilrary, dll C i TMDOW S syskem 32 pilmon. dil 41,2960 5afe PIL Languar
tcpron. dil e TMDOW S syskemn 32 boprnon, dll 41,2960 Safe Standard TC
usbrman, dil A T S sy skem 32 usbmon, dil 41,2960 3afe Standard Dy

cnbjmon,dil C TMDOW S, syskem 32 enbjmon. dll 41,2960 3afe Langage Mo

winZzspl,dll A TMDOW S, sy skem 32 win32spl.dll 41,3120 3afe J2-hit Spool
inetpp.dll CHWINDOWS) svstem32linetpp. dil 41,3280 Safe Internet Prir
netrap.di C 41, fe Met Remoke]
jscript.dll CUWINDOW S sy skem 32 jscript, dil 42,7340 Safe Microsofk (R,
drproy, dil CUWINDOW S syskem32idrproy. dll 75,3590 Safe Microsofk Te
ntlanrman. dil U INDOW S sy skem32yntlanman, dil 75,3590 Safe MicrosofkE
netuid. dil C TMDOW S sy skem 32 netuii, dil 75.3590 5afe BT LM UL Cc
netuil. dll C TMDOW S sy skem 32 netuil . dil 75.3590 3afe BT LM T Cc
davclnt.dll A TMDOW S, syskem 32 davcint, dll 75,3590 3afe w'eb Dl O
browselc, dll A TMD W S sy skem 32 brovweselc, dll 75,8590 3afe Shell Brovse
5

riched3z.dl CHWINDOWS svskem32iriched 3z dll 79,9060 Safe Wrapper DIl
ﬂ wiaucl, exe CHWINDOW S system32wuaucl, exe 82,0310 Safe Automatic U
@wuaucpl.cpl CUWINDOW S sy skem 32 wuaucpl,cpl 82,0460 Safe Automatic U-—
wups.dll CUWINDOW S syskem 32 iwups. dll 82,5000 Safe Windows Lp .j
] [} 3

UNXOMAm-

CPLU Usage: 0. 5 SMITHSCOMPUTER John Sriith

Loaded Modules window - Descriptions of Columns

Column Description

Name Shows the name of the module. Clicking the column header sorts the entries in alphabetical order of
the module names.

Path Shows the storage path of the module.

Load Time (in Shows time taken for loading the module.

seconds)

Rating Shows the result of scanning performed by KillSwitch on the module. Modules that are rated as unsafe

or unknown will be highlighted for easy identification.

Description Shows a brief description of the module.

Company Name Shows the vendor of the module.

Tip: Clicking any of the column header sorts the list in alphabetical/numerical order of the entries in it.

Filtering the Loaded Modules List

You can filter the list to hide the modules identified as 'Safe’ and show only the modules identified as 'unsafe' or 'unknown' by
clicking View > Hide Safe Loaded Modules.
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*_;I localspl, dl
%] pilrnan. i
) teprnon, il
= usbrmon.

wwinz2spl, dll
linetpp.dil

d

jscripk.dil o

drprovw.dll

E| cnbjmon.dil @

Tools  Users  Help

Systemn Information

CErl+I

Shows Cnly the Unsafe Images in Memory
Hide Safe Processes

Hide Safe Loaded Modules

Opacity

Refresh Maow

IJpdate Speed

FS

Performance Graphs

Toolbar

Select Columns., .,

Handling Loaded Modules
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You can viewing properties of or remove loaded module by right clicking on it and selecting the required option from the context

sensitive menu.

%) trkwks. i
TS5erv, exe
v w3z.dl
I:a] umpnprngr. dil
unarch.cay

| |e=1] uniirndrn. bsp
uniplat. dll

Delete

Cpen Conkaining Folder
Properties. ..
Search Online

Send to COMODD »

«  Delete - Removes the Module from your system. This ensures that the module is not loaded to your system from the

next boot onwards.

«  Open Containing Folder - Opens the folder containing the module in Windows Explorer.

»  Properties... - Opens the properties dialog of the selected Module.
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T55erv Properties

General | Campatibility | Summary |

T |TSSEW |

Typeof file:  Application

Descrption:  TS5ery

Location: E:hwirug zampleshTrojanSimulator
Size: 145 KB [148,332 bytes]
Size on dizk: 143 KB [151.552 butes)

Created: konday, December 05, 20017, 10:32:35 AM
M odified: Thurzday, December 01, 2011, 12:12:54 PM
Aoceszed: Today, December 13, 2001, 12:38:31 PM

Attributes: [ |Read-only [ Hidden

] l [ Cancel

«  Search Online - Opens the default web browser of your system with the search engine specified and searches for
information on the module on the web.

»  Send to COMODO - Submits the module for analysis to Comodo, as False Positive (if identified as suspicious by
KillSwitch) or as Suspicious file as selected from the sub-menu. You can submit the files which you suspect to be a
malware. The files will be analyzed by experts and added to global white list or black list accordingly in order to benefit
all the users of Comodo security products world wide.

Properties. ..

Search Online

Send to COMCODC r Report False Positive

Feport Suspicious

5.6.7. Running Programs from Command Line Interface

KillSwitch allows you to run Command Line Interface programs with the account privileges of currently logged-in user or those
requiring administrative privileges from its 'Tools' menu.

To run a program with the currently logged-in user privileges:

< From the "Tools' menu, click 'Run’.
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B4l system _L‘m'::: Metwork @ sutorun snalyzer
Proceszes (22) ﬁ Quick Repair. ..
Marme i Program Usage Analyzer,.,
=1 [ 5ystem Idle Process @ Find Handles aor DLLs... ChHF
@Interrupts [J Werify File Signature
Fopcs
=1 [77] System pue qarg —
L;| jsmss.exe< & Run... Chrl+R >

=\ csrss.exe riniskrato

8 winlogon. e
L_l ™ ceriics Browse logs. ..
+  Alternatively, click the Run icon from the toolbar. The 'Run'’ dialog will open.

- Type the name of a program, folder, document, ar
'E Internet resource, and Windows will open it for you,

Qpen: Enter the command here| ﬂ

o | [ concel | [Loromsens |

«  Enter the command or browse to the file/program you wish to open by clicking 'Browse'".
- Click 'OK..
To run programs that require Administrative privileges:

*  From the 'Tools' menu, click 'Run as Administrator'.

r* COMODO KillSwitch

itch  Options  Wiew

Ed System :‘LHE:: Mebwork ﬁ fukorun Analyzer
Proceszzes (24) ﬁ Quick Repair...
Mame i Program Usage Anakyzer.,.
=[] 5ystem Idle Process & FindHandles or DLLs...  Chrl+F
@Interrupts [J Werify Fil= Signature
Coecs Enable Boot Logai
nable Boot Logagin
= [Ty stem gang
Lz = = _Bun Chr
=™ smss exe
jcsrss-i Fun as &drninistratar
8 virlogon: '--_..Em_ p—
[— | . i L.\ e

The Run dialog will open.

Comodo Cleaning Essentials User Guide | © 2012 Comodo Security Solutions Inc. | Al rights reserved 112



Creating Trust Online®

Comodo Cleaning Essentials;’___;___U.ser'GJiaﬂes_f A COMODO

=

»  Enter the command or browse to the file/program you wish to open with administrative privileges by clicking 'Browse'.

= Type the name of a prograrm, Folder, document, ar
-'E Internet resource, and Windows will open it Faor wou,

Qpen; Enter the command here ﬂ

Fun the program wikh adminiskrator priviledge,

o | [ concel | [Loromsens |

«  Click 'OK".

5.6.8. Viewing KillSwitch Logs

KillSwitch maintains logs of threats found and actions taken against them as configured through 'Options' > 'Threats Log Level'.
The logs are stored as date stamped text files in the folder ...\CCE\Data\KillSwitch\KsLogs.

To view the log files:

«  From the 'Tools' menu, click 'Browse Logs'.

r® COMODO KillSwitch

witch  Options  Wiew Users Help

[_" Swskem _E'EE‘: Mebwiork ° Autorun Analyzer
Processes (22) 42 Quick Repair...
Mame i Program Usage Anakyzer.,..
=IF5ystem Idie Process | @ Find Handles or DLLs...  CirkF
@Interrupts [} werify File Signature
LJbPes Enblc Bortloeai
nable Book Loggin
=[] 5wstem 99ng
L;I [smss.exe S Run... Chl+R
[T)csrss.exe
i winlogope
|—I = Browse logs. ..

The logs folder will open in Windows Explorer.
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File Edit ‘iew Favorites Tools  Help i
__,.-' \_J,l l.ﬁ /-] Search [f—" Folders *
fddress |lﬂ Ci\Dacuments and Settings)Jser AlDeskkophcce_2,2, 217700, 170 32V CCE DataKillswitchiKsLogs b | Go
Folders X lswitch_20111213_150552 M KillSwitch_20111213_ 150659
@ Deskkop == | TextDocument == | TextDocument
B My Documents = LKB =4 0KB
3 My Computer ¥ KillSwitch_20111212_150000 S KilSwitch_20111212_170652
‘:} My Metwork Places ==| TextDocument == | Text Document
# Recycle Bin =1 1KB = LKB
= [E.gfé.zmnn. . ¥ KillSwitch_20111211_143521 ¥ KilSwitch_20111211_122320
= IEI Data ;__‘-——-_: IEKXEE Dacurent ;__‘-——-_: IEKXE'E: Dacurent
[C3) Autorun Analyzer - -
I ccE
= ) KillSwitch
[0y database
EI Durnps
l'-f? KsLogs
|53 database
[EI Logs
Ia sCcanners
[5) themes
[C5) Translations

«  Double click on the file you wish to view.

5.6.9. Finding Process of the Active Window

The 'Find Window' tool enables you to identify the process associated with the active application window or the window
components in it.

To find the process related to active application window:;

1. Click on the Find Window icon in the Toolbar.

2. Drag the bulls-eye to the portion of the window for which you want to find the process
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3 Diesel locomotive - Wikipedia, the free encyclopedia - Microsoft Internet Explorer

File - Edit - Wigw

Favarites

Tools: = Help ,—?

@Back 3 \_J @ @ -{”;j:pﬁearch ‘*-51? Favarites @ @* :\;

Address |@ hitkp: f fen wikipedia, orgfwiki Dissel_locormative V| Go  Links *
& Loginfcoreate account g
o . &5—. =
*’f ko 13 & @
a i R = | |
2 C) W . Adticle  Discussion  Edit  Wiew history | Search Q|
B 8 i
N i . .
' Diesel locomotive
WIKIPEDIA - .
The Free Ercyclopedia Frarm wikipedia, the free encyclopedia
N~ A diesel locomotive
Mavigation . .
is a type of railroad
Main page locormative in which
Cantents the prime maover is a
Featured content diesel engine, a
Current events recipracating engine
Randorm aricle operating on the
Donate to Wikipedia Diesel cycle as
invented by Or. Rudolf
FErEEE Diezel. Several types
of diesel locomative :
Help have been developed, Three styles of diesel locomotive body: cab unit, hood & i3

@ http:ffen. wikipedia. orgfwikiMain_Page

‘ Inkernet

3. On release of the mouse button, the process related to the highlighted window will be shown highlighted in the
'Processes' window of KillSwitch.

¥ COMODO KillSwitch

Wiew

Procezzes (26)

Tools Users Help

()
e

Marne

PID Rating Sigrer CPU
L@ ﬁsnﬂ“ice.exe 4037 Safe Z,228 KB SMITHS
L [=catii b ZLE6E KB SMITHS

Working Set User Neﬂ

Pl W T )

Microsoft Winda, ..

Applicationz (7)

| Caption
untitled - Paint

My Diocumnenks

Process ID

184
1996

5.7.Managing Currently Logged-in Users

The 'Users' menu in the file menu bar lists the user(s) that have logged-in to the system either directly on to the desktop or
through remote desktop connection. You can easily switch the user, log-off and communicate with a concurrently logged-in user
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(either locally or through remote desktop).

To view the the currently logged-in users, click the 'Users' menu from the file menu bar.

T COMODO KillSwitch

itch  Options vy Tools Help 5
[_J Swskern E-L:: Metwark 0: SMITHSCOMPUTER Jser A

1: SMITHSCOMPUTER) Jser B 3

Processzes (28)

Marne PIC Rt
| [T Svstem Idle Process
I ) )

Hovering the mouse cursor over an user opens an options panel with the following options:

¥ COMODO KillSwitch

ditch Oplions  Wiew  Tools

E Sysbem _E'r_il':_i Mebwark. 0: SMITHSCOMPUTER \User & Disconnect
Processes (27) 1: SMITHSCOMPUTER User B 3 Logaff
Marne PID R.aking 3 Send Message
| =177 avstem Idie Praocess ] Properties
[TMinterrupts
= DN e

- Disconnect - Enables you to disconnect the connected user account from your Windows session.
»  Log off - Forcedly logs-off the selected user from your computer.

- Send Message - Opens a message dialog that enables you to communicate your messages like information,
warnings, questions etc. to the selected user.

Send Message X

Messane kitle:

Message From SMITHSCOMPUTER \User A

Message:
Hi Bioh,
You can collect vour files From Alice,

-Jahbin

K, l [ Cancel

To send a message to a selected user

»  Enter your message in the "Text' field and click OK.
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Tip: Press 'Ctrl' + 'Enter' for moving to next line while typing messages with more than one line. Pressing just 'Enter' from your
keyboard will immediately send the message.

The message will be displayed in the user's desktop.

Message from SMITHSCOMPUTERWser A |

Hi Bah,
ou can colleck your files from alice,

-Johin

- Properties - Opens the 'Properties’ dialog of the selected user, that displays the user's session properties.

ser name: SMITHSCOMPUTER User B
Session 1D Z

State: Active

Client name: MIA

Client address: I

Client display resolukion; I

5.8.Help and About Details

The 'Help' menu in the file menu bar enables you to access the online help guide and know about the version number of
KillSwitch in your system.

T COMODO KillSwitch

kch Options  Wiew  Tools  Users

Ed system E-E_ Metwork Search  Fl
Processes (28) About

Marne

Clicking on the Help menu has the two options:
« Search
«  About

5.8.1. Help

Selecting the 'Search' option from the Help menu opens the online help guide hosted at http://help.comodo.com/. Each area
has its own dedicated page containing detailed descriptions of the application’s functionality.
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/~ Comodo Cleaning Essentials - Introduction | The security products, anti virus - Windows Internet Esp

g? - |e, Ptk help, comado, comybapic- £ 19- 1-328-35 16-Ink L-.'J-.'-E @ “? X I Barg 2.

<= Favorites @Cumndnauring&untiuk-lrtmductim|Thusacur...| | Y - Bl - ) #m - page~ Safety~ Tools- - 7

Find the desired product help Comodo Cleanng Essentas  =fii23 =]

])’ Comodo Cleaning Essentials VErSOR oY ENgis
i

Introduction To Comodo Cleaning Essentials

E- Introduction To Comodo Cleaning

Easemtials Introduction to Comodo
System Requirements ESse n ti a IS

“Downloading Comodo Cleaning
Essentials

_ . - - anmines Coaa sl El ie 3 =at o - = v Fanle Aasi
“Starting Comaodo Cleaning Comodo Cleaning Essentials (CCE) is a set of computer security tools desig
: remove malware and unsafe processes from mfected computers.
Essentials

“The Main Interface Major features include:

FlScanning Your System « KillSwitch - an advanced systam monitoring tool that allows users to

. . . unsafe processes that are runming on therr system.
Configuring Comodo Cleaning

Essentials +« Malware scanner - Fully customizable scanner capable of unearthing
F'The Tools Menu hidden files and malicious registry keys hidden deep in your system.
*Introduction To KillSwitch » Autorun Analyzer - An advanced utility to view and handle services :

' Introduction To Autorun Analyzer when your system booted-up. =
| | LI_I
._ [ ..... | ...... [ ..... —_— e e |'a’t' ExTTw /}

You can also print or download the help guide in pdf format from the webpage.

5.8.2. About

Clicking the 'About' option from the Help menu opens the 'About' information dialog of KillSwitch.

About COMODO KillSwitch ®

E COMODO KillSwikch
Product Yersion: 2.4,219500,176

Patents Pending
Copyright (o) 2004-2011 COMODO, Al rights reserved,

The About dialog displays the Version Number of KillSwitch and the copyright information.
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6.Introduction to Autorun Analyzer

The services, drivers, system files, programs and so forth, that are loaded when your system boots-up can have a significant
impact on the security your system. Certain programs and services must be loaded at start-up because they are essential to the
security and smooth operation.

Unfortunately, any malware will add a start-up item, and make it to run at the background, to pave way for malicious attempts
like key logger, rootkits, buffer overflow or Denial of Service (DoS) attacks. These attacks will be running silently in the computer
and enable hackers to steal your identity and confidential information like your credit card details.

The Autorun Analyzer makes a thorough check on the Start-up items that are loaded during system start-up and shows them as
a list with their threat rating. The interface allows you to choose precisely which programs and services are to be enabled and to
delete the items that are identified as malware.

The Autorun Analyzer section of this guide is broken down into the following sections:
* Introduction to Autorun Analyzer

«  Starting Autorun Analyzer
«  The Main Interface
«  Viewing and Handling Autorun Items

« Handling Autorun ltems

Filtering Entries based on Categories

«  Viewing Autorun Items for other User Accounts
*  Help and About Details

6.1. Starting Autorun Analyzer

Autorun Analyzer can be started by the following ways:
«  From the Comodo Cleaning Essentials interface
«  From the KillSwitch interface

»  From the folder containing Comodo Cleaning Essentials files

6.1.1. From the Comodo Cleaning Essentials Interface

»  Click '"Tools' > 'Open Autorun Analyzer' from the title bar controls of the main interface of Comodo Cleaning Essentials.
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COMODO —

Cleaning Essentials Cptions = v Helpw

Cuarantined Ikems. ..
Start Scan Manage Trusked Yendors. ..

Start a scan to unearth and remove viruses, rootkits, hidden files and malicious registn Import Yiros Database
hidden deep within your system.

Browse Logs. ..

Cpen KillSwitch
Open Aukarun Analyzer

The Autorun Analyzer main interface will be opened.

6.1.2. From the KillSwitch Interface

«  Click 'Tools' > 'Autorun Analyzer' from the file menu bar of the main interface of Comodo KillSwitch.

T COMODO KillSwitch

Program Usage Analvzer. ..

=[] 3vstem Idie Process Find Handles or DLLs... Ckrl+F
B3

': [ interrupts

Werify File Signature

oPcs :
— Enable Book Logging |
4
= Run... Ctl+R
Applicati
geligslisns (0 Run as Adminiskrator i
Caption
Browse logs., ..
Or

«  Click the Autorun Analyzer icon from the Toolbar, beneath the main display pane of KillSwitch interface.
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Display Mame Tvpe Skatus Skark Tvpe
dsk, Abinsdsk Drriver Stopped Disabled
HE0NS abp4a0ns Drriver Stopped Disabled
FI i Driver Funning Bioak Skart

Criveer Stopped

Disabled

The Autorun Analyzer main interface will be opened.
6.1.3. From the Folder Containing Comodo Cleaning Essentials Files

«  Navigate to the folder containing the Comodo Cleaning Essentials files

«  Double click on the file 'Autoruns.exe' from the Windows Explorer window.

File  Edit View Favorites  Tools  Help

@ Back - \_a-'l l.@ /__j Search [{TL' Folders . "
fAiddress |@ Cilcoe_2.2. 217700, 170_x32\CCE V| GO
Folders X e, P T o

@ Desktop

My Dacuments

-j’} Data I-:’) database
| |
= :J My Carmpuker Fap T o
J 315 Floppy (a0 -/} Logs -/} SCaMMers
[= % Local Disk (C:0 L !

'-"l

|

|C5) 035aa049d750a50b80
[ BoneyM Ir
= ) cee_2.2,217700,170.

themes Translations
|

ey |
i) Data | o I 7za.dl Autaruns
) datab "ﬁ 9.20.0.0 COMODD Cleaning Essentials
SEEli=Ee 7z Standalone Plugin . COMODO
I Logs
=) scammers — | _ boot CCE
3 themes H DAT File COMODO Cleaning Essentials B
. &4 KB COMOD0
|3 Translations
[C5) Documents and Settic [ B coedi [ 5
I Dragon “ﬂ 2.2.21092.170 "ﬂ CCEImageres.dl
|3 Program Files COMODD Cleaning Essentials
|3 Quarantine -
ccekrnl | o dbghelp.dl
& Share V. DAT File ‘ﬂ;l £.12.2.633
< I | > 297 KB ‘Windows Image Helper b

The Autorun Analyzer main interface will be opened.
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6.2. The Main Interface

Autorun Analyzer's streamlined interface provides access to all important features and options of the application at finger tips.

COM0D0 Kutoren Analyrer

File Menu Bar - SETESTENTENETY

P e Qe W o By Descripbion | Publicher Famg | Image Path

77 Evaryfhng (863) =) S HELMY SOFTWARE Microsofit', Active Setup’, Installed Components -
& Logon (25) - W [Paddress... Cutlook Bx,.. Microsoft Corpo... Safe Z:WProgram Flles\Dutiook Exprass'se. .,
B Esplorer (347 B [Sntemat . Windows S, Microsoft Corpa.., Safe CIWINDOWS sysiemaisstupapdll

£ Inerret Explorer F O mtemeat ., Windows N, Microsoft Corpa,., Safe CIWINDOWS\sysiam32ishmarate exe

(3 F R Emtemet .. E S0 Per-.. Miorosoft Corpo.., Safe COMINDOWS sysemAZEduinitess
& Schaduled Tagks B Mozl Outhook Bx.., Microsoft Corpa... Safe CProgram Files\Dutioo: Exprassae..,

(i)

- B Sl ADVPACK Micresoft Corpa... Sale CIAINDOW S avse a2 achvpack. dil

F*Muuml’.. Microsoft ... Micresoft Corpa... Sahe COMINDOWS, inPunreg mp s
P = Mrasaf .. ain Display
H [§n/a Microsoft ... Microsoft Corpa... Safe COINDOWS \sysemiddymscones. dil P-EI"E

- REnfa

- W [S)nemviest., . ADVFACK  Microsoft Corpo... Safe CHWINDOWS systemiaziacpack. dil
o FSoutook .. Windows I, Microsoft Corpa,., Safe COWINDOWS syt mazishmirate exe

& Sarvices (B7)

Crivers (152)

Category
Selection
Pane

Boot Execuis (1)
Irnage Hijacks (35}

L]
S Codecs (167)
—
i
[E] appinit: (0

4 KnownDLLe (20) I P Themes.., Mirosoftic,., Microsoft Corpa.., Safe  CIWWINDOWS\systemaziegew 32000
A winlogon {13) - Mwindow. ., Miorosoft(C... Microsoft Corpo.., Safe  CIWINDOWS\aysemaZiyegew 32 e
@ ‘Winsack Providers L @ [§wirdow... ADVFACK  Microsoft Corpa,., Safe  CrWWINDOWS\systema2\achpack,dil
o 1 i VLA, SOFTWARE ' Microsolt, Windows NT', DurrentVersion’, Winlogon', Shell
ta Prit (7} L= P Eaplorer... Windows E... Microsoft Corpa... Safe CUNINDOWS B plorer e
; L= '"l";" 00 W) i LM, SOFTWWARE' Microsalty, Windows AT, CurrentVeer sion', Winlogon', Liserinit
Meatwork (25

FIECAAWRL., UseriritLa... Microscoft Corpo... Safe CWINDOWS systamild ser it one
| S HELM, SDFTWARE " Microsoft’, Windows", Current Version', Explorer', SharedT askScheduler

E ecplorer.exe  Saw; 1,009,508 ‘Wndoves Explorer
9‘ Times 2O00-04-14 1730 Yorsion; 600, 2900, 5512 (oep 000210 Microsoft Corporstion

nformation
Pane

unsafe items and version information

(Status Bar displays currently logged-in user, number of detected ]

The interface is divided into five main areas:
*  The File Menu bar;
«  Main display Pane;
« Information Pane;
«  Category Selection Pane;
- Status Bar
The File Menu Bar

The file menu bar displays the controls for executing various tasks of the application.

Menu Option Description

File Contains options related to file operations, enabling/disabling start-up
items, and analyzing offline system.

Find Launches the Find dialog to search for a specific entry by entering a
search parameter

Open Opens a pre-stored Autorun Analyzer file

Save Opens the 'Save as' dialog to save the data in the main display pane in
the native file format of Autorun Analyzer. The file is stored with .ard
extension.

Enable All Unsafe Entries Enables the start-up items identified as unsafe, all at once.

Disable All Unsafe Entries Disables the start-up items identified as unsafe, all at once.
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Analyze Offline System Starts the wizard to analyze an idle additional Windows operating
system installed in your computer, e.g. a virtual machine.

Refresh Refreshes the Autorun Analyzer application.
Exit Closes the Autorun Analyzer application.
Entry Contains Options to handle the Start-up items
Delete Removes the selected item from the Autorun items and deletes the

parent application from your system.

Copy Copies the data in the selected row to clip-board of your system.

Jump to Entry Opens the selected entry in Windows Registry Editor

Jump to Folder Opens the folder containing the selected entry in Windows Explorer

Enabled Enables to toggle the selected autorun entry between 'Enabled' and
'Disabled' states.

Search Online Opens the default web browser of your system with the search engine
specified and searches for information on the selected autorun entry on
the web.

Properties Opens the Properties dialog of the selected autorun entry.

View Contains options related to display nature of the application.

Hide Safe Entries Displays only the autorun entries identified as unsafe by Autorun
Analyzer.

Font Opens the Font dialog that enables you to configure the font, font style,

font size and so on, to customize the look and feel of the application.

Language Autorun Analyzer is available in several languages. The 'Language'
option in the 'View' menu enables you to select the language in which
the application has to be rendered.

Users Enables to filter the autorun entries displayed depending on the user
that started the application. Refer to 'Filtering Entries Based on
Users' for more details.

Help Opens the '"About' dialog of the Autorun Manager application. Refer to
About Autorun Analyzer for more details.

Main Display Pane

The main display pane displays the list of all Start Up items as a table. Right clicking on an entry opens the context sensitive
menu that enables to handle the entry. Refer to Viewing and Handling Autorun Items for more details.

Information Pane
The Information Pane displays the complete details of the autorun entry selected from the Main Display Pane.

Category Selection Pane

The Category Selection Pane enables to filter the autorun entries displayed depending on their category. Refer to Filtering
Entries Based on Category for more details.

Status Bar

The status bar at the bottom of the interface displays the current state of the application, currently logged-in user name, number
of detected unsafe entries and the version of application that you are using.

Next: Viewing and Handling Autorun Items
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6.3.Viewing and Handling Autorun ltems

The Autorun Analyzer allows you to manage autorun items that are loaded to your system during system start up. All autorun
entries are displayed in a tree structure with their description, location, software publisher details and threat rating. Untrusted
Autorun entries are highlighted for easy identification.

On selecting an autorun entry, the complete details like the parent application, installation date/time, version of the application,
software publisher information are shown in the Information area beneath the main display pane for the entry.

You can filter the entries based on their categories and the users that has started them, by selecting the category from the
Category Selection Pane and the user from the 'User' menu in the file menu bar respectively.

You can perform various operations on any entry by selecting an entry and selecting an option from the 'Entry' menu in the file
menu bar or right-clicking on an entry and selecting an option from the context sensitive menu. Also you can directly enable or
disable an entry from the main display pane by selecting/deselecting the checkbox beside the entry.

Autorun Entry |Descriptiu:un |F'u|:u|isher |Rating |Image Path |
= ﬁHKLM\EDFrWARE\Micrusnft\Active Setup', Installed Components
- W [|address... Outlook Ex... Microsoft Corpo... Safe C\Program FilestOutlook Expressise...
- M [&]Internet .. Windows S... Microsoft Corpa,.. Safi CWWINDOWShsystem32isetupapi.dll
- 0 FInternet ... Windows N... Microsoft Corpo... Safe CAWINDOWShsystem32tshmgrate.exe
— F [Internet ... IE 5.0 Par-... Microsoft Corpo... Safe CWAINDOWS sy stem32ieduinit. exe
- ¢ [Microsof... Outlook Ex... Microsoft Corpo... Safe C:\Program FileshOutlook Expressise...
- M [ EMicrosof... ADVPACK Microsoft Corpo... Safe CAINDOW S systema2iadvpack. dil
— W @@ Microsof... Microsoft ...  Microsaft Corpo... Safe CWWINDOWSinfyunreg mp2. exe
— # [ Microsof...
- M [En/a Microsoft ... Microsoft Corpo... Safe CMWAYIMDOW S ayste m32ymscories. d||
- M [En/a
- M [E|Metest... ADYPACK Microsoft Corpo... Safe C WA INDOWShesystem32advpack. dll
- B [Foutlook ... Windows M., Microsoft Corpo,.. Safe CWWINDOWShsystem32ishmgrate.exe
- [T Themes... Microsofic... Microsoft Corpo... Safe CWWINDOWSheyste m32regevr32.exe
- FWindow... Microsoft(C... Microsoft Corpo... Safe CWINDOW S ayste m32regevr 32, exe
L W & wWindow.., ADVPACK Microsoft Corpo... Safe CWWINDOWShsystem32iadvpack. dll
= QHKLM\SDHWARE\ Microsoft', Windows NT" CurrentV¥ersion', Winlogon®, Shell
LR i Explorer.., Windows E... Microsoft Corpo,,. Safe CWWINDOWWShexplorer . exe
= QHKLM\SDHWARE\ Microsoft', Windows NT* Current¥ersion', Winlogon®, Userinit

L M WML, Userinit Lo... Microsoft Corpo... Safe CWYINDOWSheyste m32userinit. exe
= @“ HKLM' SOFTWARE" Microsoft', Windows", Current¥ersion', Explorer*, SharedTaskScheduler

L # [#lerowseu... Shell Brow... Microsoft Corpa.., Safe C oA INDOWShsvste ma2ibrowseidll 7
explorer.exe  Size: 1,009.50 KB Windows Explarer

g! Time: 2003-04-14 17:30 Yersion: 6,00,2900.5512 (xpsp,030413-2105)  Microsoft Corporation

LLLA M.

Explorer. exe

Uset: SMITHSCOMPUTER \User B Unsafe: 1| 2,2,217700,170

Autorun Analyzer - Descriptions of Columns

Column Description

Autorun Entry Displays the name of the Autorun Entry. Selecting/Deselecting the check box beside each name
toggles the Autorun ltem between 'Enabled' and 'Disabled' states.

Description A brief description of the entry.

Publisher The Software Publisher that has released the parent application.
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Rating Displays the result of the scanning performed on the item by Autorun Analyzer. ltems identified as
unsafe are shown highlighted for easy identification.

Image Path Shows the installation path of the patent application or the loaded module.

From this interface, you can:
« Handle the autorun items;
«  View the autorun items based on categories;

«  View the autorun items of other user accounts.

6.3.1. Handling Autorun Items

Autorun Manager interface allows you to enable/disable autorun items, view the registry key associated with an item, view the
parent application/module that has loaded the item and view the properties of the item. In cases where the item is found
unsafe/untrusted or you do not want the item to be loaded during start-up in order to optimize your system's boot-up time and
performance, you can remove the item from the start-up entries.

To manage an autorun item:
«  Select the item from the main display pane click on the Entry menu from the file menu bar and select the option.

COMODO Autorun Analyzer

i File View User Help

XK Delete Del by Description Publisher

= E Copy Flwindow... Microsaft(C... Micros
~m Jurnp to Enkry. Window.., ADWPACK
| B8 H Jurnp ko Falder, (LN SOFTWARE' Mi
'« Enabled

Search Online,..  Crl4+M
E] Propetties...  Alk+Enter

Or

«  Right-click on the item and select the option from the context sensitive menu.

COMODO Autorun Analyzer

! File Entey Miew User Help

Categories % 8 autorun Entry Diescription Publisher

¥ Fwindow.., Microsoft(C... Microsof
P [8)window... ADVPACK  Microsof
= @HKLM\, SOFTWARE" Microsoft, Windows

Everything (682) ]
Logon (243
Explorer (34

o 8 ® T

Internet Explarer -
(3 i'_:I@HKLM\ ¥ Delete ChetD
@ Scheduled Tasks L VEC Lopy CtrbC
(23} =l ﬁHKLM\ Jumnp ko Enkry.
Services (B7) |: 7 @8 Jump ko Folder..
F_,ﬂ I:.:lrw.ers (lﬁ.‘?) 9 .ﬁ:KLhSE v Enabled
T Search Online...  Ctrl4+m
|4] Properties...  Alt+Enter

«  Delete - Removes the selected item from the Start-up items. Removing an Autorun item just stops the parent
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application from loading into your system during start-up and does not remove the parent application. You can still start
the application from the Windows Start Menu when required.

»  Copy - Copies the selected row to clip-board of your system.
«  Jump to Entry - Opens the selected entry in Windows Registry Editor.

« Jump to Folder - Opens the folder containing the parent application or the module that loaded the autorun item in
Windows Explorer with the parent application or the module selected.

«  Enabled - Toggles the selected autorun item between 'Enabled' and 'Disabled' states.

Tip: You can directly enable or disable an entry from the main display pane by selecting/deselecting the checkbox beside the
entry.

«  Search Online - Opens the default web browser of your system with the search engine specified and searches for
information on the selected autorun item on the web.

«  Properties - Opens the Properties dialog of the selected autorun item.

explorer Properties

General |"-.-"ersiu:un || Compatibility || Summar_l,l|

-
| explarer |

Type of file:  Application

Descrption:  Windows E=plarer

Location: C:hi/ I D0
Sizer 0.93 MB [1.033,728 bytesz)
Size on dizk: 0,98 ME [1,036,238 bytes]

Created: Monday, Apnl 14, 2008, 5:30:00 P
b odified: bonday, April 14, 2008, 5:30:00 P
Aocezsed: Today, December 19, 2017, 12:08:04 P

Aftributes: [ 1Read-only [ ]Hidden

(] l [ Cancel

6.3.2. Filtering Entries based on Categories

The left hand side pane of the Autorun Analyzer interface displays a list of various types of the autorun items and the program
groups. The number of items loaded in the respective category is displayed within parentheses beside each category name.

By default, all the autorun items loaded, are displayed in the main display pane. If you want to analyze the autorun items based
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on their categories or to analyze the items loaded by various program groups, you can filter the items , by selecting the
respective category from the list.

COMODO Autorun Analyzer

i File  Entry

Autorun Entry | Description Publisher R ating

ﬁHKEU‘\,SuI'tware‘\,Mn:rDsuft‘\Wlndums\[urrenth‘ersmn\ﬁa; 1
M tFmon.exe  CTF Loader Microsoft Corporation Safe

Categories

[E Everything (742) ]

@ Logon (3]

B Explorer (31)

@ Internet Explorer (14)

& Scheduled Tasks (4)
Services (105)

B Drivers (151)

ES Codecs (169)

™ Boot Execute (1)

[7 Image Hijacks (4&)

[Z] Applnit {0}

wWindows Live, .. Microsoft Cu:urporatior. Anal

=l ﬁHKLM\SDFTWAREKMlcrusuﬂ:\nctwe Setup‘glnstalled Conip
- F’E.ﬁ.&d_ress B... Qutlook Expr... Microsoft Corporation Safe
- L’;jBru:uwser C... [EAK branding  Microsoft Corporation Safe
- L’;jBru:uwser C... [EAK branding  Microsoft Corporation Safe
- EInternet E... IE Per-User ... Micrasoft Corporation Safe
B [JInternst E... IE Per-User I... Microsoft Corporation Safe
— B [TJInternet E... IE Per User A... Microsoft Corporation @

- B [Microsoft ... Outlook Expr... Microsoft Corporation Safe

- W @Micmsoft . ADWPACK Microsoft Corporation Safe
[B] KnownDLLs (20) , _ _ . B
) - Hﬁrﬂlcmsoﬂ: ... Microsoft Win. .. Microsoft Corporation Safe
@ ‘inlogon (15) - [ Microsaft ..
W Winsock Providers (22) L @ [=ina
=y Prink (7) - [)n/a Microsaft JME.., Microsoft Corporation Safe
@) L34 Providers (10) ) t&]NetMeetin... B0WPACK Microsoft Corporation Safe

W Metwork (28] - B []outlookE... Windows NT ... Microsoft Corporation Safe
- REThemes S... Microsoft(Ch ... Microsoft Corporation Safe
- P"EWindu:uws Microsoft(C) ... Microsoft Corporation Safe
L L:]'-.l'-.-'lndcuws ADVPACK Microsoft Corporation Saf
=l @HKLM\SDFTWAREKMlcrusuft\Wmduws NT\ Current¥ersion,}

M dEprDrer . Windows Exp... Microsoft Corporation Safe

GoogleToolbarkatifier exe Size: 36,48 KE  GoogleTookb
© Time: 2011-07-25 17:35 Version: 4, 1, 509, 1944

"C\Program FilesiGooglelGoogleToolbarkatifier| GoogleToolbar

Descriptions of Categories

Category Description
Everything Displays all the autorun items in the main display pane.
Logon Displays only the autorun items identified from standard autostart locations such as the Startup folder

for all users, the Registry Run keys, and standard application launch locations.

Explorer Displays only the Explorer shell extensions from various installed applications, browser helper objects
(BHO), explorer toolbars, active setup executions and shell execute hooks.

Internet Explorer Displays only the BHOs, Internet Explorer toolbars and extensions.

Scheduled Tasks Displays the modules loaded by tasks and applications scheduled from Windows Task Scheduler.
Services Displays the modules loaded as Windows Services.

Drivers Displays only the kernel-mode drivers that are in currently enabled on the system.

Codecs Displays the autorun items loaded by various coders-decoders used for handling media files like audio

and video files.

Boot Execute Displays the autorun items loaded by applications, services and commands executed during the time
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period between the system boot-up and the user log-on.

Image Hijacks Displays the modules loaded by image file execution options of various applications installed in your
system. Most of the malware modify the image file execution options of a legitimate application and
make themselves to run when the real application is started. Autorun Analyzer enables you to identify
such illegitimate autorun items loaded by malware that affect the image file execution options of
legitimate applications and to disable / remove them.

Applnit Displays the application initialization Dynamic Link Library (DLL) modules loaded as autorun items.
KnownDLLS Displays the DLL modules loaded by Windows for the start-up applications that reference those DLLs.
Winlogon Displays the DLL modules registered for Winlogon notification of logon events.

Winsock Providers Displays the DLL modules registered for Winsock protocols, including Winsock service providers.

An anti-malware software do not scan Winsock Service Providers as it is treated as a safe zone.
Taking advantage of this, some malware enter into your system as a Winsock Service Provider. But
Autorun Analyzer can identify the DLL modules loaded by Winsock Service Providers and notify you if
they are untrusted. It also enables you to remove those untrusted modules from your system.

Print Displays the DLLs load into the print spoolers configured as services to start with Windows. Some
malware find their entry through Print spooling service to start themselves automatically during system
start-up.

LSA Providers Displays the DLL modules registered by Local Security Authority (LSA) authentication, notification and

security packages.

Network Displays the DLL modules loaded by network connection services.

6.3.3. Viewing Autorun Items for other User Accounts

By default, Autorun Analyzer displays the autorun items loaded as per the start-up configuration of the currently logged-in user
account. The 'Users' menu in the file menu bar enables you to view the autorun items for the other user accounts registered in
your system.

COMODO Autorun Analyzer

: File Entry View Help
T NT AUTHORITY|SYSTEM L Publisher Rati

.................................................... NT AUTHORITY\LOCAL SERVICE soft\Active Setup

e Logon (24) MWT AUTHORITYIMET'WORK SERVICE .. Microsoft
| @ explorer (54) SMITHSCOMPLTER|User 4 S.. IV
Internet Explo SMITHSCOMPUTER | Lser B

SMITHSCOMPUTER Administrator

«  Selecting a user name from the User menu will display the autorun items configured for that user account.

6.4.Help and About Details

The 'Help' menu in the file menu bar enables you to access the online help guide and know about the version number of Autorun
Analyzer in your system.
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COMODO Autorun Analyzer - Show ALLE

i File Entry  Miew  User

Caktegories

|.'.-—.' Everything (745) are\™M
f Logon (313 I
| @ Explorer (94) :nsnn'
Internet Explorer {14} 4 HKLM 5

Clicking on the Help menu has the two options:

+ Search
«  About
6.4.1. Help

Selecting the 'Search' option from the Help menu opens the online help guide hosted at http://help.comodo.com/. Each area
has its own dedicated page containing detailed descriptions of the application's functionality.
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/~ Comodo Cleaning Essentials - Introduction | The security products, anti virus - Windows Internet Esp

G? - |I!', kg fhelp comado, comybapic- £ 19- 1-328-3516-Ink L-.'J-.'-E @ | X I Birig 2.

<= Favorites ﬁ@mndnﬂuring&unﬁuk-lmmductim|Thusacur...| | Y - Bl - ) #m - page~ Safety~ Tools- - 7

Find the desired product help Comodo Cleanng Essentas  =fii23 =]

])’ Comodo Cleaning Essentials VErSOR oY ENgis
i

Introduction To Comodo Cleaning Essentials

E- Introduction To Comodo Cleaning

Easemtials Introduction to Comodo
System Requirements ESse n ti a IS

“Downloading Comodo Cleaning
Essentials

Comodo Cleaning Essentials (CCE) is a set of computer secunty tools desig

“Starting Comodo Cleaning ]
remove malware and unsafe processes from infected computers.

Essentials
“The Main Interface Major features include:
FlScanning Your System + KillSwitch - an advanced system monitoring tool that allows users to
. . . unsafe processes that are runming on therr system.
Configuring Comodo Cleaning

Essentials +« Malware scanner - Fully customizable scanner capable of unearthing

F'The Tools Menu hidden files and malicious registry keys hidden deep in your system.

' Introduction To KillSwitch » Autorun Analyzer - An advanced utility to view and handle services :

when your system booted-up.

- introduction To Autorun Analyzer =
4] | L|_I
T S RS B e e T

You can also print or download the help guide in pdf format from the webpage.

6.4.2. About Autorun Analyzer

The Help menu in the file menu bar opens the 'About' dialog of Comodo Autorun Analyzer.

COMODO Autorun Analyzer - Show All Ent

: File Enkry

Categories Descripkion

apehMicrosoft!

{777 Ewverything (745

] Logon (31) Hnki=es
mznmsgr
B Explorer (34) _
A At [ A bout Aut -un Analyzer

g COMODO Aukarun Analyzer
Product Yersion; 2.3.219500,175

Copyright {c) 2004-2011 COMODD, All rights reserved.
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The 'About' dialog displays the version Number of Comodo Autorun Analyzer and the copyright information.

/.Help and About Details

The Help menu at the top right corner of the CCE main interface enables you to access the online help guide and view the About
dialog of the application.

cCOMODO e

Cleaning Essentials Options Toolz + Help +

Start Scan

Start a scan to unearth and remove wirdses, rootkits, hidden files and malicious registry keys
hidden deep within your system.

Click the links below for more information:

* Help
«  About

7.1.Help

Clicking the 'Help' option from the 'Help' menu opens the online help guide hosted at http://help.comodo.com/. Each area has
its own dedicated page containing detailed descriptions of the application's functionality.
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/~ Comodo Cleaning Essentials - Introduction | The security products, anti virus - Windows Internet Esp
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<= Favorites @Cumndnauring&untiuk-lrtmductim|Thusacur...| | Y - Bl - ) #m - page~ Safety~ Tools- - 7

Find the desired product help Comodo Cleanng Essentas  =fii23 =]

])’ Comodo Cleaning Essentials VErSOR oY ENgis
i

Introduction To Comodo Cleaning Essentials

E- Introduction To Comodo Cleaning

Easemtials Introduction to Comodo
System Requirements ESse n ti a IS

“Downloading Comodo Cleaning
Essentials

_ . - - anmines Coaa sl El ie 3 =at o - = v Fanle Aasi
“Starting Comaodo Cleaning Comodo Cleaning Essentials (CCE) is a set of computer security tools desig
: remove malware and unsafe processes from mfected computers.
Essentials

“The Main Interface Major features include:

FlScanning Your System « KillSwitch - an advanced systam monitoring tool that allows users to

. . . unsafe processes that are runming on therr system.
Configuring Comodo Cleaning

Essentials +« Malware scanner - Fully customizable scanner capable of unearthing
F'The Tools Menu hidden files and malicious registry keys hidden deep in your system.
' Introduction To KillSwitch » Autorun Analyzer - An advanced utility to view and handle services :
# Introduction To Autorun Analyzer when your system booted-up. =
| | LI_I
._ [ ..... | ...... [ ..... —_— e e |'a’t' EaTT - /}

You can also print or download the help guide in .pdf format from the webpage.

7.2.About

Clicking 'About' from the 'Help' menu opens the the 'About’ dialog of Comodo Cleaning Essentials.

About COMODO Cleaning Essentials x

COMODO

Cleaning Essentials

Product Version: 2.3.219500,176
‘Wirus Signature Database Version: 11195

Patents Pending
Copyright () 2004-2011 COMODO,
All righks reserved.,

The 'About' dialog version of Comodo Cleaning Essentials, version of virus database that is in your computer and the copyright
information.
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8.Using the Command Line Interface

Comodo Cleaning Essentials allows users to execute smart scans, custom scans and virus database
updates from the Windows command line interface..

To access the Windows command line interface
«  Click Start > All Programs > Accessories > Command Prompt.
or
«  Click Start > Run, type 'cmd" in the Run interface and click 'OK'".
Click the links below for more details on the tasks executed from the Command Line Interface:
*  Running a Smart Scan from the Command Line Interface
*  Running a Custom Scan from the Command Line Interface
«  Running a Virus Database Update Task from the Command Line Interface

«  Viewing Help
8.1.Running a Smart Scan from the Command Line Interface

»  Open the Windows command line interface

«  Specify the command in the following format
<file path>/ <executable> -smart
For example, if the folder containing Comodo Cleaning Essentials files is stored in C:\Comodo, the command would

be:
C:\Comodo\CCE\CCE - smart

Note: The Commands are not case sensitive.

The CCE application will start scanning, reboot and clean threats automatically without user interaction.

8.2.Running a Custom Scan from the Command Line Interface

»  Open the Windows command line interface

«  Specify the command in the following format

<file path>/ <executable> -scan parameter1 - scan parameter2 -scan parameter3...

For example, if the folder containing Comodo Cleaning Essentials files is stored in C:\Comodo, the command would
be:

C:\Comodo\CCE\CCE -s “<scan attribute1>;<scan attribute1>” -0 “<scan option1>;<scan option1>” -d “<drive
letter>” -p “<file path>” -shift

«  The parameters -0, -d and -p are optional

«  The parameters and arguments are explained in the following tables:
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Scan Attributes
Scan Attributes
Argument Description
m Scan memory on start.
c Scan critical areas and boot sectors.
f Scan selected drivers for hidden files/folders.

Note: if you use "f" parameter, you must add -d "drive" (explained below).

r Scan hidden registry objects.
nv Don't scan for viruses.
Syntax

-s “<scan attribute1>;<scan attribute1>”...

Examples:

To run a scan with the attributes 'scan memory on start', 'Scan critical areas and boot sectors' and 'Scan selected drivers for
hidden files/folders' on drive 'c:', then the parameters are to be entered as:

C:\Comodo\CCE\CCE -s"m;c;f;r" -d "¢
To run a full scan of your system, just enter

C:\Comodo\CCE\CCE -s

Scan Options

Scan Options

Argument Description
ARCHIVE Scan archive files (e.g. *.zip, *.rar).
HOOK Restore any kernel hooks before the scan.
SUSMBR Scan selected drivers for hidden files/folders.Scan suspicious MBR modifications in full scan (Valid for

single boot computers only).

MODMBR Report all MBR modifications in full scan(Valid for single boot computers only).
RESTORE Create a windows restore point before performing the scan.
CAMAS Scan unknown processes in memory with CAMAS.

CAMASTIME=NN | CAMAS timeout seconds.

Heur=N Heuristics Scanning level.
o 0=off
o 1=low;
e 2=middle;
« 3 =high.
MAX=20 Do not scan files larger than 20(MB).
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LOGLEVEL=N Specifies the log level.
« (0=disable log;
* 1=show threats log;

« 2 =show full log.

Syntax
-0 “<scan option1>;<scan option1>”

Examples:

To run a scan drive 'C:" with the options 'Scan archive files', 'Report all MBR modifications in full scan' and 'Scan unknown
processes in memory with CAMAS' with CAMAS time out period of 300 seconds

C:\Comodo\CCE\CCE -s -0 "ARCHIVE;MODMBR;CAMAS;CAMASTIME=300 -d "c"

Scan Drives
The hard disk drive partition(s) to be scanned can be specified as arguments for the parameter -d.

Syntax
-d “<drive letter 1>;<drive letter 2>... ”
Examples:

To run a scan drive partitions 'C: and 'D:'

C:\Comodo\CCE\CCE -s -d "c;d"
Scan Specific Folders/Files

To scan specific file(s)/folder(s), you can enter the path(s) of it/them as argument to the parameter -p.

Syntax
-p “<file path 1>;<file path 2>...”

Examples:

To scan the folder 'C:\Program Files'

C:\Comodo\CCE\CCE -s -p “C:\Program Files”

To run a scan files 'note1.txt' and 'note2.txt' in the folder 'C:\My Documents'

C:\Comodo\CCE\CCE -s -p “C:\My Documents\note1.txt;C:\My Documents\note2.txt”

Aggressive Mode Scanning

To start the scanning in aggressive mode, include the parameter -shift to the command.
Example:

C:\Comodo\CCE\CCE -s -shift

The CCE application will start scanning, reboot and clean threats automatically without user interaction.
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8.3.Running a Virus Database Update Task from the Command
Line Interface

»  Open the Windows command line interface
»  Specify the command in the following format
<file path>/ <executable> -u

For example, if the folder containing Comodo Cleaning Essentials files is stored in C:\Comodo, the command would
be:

C:\Comodo\CCE\CCE -u

The local virus database will be updated.

Note: You should be connected to Internet in order to receive the updates.

8.4.Viewing Help
»  Open the Windows command line interface
«  Specify the command in the following format
<file path>/ <executable> -help

For example, if the folder containing Comodo Cleaning Essentials files is stored in C:\Comodo, the command would
be:

C:\Comodo\CCE\CCE -help
The CCE online help guide hosted at http://help.comodo.com/ will open.
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About Comodo

The Comodo companies are leading global providers of Security, Identity and Trust Assurance services on the Internet. Comodo
CA offers a comprehensive array of PKI Digital Certificates and Management Services, Identity and Content Authentication
(Two-Factor - Multi-Factor) software, and Network Vulnerability Scanning and PCI compliance solutions. In addition, with over
10,000,000 installations of its threat prevention products, Comodo Security Solutions maintains an extensive suite of endpoint
security software and services for businesses and consumers.

Continual innovation, a core competence in PKI and a commitment to reversing the growth of Internet-crime distinguish the
Comodo companies as vital players in the Internet's ongoing development. Comodo, with offices in the US, UK, China, India,
Romania and the Ukraine, secures and authenticates the online transactions and communications for over 200,000 business
customers and millions of consumers, providing the intelligent security, authentication and assurance services necessary for
trust in on-line transactions.

Comodo Security Solutions, Inc. Comodo CA Limited

525 Washington Blvd. Jersey City, 3rd Floor, 26 Office Village, Exchange Quay, Trafford Road,
NJ 07310 Salford, Greater Manchester M5 3EQ,

United States United Kingdom.

Tel : +44 (0) 161 874 7070
Fax : +44 (0) 161 877 1767

Tel: +1.888.256.2608
Tel: +1.703.637.9361

Email: EnterpriseSolutions@Comodo.com

For additional information on Comodo - visit http://www.comodo.com.
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