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1. Comodo IceDragon - Introduction
Comodo Ice Dragon is a fast, secure and versatile Internet Browser based on Mozilla core and 

infused with Comodo's unparalleled level of security. 

Guide Structure

This guide is intended to take you through the installation, configuration and use of Comodo IceDragon.

• Comodo Dragon - Introduction

• System Requirements

• Download And Install Comodo IceDragon

• The Basics

• Start Comodo IceDragon

• Set IceDragon as your Default Browser

• Set Your Homepage

• Search the Internet

• Customize the Toolbar

• Open Recently and Most Visited Websites

• View Browsing History

• Set Fonts, Languages and Encoding

• Configure IceDragon Updates

• Page Action Menu

• Portable Version

• Uninstall IceDragon

• Tabbed Browsing

• Use Tabs

• Customize Your 'New Tab' Page

• Tab Settings

• Bookmarks

• Create Bookmarks

• Find and Edit Bookmarks

• Manage Bookmarks

• Bookmarks - Import, Export and Back up

• Privacy And Security

• Private Browsing

• Delete Browsing History and configure History settings

• Allow/Block pop-up windows

• Manage Cookies and Site Data

• Block Websites from Tracking your Browsing History

• View and Manage Permission Settings

• Configure Suggestions when Entering a Website Address

• Manage Cache
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• Manage Add-on permissions

• Manage Passwords

• TLS/SSL Certificates and Secure Connections

• Manage SSL Certificates and HTTPS Security

• Force Secure Connections

• Website Security Indicators

• Disable accessibility indicator setting

• Configure IceDragon performance and browsing settings

• Network Proxy settings

• Downloads

• Download a File

• Change Download Location

• View Download History

• Clear Download History

• Introduction to  Add-ons

• Download and Install Add-ons

• Install Add-ons from Local Storage

• Configure Updates to Add-ons

• Manage Extensions

• Customize the Appearance of IceDragon

• Manage Plugins

• Tools and other Features

• Customize Applications for Opening Different File Types

• Search Within Page Content

• Form Autofill

• Keyboard and Mouse Shortcuts for Comodo IceDragon

• Manage IceDragon in Safe mode

• Set up Comodo IceDragon sync information

• View Digital Rights Management

• Improve IceDragon Performance Settings

• Comodo Online Security Extension

• View Task Manager

• Web Developer Tools

• Open the Tools console 

• Inspect Page Elements

• Use the Web Console

• Remove Inconsistencies with HTML, CSS and Javascript

• View and Run Experimental Style Sheets on a Webpage

• Improve Web Page/Web Application Performance

• Memory Tool

• Network Monitoring 

• Storage
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• Accessibility

• Use the WebIDE

• Browser Toolbox and Browser Content Toolbox

• Browser Console

• Responsive Design View

• Eyedropper

• Run Experimental Java Scripts on Page

• View Page Source

• Service Workers

• Connect Remote Device

• Add More Web Development Tools

• Work Offline

• Troubleshooting

• Error: “This Connection is Untrusted"

• Report a Bug

2. System Requirements
To ensure optimal performance of Comodo IceDragon, please ensure that your PC complies with the minimum 
system requirements:

• Windows 8 / 8.1 / 7 / Vista / XP 

• 128 MB RAM

• 40 MB Hard Disk Space

See Download And Install Comodo IceDragon to download and install the IceDragon.

3. Download And Install Comodo 
IceDragon

You can download the IceDragon setup file from: http://icedragon.comodo.com/ 

After downloading the file, double click icedragonsetup.exe               to start the installation wizard.

Step1 - End User License Agreement

The EULA screen of the setup wizard is displayed. Complete the initialization phase by reading and accepting the 
End User License Agreement (EULA).
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• Click 'I agree' button to continue the installation.

• Click 'Cancel' button to abort the installation.

Step 2 - Select Installation Folder

The next screen allows you to select where you want to install Comodo IceDragon. The default installation path is 
C:\Program Files(x86)\Comodo\IceDragon.
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• Click 'Browse' to choose a different installation location.

• 'Portable version (user profile is stored in destination folder)' - The portable version saves all user profile 
data to the IceDragon folder instead of the Windows 'user' folder. This allows you to copy the IceDragon 
folder to a USB drive, plug it into any computer and access your personalized version of the browser. See 
Portable Version help page for more details. 

• Click 'Next' to move onto the next stage of the installation wizard.

 Step 3 - Installation 

Next, IceDragon will begin installing. The progress will be displayed as followed:
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• The 'Installation Complete' dialog will appear once setup is complete:
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• Leave 'Run Comodo IceDragon'  enabled to start browsing with IceDragon immediately.

• Leave 'Make Comodo IceDragon my default browser' selected to make Comodo IceDragon your default 
browser. If you want to keep your current browser as default, deselect the checkbox.

• Click 'Finish'.

• You will also be offered the opportunity to set your search engine provider to Yahoo (or Yandex in Russia, 
Ukraine, Romania, Kazakhstan and Turkey): 

• Choosing Yahoo/Yandex as your default search engine means:
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• When you enter a search item into the address bar of a supported browser, the search will be carried 

out by Yahoo/Yandex 

• A ‘Search with Yahoo/Yandex’ menu entry will be added to the right-click menu of supported browsers. 

• Yahoo/Yandex will be set as the default search engine in the ‘Search’ box of supported browsers 

• The instant ‘search suggestions’ that you see when you start typing a search item will be provided by 
Yahoo/Yandex 

• Click 'Decline' to cancel the enhancements.

4. The Basics
This section of the guide explains how to launch, configure and use Comodo IceDragon to its full potential. 

Click the following links to find out more:

• Start Comodo IceDragon

• Set IceDragon As Your Default Browser

• Set Your Homepage 

• Search The Internet 

• Change Search Options 

• Customize the Toolbar and the Menu

• Open Recently And Most Visited Websites In IceDragon

• View Browsing History

• Set Fonts, Languages And Encoding

• Configure IceDragon Updates

• Page Action Menu

• Portable Version

• Uninstall IceDragon

4.1.Start Comodo IceDragon
There are two different ways to start Comodo IceDragon:

• Start Menu

• Desktop

Start Menu

You can launch Comodo IceDragon via the Start Menu.

• Click Start and select All Programs > Comodo > IceDragon > Comodo IceDragon
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Desktop

• Just double-click the Comodo IceDragon icon on your desktop.

Further reading related to the topic of this page:

• Set Your Homepage

• Open Recently and Most Visited Websites in IceDragon

• Set IceDragon As Your Default Browser
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4.2.Set IceDragon as your Default Browser
If you have more than one browser installed, it's likely that you'll want to pick one as your 'go-to' browser for 
everyday use.

This means that it will automatically be used to view websites when you click a link in, say, an email or IM 
conversation.

To do this:

• Click the hamburger button at top-right corner 

• Select 'Options'  > 'General' then click 'Make Default' button. 

• Always check if IceDragon is your default browser – Will check and notify you if IceDragon is not set as 
your default browser. The notification offers the option to set Dragon as your default. 

Related to this page:

• Set Your Homepage

4.3.Set Your Homepage
• You can configure IceDragon to open at a specific page, or open a set of pages at startup. 

• You can also make it start with a blank page or with the pages that were open at the end of your last 
session.

Click the following links for more help:

• Configure Home

•  Home page

Configure Home

• Click the hamburger/menu button at the top-right corner.

• Select 'Options' > 'Home' on the left.
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• Home page and new windows - Specify the URLs you want to open at Ice Dragon startup. See 
'Configure Home page' if you want more help with this.

• New Tabs - Specify the page you want to see when you open a new tab. By default, this is the Ice Dragon 
home page.

Configure Home page

You can set your favorite web page as your home page using one of the following methods:

Manual

• Click the hamburger button at the top-right corner 

• Select 'Options'  > 'Home'

• Type the URL of your desired homepage in the 'Custom URL' field:

From the currently open page

• Open the page you want to use as your home page

• Click the hamburger button at the top-right corner 

• Select 'Options'  > 'Home' 

• Scroll to the 'Home' section
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• Click 'Use Current Page'

You can also set your home page by dragging favicon onto the 'Home' button. The favicon is the icon on the left of 
the website address bar.

From your bookmarks

• Click the menu button at the top-right corner then select 'Options' > 'Home' 

• Click 'Use Bookmark'.

• Select your favorite page from the list and click 'OK'.

Set Default Home page

If you want to return to using Yahoo/Yandex as your home page,

• Click the hamburger button at the top-right corner then select 'Options' > 'Home” 

• Click 'Restore Defaults' at the top-left.

4.4.Search the Internet

The Comodo IceDragon address bar also serves as a search box. By default, keywords typed into the address bar 
will use Yahoo/Yandex as the search engine:

• Enter your keywords or phrases into the address bar.

• To search, click the arrow at the right side of the address bar or press 'Enter' on the keyboard.
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• When you start typing a website address in the address bar, the browser automatically searches your 
browsing history and your bookmarks to provide auto-complete suggestions. This allows you to easily find 
pages you have previously visited.

• You can change the default search engine as per your preference. Please see 'Change Search Options' 
for more details.

Click the links below for different ways to search the internet:

• Search adding to address bar

• Search using the Search box in the navigation tool bar

• Search within a webpage

•  the internet for a keyword from within a webpage

Search adding to address bar

IceDragon lets you to split the search bar and address bar. 

• Click the hamburger button at the top-right corner 

• Select 'Options' > 'Search' 

• Select 'Use the address bar for search and navigation' box or 'Add search bar in toolbar'
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Search using the Search box in the tool bar

Comodo IceDragon can also display a dedicated search box to the right of the address bar. The search box is not 
displayed by default. To add it:

• Right-click anywhere on the file menu or navigation bar and select 'Customize'

OR

• Click the hamburger button at the top-right corner 

• Select the 'Customize' button

• This will open the 'Customize Toolbar' panel. This panel allows you to simply drag the items you want onto 
the navigation bar

• Drag the 'Search' box to the navigation tool bar.
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• Click 'Exit Customize'. The search box will appear in the navigation tool bar.

• By default, the search box uses Yahoo/Yandex. 

• To change this, click the magnifying glass in the search bar and select 'Change Search Settings'. 

By default, the search box uses Yahoo/Yandex.

• That will open the 'Default Search Engine' under the 'Search' tab in the 'Options' dialog with list of 
alternatives. 

• Select your favorite search engine from the drop-down.

Search within a web page

To search for a specific keyword/phrase from within a web page: 

• Click the hamburger button at the top-right corner then select 'Find in This Page'

Or

• Press Ctrl + F on the keyboard.

A search box will appear at the bottom-right of the window:
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• Enter your search phrase and press 'Enter'. The first occurrence of the phrase will be highlighted on the 
page.

• To find other occurrences, press 'Enter' again or use the up/down buttons beside the search box.

• If you want to see all occurrences, click 'Highlight All'.     

Search the internet for a keyword from within a web page

• Highlight the word/phrase using your mouse, right click and select 'Search <your default search engine > for
“<selected keyword>'.

• Highlight the word/phrase with your mouse and drag the text into address bar/search box.

Further reading related to the topic of this page:

• Bookmarks

• View Browsing History

• Downloads
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4.5.Change Search Options 

• Change the search engine used for keywords entered in the address bar

• Turn keyword search off

• Configure URL Suggestions

Change the search engine

• Type about:config  in the address bar and press 'Enter'.

A warning will open:

• Click 'I accept the risk!'

• Type 'keyword' in the search field then double click in the Keyword.URL entry in the configuration page.

• Alternatively, right-click on 'Keyword.URL' and select 'Modify'

• Type the URL of your desired search engine
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Examples: 

• To use Yahoo search engine, type “https://search.yahoo.com/”

• To use Yandex search engine, type “https://search.yandex.com/search?p=”

• To use Bing search engine, type “https://www.bing.com/search?q= ”

• To search Wikipedia for the keyword, type “https://en.wikipedia.org/wiki/”

• Click 'OK'

• To reset to Yahoo/Yandex, erase the content in the keyword.URL dialog and click 'OK'

Turn keyword search off

• Type about:config in the address bar and press 'Enter' from the keyboard

• Click 'I accept the risk!' in the warning dialog to view the about:config page

• Type 'Keyword' in the search bar to reach the item 'keyword.enabled'

• Double-click on the item to change the value of the item to 'false'

The keyword search from the address bar will be stopped. To enable the feature again, follow the same procedure to
change the value to 'true'.

Configure URL Suggestions

IceDragon shows suggested links from your browsing history and bookmarks when you start typing a URL. This lets 
you quickly get to pages you have visited before.

• Click the hamburger/menu button at the top-right corner.

• Click 'Options' >  'Privacy & Security'.

• 'Address Bar' - Leave all check boxes enabled to draw suggestions from your browsing history, bookmarks 
and open tabs.

Enable or disable search suggestions

Comodo IceDragon User Guide | © 2020 Comodo Security Solutions Inc. |  All rights reserved                                                                    22



Comodo IceDragon - User Guide
You can enable or disable search suggestions in two ways:

• through the Search bar

• through the Search engine

Enable or disable search suggestions through the Search bar

• Right-click on the 'Search' bar

• Click on a provider's logo to select another search engine

Enable or disable search suggestions through the search engines manager 

• Click the hamburger button at the top-right corner.

• Click 'Options' >  'Search' tab.

OR

• Right-click on the 'Search' bar

• Click 'Change Search Settings' from the drop-down

• Select / deselect the check 'Provide search suggestions' box to enable / disable search suggestions.

• Enable 'Show suggestion in location bar results' to show suggestions when you search from the 
IceDragon address bar.

• Show search suggestions ahead of browsing history...' - Enable if you wish to see suggestions from 
your search engine first, and suggestions from previous pages that you have visited second.

Add a specific search engine

• Open the website

• Click on the magnifying glass        on the 'Search' bar
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It will appear in your built-in search options:
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• And in your 'Default Search Engine' list.
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Hide search engines 

• Click the hamburger button at the top-right corner then 'Options' >  'Search' tab

OR

• Click on the magnifying glass in the 'Search' bar on your toolbar 

• Click 'Change Search Settings'

• Uncheck the mark next to each search engine under the 'One-Click Search Engines'
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Remove search engine 

• Click the hamburger button at the top-right corner then 'Options' >  'Search' tab

OR

• Click on the magnifying glass in the 'Search' bar on your toolbar and click the 'Change Search Settings '

• Select the search engine you want to delete

• Click 'Remove' to remove from your list
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• Click 'Restore Default Search Engines' to add a default search engine back to the list.

• Click 'Find more search engines' to add a search engine which isn’t in the default list.

4.6.Customize the Toolbar and the Menu
The IceDragon toolbar contains shortcuts to items such as your homepage and bookmarks. The content of the 
toolbar is fully customizable.

Add or remove items on the toolbar

• Right-click anywhere on the file menu or navigation bar and select 'Customize' 

OR

• Click the hamburger button at the top-right corner > 'Customize'

This will open the 'Customize Toolbar' panel. This panel allows you to simply drag the items you want onto the tool 
bar.
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• To add an item, drag it from the dialog and drop on the toolbar. See table below for descriptions of icons

• To remove a tool, drag it from the toolbar and drop it into the 'Customize Toolbar' interface 

• Click on the 'Title Bar' ti display or hide the title bar

• Check show / hide in the 'Toolbars' drop-down to configure visibility of the 'Menu Bar' or 'Bookmarks' toolbar

• To set a theme, click the 'Theme' drop down to 'Manage' or 'Get more Themes'. You will be taken to 
IceDragon about:addons or Firefox add-ons webpage
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• You can choose a built-in dark or light theme, or choose one of the recommended themes.

• Click 'Restore Default' to return IceDragon toolbars to their original state

• Click 'Done' for your settings to take effect.
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Table of Icons and their Descriptions

Icon Description

• Cuts selected text from form field and copies it 
to the clipboard 

• Copies selected text to the clipboard 

• Pastes the text in the clipboard to the selected 
form field.

Magnify or de-magnify the current page 

Opens a new Comodo IceDragon window 

Opens a new private window.

Prints the currently displayed page.

Opens the History sidebar that show a list of recently 
visited pages 

Displays the current page in Full Screen view 

Find item in the current page

Opens 'Options' interface
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Opens Add-ons interface that shows a list of your 
Appearence.
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Opens the web developers tools interface

Inserts a search box to the navigation toolbar.

Opens the Downloads dialog that shows the list of 
previous downloads and progress of the current 
download

Enables subscription of RSS feeds from the currently 
displayed page.

Opens the Bookmarks window that shows a list of your 
bookmarks.

Saves the currently opened page on html format

Provides a quick access to the file from your computer

Provides a quick access to the fonts Unicode ranges

Opens a new Comodo IceDragon tab

Opens the Bookmarks or History Sidebar
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Closes all tabs that were open and deletes recent 
cookies and history. You could choose the time period 
from 24 hours, 2 hours or 5 minutes. This action cannot 
be undone.

Sync lets you access open tabs across your desktop, 
laptop and mobile devices that use Firefox. 

4.7.Open Recently and Most Visited Websites

• If you accidentally closed a page without bookmarking and decide you need to see it again, then you can 
use the 'Most visited' and 'Recently Closed Tabs' features.

• When you open a blank new tab in IceDragon, you will see thumbnails of sponsored and your most visited 
sites so you can quickly re-open them. 

View recent and most visited websites:

• Click the   icon at right of your open tabs: 

A tab will open containing thumbnails of your fifteen most visited sites.
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Enable the most visited sites feature

• In the address bar, type about:config  and click 'Enter'. "This might void your warranty!" warning 
page will appear

• Click 'I accept the risk!'

• Type browser.newtab.url 

• Double-click on it

OR

• Right-click on the string value > 'Modify'

• Change the value to about:newtab and click 'OK'.

Disable most visited sites feature

• In the address, type about:config  and click 'Enter'. "This might void your warranty!" warning page will 
appear

• Click 'I accept the risk!'

• Type browser.newtab.url 

• Double-click on it

OR

• Right-click on the string value > 'Modify'

• Change the value to about:blank and click 'OK'

• To view recently closed tabs, click the hamburger/menu' button at the top-right corner then select 'History' 

• To open all recently closed tabs in a new tabbed window,  click the hamburger/menu button at the top-right 
corner then select 'History' and select 'Restore Closed Tabs'.

Further reading related to the topic of this page:

• Use Tabs

• Customize Your 'New Tab' Page

4.8.View Browsing History

• IceDragon keeps a record of web pages that you have visited for the past 10 weeks. From time to time you 
may find it useful to look back through your history to revisit a particular site.

• Note - IceDragon only stores your browsing history when in standard mode. No history is saved in private 
mode. 

This section explains how to view your browsing history.

• View a quick list of past fifteen pages

• View full browsing history

View a quick list of your browsing history

• Click the hamburger/menu button at the top-right corner

• Select 'Library' > 'History'. 

A list of web pages that you have browsed in the recent past will be displayed.
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• Click on the page you want to re-visit.

You can also see the pages that you have visited in your present browsing session by clicking and holding down the 
forward and backward arrows adjacent to the address bar. Hover over a result and release the mouse key to switch 
to that page.

View full browsing history

• Click the hamburger/menu button at the top-right corner

• Select  'Library' > 'History' > 'Show All History'.

 A library window will open:
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• Double-click on the time period for which you want to see the browsing history. You can choose from 
yesterday, the previous week and previous months.

The list of visited pages for that time period will be displayed.

• Double click on the webpage you want to re-visit.
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Further reading related to the topic of this page:

• Delete Browsing History

• Use Tabs

4.9.Set Fonts, Languages and Encoding

Comodo IceDragon lets you change the way web pages are shown on your screen. You can configure the fonts, 
color and language of page content.

• Configure fonts and colors

• Configure language

Configure fonts and colors

Choose fonts

• Click the hamburger/menu at the top-right  

• Click 'Options' > 'General'

• Scroll down to 'Language and Appearance' > ‘Fonts & Colors’

• Select the font type and size that you want the browser to display:

• Click ‘Advanced...’ to configure even more detailed settings:
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• 'Allow page to choose their own fonts, instead of your selection above' - Deselect this check box 
to enforce your settings. This will stop websites from overriding your choices and using their own fonts 
and colors.

• Fallback Text Encoding - Web content usually includes a character set command which tells the page
how to display the text. The encoding means pages can correctly display characters from various 
languages. For example, ä, å, ü, あ, ஔ etc.

This setting lets you choose the character set IF it was not specified by the page. Default is current 
system language. 

Choose color

• Click 'Colors' beneath the 'Advanced' button to open the colors interface box.

Comodo IceDragon User Guide | © 2020 Comodo Security Solutions Inc. |  All rights reserved                                                                    39



Comodo IceDragon - User Guide

• Click on the color patch and select the desired color from the palette to change the colors in which the text, 
background and links will show.
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• 'Override the colors specified...' - will force web pages to use your display settings when rendering 
pages. This is especially useful for people with visual disabilities. 

• Click ''OK' in the color palette and again in the colors dialog to save your preferences.

Configure your preferred languages

Preferred language for IceDragon menus, notifications and messages

You can configure the language used in IceDragon menus, notifications, messages and other parts of the interface.  

• Click the hamburger button at top-right 

• Click 'Options' then 'General' 

• Scroll down to the language section and select from the language drop-down

• Click 'Apply and Restart'  to apply your changes. 

• Note – This only changes language of IceDragon menus, notifications and messages – it doesn’t 
change the language of the webpage. Go to https://translate.google.com if you want to translate web
content.

• To add more languages to IceDragon interface, click 'Search for more languages...' from the language drop-
down.
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• Click 'Select a language to add...', choose another language and click 'Add'

• Use the 'Move Up' and 'Move Down' button to reorder the language list.

• Click 'Remove' to delete a language

• Click 'OK'

You can set your preferred language order, if an IceDragon feature is not available in your top language.

• Click the hamburger button at top-right 

• Click 'Options' then 'General' 

• Scroll down to the language section and click 'Set Alternatives'
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• Use the 'Move Up' and 'Move Down' button to reorder the language list.

• Click 'Remove' to delete a language

• Click 'Select a language to add...', choose another language and click 'Add'

• Click 'OK'

• Click 'Apply and Restart'  to apply your changes.

Choose web pages display languages

IceDragon supports webpages that are offered in multiple languages. Configure your preferred language list. If a 
webpage is not available in your top language, then IceDragon checks if the same is available in the next language.

• Click the hamburger button at top-right 

• Click 'Options' then 'General' 

• Scroll down to the language section and click 'Choose...'

The 'Webpage Language Settings' screen opens:
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• The languages that are currently added to the browser are listed in the order of their usage preference.

• To add a new language to the browser, click the drop-down button beside 'Select a language to add...', 
select your desired language from the drop-down, click 'Add'.

• To change the order of preference of languages to be used by the browser, select the language and 
use 'Move Up' and 'Move Down' keys.

• To remove a language from the browser, select the language and click 'Remove'.

• Click 'OK' for your changes to take effect.

• Check your spelling as you type - If enabled, the browser will check the spelling of every word or phrase 
you type into various fields of a web-form. This features requires dictionaries to be downloaded. 

To download a dictionary, while typing inside a field in a web-form, right-click on the field, select 'Languages'
from context sensitive menu and select 'Add Dictionaries'. You will be taken the webpage from which you 
can download required dictionaries.  

Set a language as your default

• Click the hamburger/menu button at top-right 

• Click 'Options' > 'Languages' 
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• Select the language and click 'Set as default'
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• Click 'OK' to restart IceDragon for the settings to take effect.

4.10. Configure IceDragon Updates

Comodo IceDragon automatically downloads updates when it detects that a new version of the browser is available. 
This ensures your browser always has the latest features and security updates.  

• By default, available updates are downloaded in the background and installed automatically
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• You will see a notification to restart IceDragon and install the update it has been waiting for more than 24 

hours.

Configure updates automatically

• Click the hamburger/menu button at the top-right corner

• Click 'Options' > 'General' panel

• 'IceDragon Updates' - Select  'Automatically update search engines' to receive automatic updates to your 
search engines. Enabled = default. 

If automatic updates are disabled then IceDragon will not silently install updates. Instead, you will be alerted when 
updates are available via the notification bar.  

Configure updates manually

• Click the hamburger/menu button at the top-right corner then select 'Options'

• Click the 'IceDragon Updates' panel under the 'General' tab

• Automatically install updates (recommended) - Downloads and installs updates automatically.

• Check for updates, but let you choose to install them - Informs you if an update is available so you 
can choose whether to install now or later

• Never check for updates (not recommended) - Note: If this setting is selected, you will not receive 
critical security updates that may keep you safe online. You should manually check for updates 
frequently to avoid this situation..

You can configure updates for add-ons and extensions by clicking the hamburger button at top-right then 'Add-ons' >
'Extensions'.

• Click the gear icon then select 'Check for Updates' or 'View Recent Updates'.
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4.11. Page Action Menu
The page action menu is located on the right of the address bar. It appears when you click the ellipsis and lets you:

• Bookmark the current page

• Copy the current website address (link)

• Share a link with friends

• Send a link to the site to another device

• Enforce secure connections, so the site always uses HTTPS

• Report a problem with site

• Click 'Bookmark This Page' to add the page to bookmarks. Click here to view more on how to bookmark 
pages

• Click 'Copy Links' to save it to clipboard

• Click 'Email link' to send the link via email

• Click 'Send Tab to Device' to send a link to your mobile device

• Click 'Share' to send the link via mail or social networking

• Click 'Enforce secure connections' to enhance the browser's security connection through the secure HTTPS
protocol. Click here to find more details on this

• Click 'Report Site Issue' to file a bug report about the site. The form lets you describe the issue in detail.

Comodo IceDragon User Guide | © 2020 Comodo Security Solutions Inc. |  All rights reserved                                                                    48



Comodo IceDragon - User Guide
4.12. Portable Version

Comodo IceDragon can also be installed in portable mode. As the name suggests, portable mode allows you to 
install Ice Dragon on a USB stick. You can then quickly launch and use your personalized version of IceDragon on 
any computer without needing to install, import bookmarks or modify settings.

In portable mode, the user profile (configuration data) is written to the IceDragon installation folder instead of the 
Windows ‘user’ folder on the local machine. By simply copying the installation folder to another drive (such as a USB
stick) you can launch and use your personalized Comodo IceDragon.

Portable mode must be selected during the installation process: 

There are a few differences to setup if portable mode is selected:

• The Installer does not write anything to the Windows registry 

• Uninstaller is not created 

• User profile is stored in the "User Data" folder inside the main Comodo IceDragon installation folder. 
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4.13. Uninstall IceDragon

Note – Uninstall steps may vary depending on the Windows version. The following instructions are for Windows 10: 

• Click 'Start' > right-click on 'Comodo IceDragon' 

• Select 'Uninstall'  to open the 'Control Panel' 

• Select the IceDragon .exe in 'Programs and features'

• Click 'Uninstall / Change'

OR

• Click 'Start' > 'Settings' icon 

• Click 'Apps' > 'Apps & features'

• Select 'Comodo IceDragon' > 'Uninstall' in the list of currently installed programs on the right 

The 'Uninstall Comodo IceDragon' dialog will open:

• By default, you will be provided a choice to save your IceDragon profile data in your computer. 

• If you plan to install IceDragon again at a later time, IceDragon will use this profile data to configure 
your new installation.

• If you do not wish to retain or transfer your browser settings, select the checkbox 'Remove user profile'.

The screen displays the selection of the folder in your hard drive for installing Comodo IceDragon. The 
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default installation location is C:\Program Files (x86)\Comodo\IceDragon.

•  Click the 'Uninstall' button

• On completion, click 'Finish' to close the window.
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5. Tabbed Browsing
This section explains how to use tabs to view websites in Comodo IceDragon. 

Use the following links to find out more:

• Use tabs

• Customize Your New Tab Page

• Tab Settings

5.1.Use Tabs
Each web-page you open is shown in what is known as a 'tab'. 

• Multiple tabs can be opened at once. Each tab can contain a different web page.

• Click any tab to switch straight to that page.

• Click the 'Open a new tab' button to open a blank tab.

• Click the 'X' button on the right of the tab to close a tab.

• To open a new tab, click the   icon, which is next to the last tab:
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• To rearrange tabs, left-click on a tab, hold-down the mouse button then drag the tab to its new position

• When you open a new, 'blank' tab, it will display a list of your most visited websites for your easy access:

Next:

• Customize Your 'New Tab' Page

• Tab Settings

5.2.Customize Your 'New Tab' Page

• By default, the new tab page shows thumbnails of sponsored links and your most visited websites. 

• However, you can make the 'New Tab' page display whatever you want.

• Each website is shown as a tile. Tiles can be deleted and rearranged as you see fit.
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Add a site to the new tab page

• Open a new tab

• Click the bookmarks icon on the toolbar 

• Select 'Show All Bookmarks' to open the 'Library' window

• Select a bookmark and drag it to the new tab page

Add your top sites

• Click the three-dot button in the top-right corner of the page:

• Select '+ Add Top Site' to add the page 
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• Enter a title, URL of the site to define the appearance in a new tab

• Click 'Use a custom image' (optional)

• Click 'Add'

Set a top site

• Open a new tab

• Place your mouse over a tile

• A          will appear in the top-right corner of the tile. 

• Select 'Open in a New Window' to open in a new window

• Select ''Open in a New Private Window' to browse without being tracked

• Click 'Dismiss' to remove a tile

• Select ''Delete from History' to remove a site from your browsing history.

Rearrange top sites

• Simply click and drag the tile into the position you prefer

Comodo IceDragon User Guide | © 2020 Comodo Security Solutions Inc. |  All rights reserved                                                                    55



Comodo IceDragon - User Guide
Customize tab preferences

This lets you configure the sites and highlights shown when you open a new tab.

• Click the cog icon in the upper-right of the new tab

OR

• Click the Top Sites / Highlights three-dot menu

• Select 'Manage Section'

• You will be taken to 'Home' area

• Scroll to the 'IceDragon Home Content'

• Check 'Top Sites' to access the most visited sites

• Choose up to four rows of your favorite sites 

• Check 'Highlights' to enable sites you have recently visited or bookmarked. 

• You will see: Bookmarks, Pages Saved to Pocket, Visited Pages, Most Recent Downloads 

To reset the page and show blank tiles, you can clear your browsing history:

• Click the hamburger/menu button at the top-right corner

• Click 'Library' > 'History' > 'Clear Recent History' > select 'Clear Now' button.

5.3.Tab Settings
The following sections explain more about:

• Configure tab settings

• Restore previous session from the homepage

• Re-open tabs from your last session when you next start IceDragon

• Use right-click options

Configure tab settings

• Click the hamburger/menu button at the top-right corner

• Click 'Options' > 'General' button:

• CTRL+Tab cycles through tabs in recently used order - Enabled = by default - Lets you use Ctrl+Tab to 
view open tabs one at a time.

• Open links in tabs instead of new windows - Enabled = by default - any links you click will open in a new
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tab in the same IceDragon window. Disabled - any links you click will open in a separate IceDragon window.

• When you open a link in a new tab, switch to it immediately -  Check this option to load and display the 
page in a new foreground tab.

• Show tab previews in the Windows taskbar - Check this option to show a separate preview for each tab.

Restore a tab or a window from the homepage menu

• Click the hamburger button at the top-right corner

• Click 'Options' > 'Home'

• In the 'Home' area, click 'Restore to Defaults' 

Re-open tabs from your last session when you next start IceDragon

• Click the hamburger/open menu' button at the top-right corner

• Select 'Options' > 'General' tab

• Select 'Restore previous session' under the 'Startup' to restore all windows and tabs that were opened 
previously

• Click 'Warm you when quitting the browser' when you try to close the window

Warn dialog does not appear if:

• Opened one tab per a window

• Private Browsing Mode session is in use

• Session restored on startup

• Browser is restarted
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Right-click options

• Right-click on any tab to open a context-sensitive menu:

• Reload Tab - Refreshes the page

• Mute Tab - Turns off the sound of a particular tab

• Pin Tab - Pins the tab to left of the browser window

• Duplicate Tab - Copy the URL in the current tab and open it in a new tab 

• Select All Tabs - All opened tabs in the browser will be bookmarked

• Bookmark Tabs - Tabs that are currently open in the browser will be bookmarked

• Reload All Tabs - Reopens last closed tab in the same tab location of the browser window

• Move Tab - Move tab to start, end or open the tab in a new window 

• Send Tab to Device - Move tabs from your desktop to mobile device. Note: You need to be synced 
with your CID account

• Close Tabs to the Right -  Closes tabs to the right

• Close Other Tabs - Closes all other tabs

• Undo Close Tabs - Undoes closed tabs through a toolbar button or the right-click context menu

• Close Tab - Closes the tab
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Further reading related to the topic of this page:

• Use Tabs

• Customize Your 'New Tab' Page

6.  Bookmarks
Bookmarks are an easy way to save links to your favorite web-pages so you can quickly visit them later. This section
shows you how to create, edit and manage bookmarks. Click the following links to find out more.

• Create Bookmarks 

• Find and Edit Bookmarks 

• Manage Bookmarks 

• Import and Export Bookmarks 

6.1.Create Bookmarks
There are multiple ways to create a bookmark:

Method 1

When on a webpage that you want to bookmark, simply click the star at the right of the address bar:

• Once bookmarked, the star will change color to blue. 

• On all subsequent visits to bookmarked pages, you will see this blue star. 

• By default, a bookmark will be created in the 'Other Bookmarks' folder.

• Click the star to open option menu which allows you to modify bookmarks: 
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You can remove the bookmark or change the folder in which the bookmark is saved.

Method 2

• Click the three dot icon in the far address bar > ''Bookmark This Page''

Method 3

• Open a menu at top-right > 'Library' 

• In the 'Bookmarks' menu bar, select 'Bookmark This Page'

Method 4

To bookmark all open tabs at once, 

• Right-click on any tab and select 'Bookmark All Tabs...' on the context sensitive menu

• Next, assign a name for the set of bookmarks and specify the folder in which they should be saved 

• Click 'Add Bookmarks' to save your bookmarks.

Method 5

You can import bookmarks from other browsers.

Method 6

Drag and drop a link or URL onto the 'bookmarks' button on the right of the address bar. 

Method 7

Use the keyboard short cut CTRL+D to bookmark the page you are currently viewing.

The following links contain further reading on bookmarks:

• Find and Edit Bookmarks

• Manage Bookmarks

• Import and Export Bookmarks
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6.2.Find and Edit Bookmarks
The bookmark bar under the address bar shows all your bookmarked pages and folders. 

If you have not docked the bookmark bar, follow the steps given below:

• Dock the bookmark bar

• Add bookmarks to the bookmarks toolbar

• Relocate bookmarks on the bookmarks toolbar

• Right-click options

• Edit bookmarks

• Delete bookmarks

Dock the bookmark bar

• Click the hamburger/menu button at the top-right corner > 'Customize'

• This will open the 'Additional Tools and Features' page

• Click the 'Toolbars' drop-down at the bottom and enable 'Bookmarks Toolbar'

• Click the 'Done' button or close the tab

• The new toolbar will immediately appear below the address bar

Add bookmarks to the bookmarks toolbar

• Open the web page to be added to the bookmarks toolbar

• Click and simply drag the web site icon on to the bookmarks toolbar in the 'Location' bar

Relocate bookmarks on the bookmarks toolbar

• Click the bookmark or folder and drag it into new position.

Right-click options on the bookmark bar

The following options are available when you right-click on the bookmark bar:
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• Open All in Tabs

• New Bookmark

• New Folder

• New Separator

• Paste

Edit bookmarks

• Click the blue star on the address bar

• Name - Bookmarks label.

• Folder - Default folders to store your bookmark (Bookmarks Toolbar, Bookmarks Menu, Other Bookmarks). 
Click the arrow beside the drop-down to specify a different folder or create a new folder.

• Tags - Set tags for the bookmark. Tags can be searched from the IceDragon address bar. 

• Click the arrow button to expand the 'Folder' / 'Tags' or to create a new folder.

Delete bookmarks

• Open the page in your bookmarks

• Click the star icon and click 'Remove Bookmark' button

Please note: When you delete a folder, all the bookmarks in the folder will also be deleted.

Set the toolbar icon

• Click the hamburger/menu button at the top-right corner then select 'Customize'

• Click the 'Done' button to appear in the bookmarks tool bar.

Show/hide the bookmarks toolbar

• Click the hamburger/menu button at the top-right corner then select 'Customize'

• Deselect the 'Bookmarks Toolbar' in the 'Toolbars' drop-down.
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6.3.Manage Bookmarks
Comodo IceDragon allows you to organize your bookmarks as required. From here you can edit, delete or rename 
bookmarks and folders. 

Organize your bookmarks

• Click the star icon on the right of the file-menu

• Select 'Show All Bookmarks' from the menu

The 'Library' interface will open:

From here you can:

• Search bookmarks

• View / sort bookmarks

• Rename / edit bookmarks

• Delete a one bookmark 

• Delete multiple bookmarks
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• Move a bookmark

Search bookmarks

• Enter the bookmark name in the search box in the 'Library' interface

Or

• Enter the bookmark name in the search box from the Side bar.

View / sort bookmarks

• Click the Bookmark button and select 'Show All Bookmarks'

• Click the 'Views' button to open menus which allow you to sort bookmarks by various criteria, and to add 
additional columns to the bookmarks table.

• Alternatively, right-click on the 'Bookmarks Toolbar' folder and select 'Sort By Name'

Rename a folder, bookmark or edit its address

• Select the bookmark you want to edit

• Click the star icon and change the name of the bookmark in the 'Edit This Bookmark' dialog

OR

• Click the 'Show your bookmarks' icon next to the address bar. Select a bookmark from the list and edit its 
name or URL using the fields at the bottom of the interface

Aadd a new bookmark folder

• Select the location you want to add new bookmark folder in the left side

• Click the 'Organize' menu and select 'New Folder'

• You can also right-click on the desired location and add a new folder from the menu.

Delete bookmarks or folders

• Click on the star icon in the 'Location' bar

• Click the 'Remove Bookmark' button

OR

• Click the 'Show your bookmarks' icon on the right of the address bar

• Select 'Show All Bookmarks' to open the 'Library' window

• In the left pane, click on the folder you want to view (its content appears in the right pane.)

• CTRL+click to select multiple items

• Right click on the selected items and select 'Delete' (or click 'Organize' > 'Delete')

Move bookmarks

Just click and drag a bookmark or folder to another destination to the folder list in the left side.

6.4.Bookmarks - Import, Export and Back up

You can import bookmarks from other browsers, export bookmarks to HTML and automatically create backups of 
your bookmarks on a daily basis.

Click the following links for more help:

• Import bookmarks
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• Import bookmarks from any browser as a HTML file

• Export bookmarks

• Restore from backup

Import bookmarks from Microsoft Edge and Internet Explorer

• Click the star icon > 'Show your bookmarks' button

• Select 'Show All Bookmarks' 

• Select 'Import and Backup' 

• Select 'Import Data from Another Browser'. 

• Select the browser from which you want to import and the specific items you wish to import:
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• Cookies: Small files stored on your computer by websites you have visited that contain information 
about your preferences while on that website. Cookies are used for such things as keeping you logged 
in to a website and to save your site preferences

• Browsing History: A list of URLs that you have recently visited

• Saved Passwords: All authentication information in a selected browser 

• Favorites: (also known as 'Bookmarks'). Imports your bookmarks from the source browser

• Click the 'Next' button then click 'Finish' at the confirmation dialog:
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Bookmarks from the other browsers will now be available in Comodo IceDragon in a folder named 'From Internet 
Explorer', Chrome or 'Microsoft Edge'.

• To view and access your bookmarks, simply click the bookmarks button. 

• All Bookmarks (including any imported) will be listed in the menu:

Import bookmarks from any browser as a HTML file

• Click the 'Show your bookmarks' button then 'Show All Bookmarks'

• Click the 'Import and Backup' tab on the 'Library'

• Click 'Import Bookmarks from HTML'

• Navigate to the HTML file saved in your computer and click 'Open'.

Export bookmarks 

• Click the 'Show your bookmarks' button then 'Show All Bookmarks'

• Click the 'Import and Backup' tab on the 'Library' 

• Select the 'Export Bookmarks to HTML' 

• Choose a location where you want the bookmarks to be saved and click the 'Save' button

Restore from backup

• Click the 'Show your bookmarks' button then 'Show All Bookmarks'

• Click the 'Import and Backup' tab on the 'Library' 

• Click 'Restore'. Select the backup from which you want to restore

• The dated entries are automatic backups.

• 'Choose File...' lets you restore from a manual backup.

The 'Revert Bookmarks' dialog will appear, click 'OK'.

After choosing a backup, your bookmarks will be restored.
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7.  Privacy And Security
This section explains how to configure privacy and security settings in Comodo IceDragon as per your browsing 
requirements. By default, IceDragon is designed to ensure your private data remains safe and secure while browsing
online.

Click the links to find out more:

• Private Browsing

• Delete browsing history and configure history settings

• Allow/block pop-up windows

• Manage Cookies and Site Data

• Block websites from tracking your browsing history

• View and manage permission settings

• Configure suggestions when entering a website address

• Manage Cache

• Manage Add-on Permissions

• Manage passwords

• TLS/SSL Certificates and Secure Connections

• SSL/HTTPS security settings

• Force Secure Connections

• Website Security Indicators

• Disable accessibility indicator setting

• Configure IceDragon performance and browsing settings

• Network Proxy settings

7.1.Private Browsing
In a private browsing session, IceDragon does not store:

• Browser history

• Search history

• Download history

• Web form entries

• Cookies

• Passwords

• Temporary internet files

This helps improve your overall security by removing any local copies of internet activity. Any bookmarks you create 
are, however, kept. 
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Start a Private Browsing session

• Click the hamburger button at top-right 

• Select 'New Private Window'

• Start browsing as normal by opening a bookmark or searching from the address bar

• A mask icon is shown at top-right while in 'Private Browsing' mode:

See Block Websites From Tracking Your Browsing Activities for more details on how to block website elements 
that could track your browsing activity 

Enable Private Browsing Permanently

If you want all your browsing sessions to be kept private, you can enable private browsing permanently.

• Click the hamburger at top-right corner 

• Click 'Options' > 'Privacy & Security' tab

• Click the 'IceDragon will' drop-down > select 'Use custom settings for history'
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• Enable 'Always use private browsing mode'. 

• Restart the IceDragon at the prompt to enable the feature.

7.2.Delete Browsing History and Configure History Settings

• IceDragon saves certain data to speed up website load times and improve your online experience. 

• Items stored include a history of your visited pages, cookies, form data and cached page content. 

• You may wish to clear these items periodically for performance and security reasons.

• Delete Browsing History

• Configure History Settings

Delete browsing history

• Click the hamburger button at the top-right corner

• Select 'Library' > 'History' > 'Clear Recent History' 
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• In the 'Clear Recent History' dialog, select the period that you want to clear history from the 'Time range to 
clear:' drop-down box.

• Leaving this at the default of 'Everything' will clear all history information in your browser. 

• 'History' displays items from which you can select for the history information to be removed. 
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• The following items can be deleted: 

• Browsing and Download History - Browsing history is the list of websites that you've visited and the 
download history is the list of files that you've downloaded.

• Active Logins - Authenticated sessions that are still active, that is, if you've logged into a website that 
requires authentication, are called active logins. 

• Form & Search History - Form history are the list of terms that you've entered in web page forms and 
these terms will be listed in a drop-down menu in the Auto Form Fill as you start entering the first few 
letters in the form field.

• Cookies - Cookies are small pieces of information sent by websites that you've visited which are 
stored by your web browser. Cookies are used by these websites to store your preferences about that 
website (for example, if you ask a website to 'Keep me logged in' or similar, it is the cookie that keeps a
record of this preference). 

• Cache - The cache memory stores temporary files, such as of web pages that you've visited, which will
help to load the pages much faster when you are visiting any of them once again.

• 'Data':

• Site Preferences - Settings configured by you for certain websites such as zoom level and 
permissions.

• Offline Website Data - If you've saved a webpage as 'Web Page, complete' in the save as option 
in the 'File' menu, you can view the page even if you are not connected to the internet.

• Select items you wish to delete and click 'Clear Now'.

Configure history settings

The 'Privacy and Security' section in 'Options' lets you specify default history settings for IceDragon. 

• Click the hamburger/'Open Menu' button at the top-right corner

• Select Options' > 'Privacy and Security' tab > 'History' 

• In the 'History' section, specify default behavior in the 'IceDragon will' drop-down
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The options available are: 

• Remember history - The browser will always remember history and you have to clear it manually as 
explained in the first half of this page. 

• Never remember history - The browser will never store any history.

• Use custom settings for history - If you select this, you have the following options: 

• Always use private browsing mode - If you select this option, IceDragon will always open in private 
browsing mode. See 'Private Browsing' for more details. 

OR

• Click 'Clear History...' to open the history management screen as shown below:
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7.3.Allow/Block Pop-up Windows
Many websites open pop-up windows to show adverts and other messages.

While many of them are used for legitimate purposes (for example, banking sites use pop-ups for login screens and 
to provide warnings), some may be used for malicious purposes like injecting rootkits, keyloggers and other 
malware. Other pop-ups can just be plain annoying adverts. 

• Comodo IceDragon blocks pop-up windows by default. 

• You can configure IceDragon to allow or block pop-ups as you wish and can add exceptions so that pop-
ups from selected websites are always allowed.

• When a website tries to open a pop-up, IceDragon shows a message telling you that the pop-up was 
blocked.

Configure pop-up windows

• Click the hamburger button at the top-right corner

• Select 'Options' > 'Privacy & Security' 

• To block pop-up windows, make sure the 'Block pop-up windows' box is enabled in the 'Permissions':

• To permanently allow pop-ups from all websites, deselect the check-box (not recommended)

• To add exceptions for pop-ups, click 'Exceptions'
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• Enter the URL of the website for which you want to allow pop-ups permanently in the 'Address of website' 
field and click 'Allow'

The site will be added to the list of websites which are allowed to show pop-ups. All the pop-up windows opened by 
this website will be allowed regardless of your setting in 'Block pop-up windows' check box.  

• Click 'Save Changes'.

7.4.Manage Cookies and Site Data

Cookies in brief:

• Cookies are small files stored in your browser by websites that you've visited. They contain information 
about your website preferences and can sometimes be used to authenticate you. 

• For example, if you ask a website to 'Remember me' or similar, it is the cookie that keeps a record of 
this preference.

• Most cookies are stored for the worthwhile purpose of service improvement, but they can also be used to 
track you and record data. Examples:

• Session cookies allow a website to remember your page changes and selections as you move from 
page-to-page. A shopping cart is a good example of this usage.

• A search engine may store cookies to fetch your search history and will display targeted adverts to you 
on various web-pages you visit.

• Some malicious sites may use cookies to log sensitive information about you. Hackers could, in theory, 
intercept a cookie sent from your browser to a website and extract sensitive data. 

• To maintain your privacy and security, you need to clear cookies from your browser periodically and 
evaluate your overall policy regarding allowing or blocking cookies. 

• By default, IceDragon accepts cookies from the websites you visit. You can configure it to allow or block 
cookies, or to accept/block cookies on a per-site basis.
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Browser cache in brief:

• The cache is a repository used to store web pages, images and other web content so that pages load faster
on future visits.

Site data in brief:

• Some websites require you to download files in the background so the site runs faster and to keep 
information from being lost.

• These files, used by websites and keep in your local storage, can be removed manually. 

Click the links below for more help:

• Clear Cookies, cache and site data

• View and remove stored cookies and site data individually

• Allow / block cookies and site data

• Add exceptions for storing cookies and site data

Clear cookies, cache and site data

• Click the hamburger button at top-right

• Select 'Options' > 'Privacy and Security' > 'Cookies and Site Data' section

• Click the 'Clear Data' button

• Select whether you want to delete cookies or cached content, or both.

• Click 'Clear'.

• Confirm your choice by clicking 'Clear Now' in the confirmation dialog.

View and remove stored cookies individually

The 'Manage Cookies and Site Data' dialog lets you review and manage data stored on your computer by websites. 

Access cookies and site data dialog

• Click the hamburger button at top-right 

• Сhoose 'Options' >'Privacy & Security' > 'Cookies and Site Data'
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• Click 'Manage Data' button to open the 'Manage Cookies and Site Data' dialog

• To delete an item, select it and click 'Remove Selected'.

• To delete all items, click 'Remove All'.

• Click 'Save Changes'. 

Allow cookies and site data from a website

• Click the hamburger/ menu button at top-right 

• Click 'Options' > 'Privacy and Security' > 'Cookies and Site Data'

• Leave the 'Accept cookies from websites (recommended)' checkbox selected.

• Accept third-party cookies and site data - Enable if you want to allow cookies from websites you visit or 
other applications.

Keep Until - Select the time period that the data should be retained by IceDragon:

• They expire - Cookies and site data will be stored until their end-of-life as set by the website

• I close IceDragon - Third-party cookies will be cleared when you end your browsing session.

Accept third-party cookies.... - Select when or from whom you should accept cookies:

• Always

• From visited

• Never

Block cookies and site data from a website

• Check the 'Block cookies and site data (may cause websites to break)' box. Some websites will not function
if you block cookies.

Add exceptions for storing cookies and site data
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• Click the hamburger/menu at top-right 

• Click 'Options' > 'Privacy and Security' > 'Cookies and Site Data'

• Click 'Exceptions' beside 'Accept cookies from websites' checkbox.

• Enter the url of the website for which you want to allow or block cookies or site data permanently.

• Click 'Block' to stop the cookies or site data from the site. Regardless of whether the checkbox 'Accept 
cookies and site data from websites' is checked or not, the cookies and site data from this site will be 
blocked.

• Click 'Allow for Session' to allow the cookies or site data from sites and remove them when IceDragon 
closes.

• Click 'Allow' to allow the cookies and site data from the site. Regardless of whether the checkbox 'Accept 
cookies and site data from websites' is checked or not, the cookies or site data from this site will be allowed.

The website will be added to the list with the 'Allow', Allow for Session or 'Block status' as specified.

To remove a specific website from the exceptions list

• Select the website and click 'Remove Website' 

• To remove All websites at once from the exceptions list, click 'Remove All Websites' 

• Click 'Save Changes'.
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7.5.Block Websites from Tracking your Browsing Activities

To configure tracking protection: 

• Click the hamburger icon

• Click 'Options' > 'Privacy and Security'

• Scroll down to the 'Content Blocking' section

Some websites record the browsing activities of visitors. For example, a web site may track your activity to find your 
interests and display relevant content and advertisements. While this can make for a more personalized online 
experience, it can also allow websites to build a  potentially invasive profile of your online activity.

• Content blocking prevents known trackers from recording your online behavior. You will see a shield icon  in
the address bar when IceDragon blocks content on a website. 

• Click the small 'i' or the shield icon to view what IceDragon detects and blocks on sites that you visit.

• The 'Content Blocking' section lets you configure how you want to deploy this feature:

• Standard – Default mode. Ice Dragon allows trackers in normal sessions but blocks them in private 
sessions. 

• Strict - Ice Dragon blocks trackers at all times in both normal and private browsing sessions. Note – 
Blocking cookies and trackers may cause some websites to break.

• Custom – Select what you want to block:

• Trackers - Blocks all cookies set by trackers. Choose the sessions in which you want to block trackers:

• In all windows - Ice Dragon will block trackers at all times in both normal and private browsing 
sessions.

• Only in Private Windows - Ice Dragon will allow trackers in normal sessions but block them in 
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private sessions.

• Cookies – The options available to block cookies are:

• Third-party trackers

• Cookies from unvisited websites

• All third-party cookies (may cause websites to break)

• All cookies (will cause websites to break)

Note - Your preferred settings are kept for all sessions until you change them.

• 'Do Not Track' – A setting that tells websites you visit that you do not want them to monitor or record your 
behavior.

• 'Always' - Will send the 'Do not track' command to every site you visit during both regular and private 
browsing sessions.

• 'Only when IceDragon is set to block known trackers' - Will send the 'Do not track' command if  
tracker protection is active for the session.

• Exceptions - A shield icon in the address bar indicates IceDragon is blocking a tracker on the site. All sites 
for which tracking is allowed are listed in 'Exceptions - Content Blocking'.

• To remove a site from exceptions

• Click the information or shield icon again and click 'Turn on Blocking for This Site'

OR

• In the content blocking section, click 'Manage Exceptions'

• Select the website and click 'Remote Website'. Click 'Remove All Websites' to delete all exceptions.

• Click 'Save Changes'. 

7.6.View and Manage Permission Settings

• By default, Ice Dragon will ask your permission every time a site requests your location, for access to your 
camera/microphone, or to send you notifications. 

• You can allow or block the request as you deem appropriate.

• Permission settings let you view all websites that have made such requests, and view/modify your settings 
for each site.

• Tip. You can view the permissions you have given to a specific site by clicking the information icon next
to the address bar:
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Access permissions settings

• Click the hamburger icon

• Click 'Options' > 'Privacy & Security'

• Scroll down to the 'Permissions' section
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• Location - Determines whether or not a website is allowed to request and learn your current location. You 
can revoke this permission for all sites you visit or for specific sites. 

• Camera / Microphone - Manage permissions for a specific or all pages to which it is allowed / blocked to 
use camera / your microphone. This applies to video or image / recording sites available.

• Notifications - Set whether  or not to receive notification from a website. A website which is allowed to 
send notifications can send you in-browser messages related to their services. These are shown even if you
are not on their website at the time. 

• Pause notifications until IceDragon restarts - You will not be sent any more notifications during this 
session. Notifications will only resume after Ice Dragon is restarted.

• Block pop up windows - Does not allow pop up windows on websites. You can specify exceptions if 
required.  Exceptions are sites on which you will allow pop-ups. 

• Warn you when websites try to install add-ons -  Notifies you when websites try to automatically install 
extensions/short cuts. It is enabled by default for security and privacy.

• Prevent accessibility services from accessing your browser -  Accessibility services are provided by 
3rd party vendors to alter the appearance of web site content on behalf of impaired users. For example, an 
accessibility service may magnify page text by default for visually impaired users. You can disable this 
service if you know nobody who uses the computer benefits from accessibility services.

7.7.Configure Suggestions when Entering a Website Address

• IceDragon uses your browsing history and bookmarks to provide suggestions when you start typing an 
address in the address bar.

• Simply click on one of the suggestions to visit that page.
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Click the following links to find out more:

• Configure suggestions

• Exclude a website from suggestions

• Exclude a single webpage from suggestions

Configure Suggestions

IceDragon allows you the select the sources from which suggestions are drawn, or to stop suggestions altogether.

• Click the hamburger/menu button at the top-right corner 

• Select 'Options' > 'Privacy & Security'
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• Under 'Address Bar', select the option for 'When using the location bar, suggest'

• Browsing History - Provides suggested sites from your browsing history only.

• Bookmarks - Provides suggested sites from your bookmarked sites only.

• Open tabs - Provides suggested sites from open tabs only.

Exclude a website from suggestions

Allows you configure IceDragon to block suggestions from a specific website.

• Click the hamburger/menu button at the top-right corner and select 'Library' > 'History'.

• Click 'Show All History' at the bottom of the menu.

• In the 'Library' interface use the 'Search History' at top-right to find a web site.

• Right-click on a website page and select 'Forget About This Site' from the context sensitive menu.

• Ice Dragon will no longer suggest pages from the website.

Exclude a single webpage from suggestions

• Type a part of the webpage address in the address bar.

• Hover your mouse cursor over the suggestion you want to exclude and press 'Delete' key from the 
keyboard.

7.8.Manage Cache

• The cache is a repository of web pages, images and other content that you have visited. Ice Dragon keeps 
this cache so it can load pages faster the next time you visit them. 

• The cache can grow quite large over time as it is used to store data from every site you visit. 

• Clearing the cache will free up disk space and remove any corrupt data that is causing pages to load 
incorrectly. 

Clear the cache

• Click the hamburger/menu button at top-right 

• Select 'Options' > 'Privacy & Security' > 'Cookies and Site Data'

• Click 'Clear Data' button

• Leave the 'Cached Web Content' checked

• Click 'Clear' to apply your settings.

Automatically clear the cache

• Click the hamburger/menu button at top-right 

• Click 'Options' > 'Privacy & Security' > 'History' section

• 'IceDragon will' - Select 'Use custom settings for history' 

• Select 'Clear history when IceDragon closes'

• Click the 'Settings' button next to it

• Make sure the 'Cache' box is checked:

Comodo IceDragon User Guide | © 2020 Comodo Security Solutions Inc. |  All rights reserved                                                                    84



Comodo IceDragon - User Guide

• Click 'OK' to apply your changes.

Offline Web Content and User Data Management

Some websites store user data on your computer for offline use. You can delete this offline data if required.
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To remove the cache from the About Config page

• Type about:config in the address bar and press 'Enter'.

A warning will open:
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• Click 'I accept the risk!'

The configuration page will open:

• Type 'browser.cache' in the search field then double click in the browser.cache.disk.enable and 
browser.cache.memory.enable entry.

• Alternatively, right-click on browser.cache.disk.enable and browser.cache.memory.enable and select 
'Toggle'.

• Switch to 'false' value and restart the browser.
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7.9.Manage Add-on Permissions

Add-ons are small pieces of software designed to expand the functionality of Ice Dragon. Add-ons are broadly 
classified as: 

• Extensions - Add new features to the browser. Examples include extensions to auto-update Facebook 
profiles, analyze your typing skills, detect website trackers, compare prices from different e-merchants and 
more.

• Appearance - Customize how the browser should appear by applying themes and styles.

• Plugins - Support different kinds of file types from the internet. For example, to open .pdf files, play video 
and audio files, play online games and so on. 

See 'Introduction to  Add-ons' for more details.

While most add-ons are safe, some may be harmful, injecting rootkits, key-loggers and other malware.

Ice Dragon lets you choose the level of permission that websites have to install add-ons:

Click the links below for more help:

• Allow/block automatic installation of Add-ons by websites

• Add exceptions for automatic Add-on installations

Configure automatic installation of add-ons

1)

• Click the hamburger button at the top-right corner 

• Select 'Options' > 'Privacy & Security' > 'Permissions'

• Warn you when sites try to install add-ons' - If enabled, you will see an alert if a site tries to install 
an add-on. You can decide whether to allow or block it.
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2)

• Click the hamburger button at the top-right corner

• Select 'Options'  > 'Privacy & Security' > 'Security'

• Block dangerous and deceptive content (aka 'Phishing', malware, attack sites, unwanted software) - 
Blocks unknown sites, unwanted files and downloads. An alert is displayed if you try to connect to a 
dangerous site.

• 'Block dangerous downloads' - Detects and prevents the download of malicious apps. 

• 'Warn me about unwanted and uncommon software' - Shows an alert if an app tries to harm your 
browsing experience. Examples include changing your homepage or showing additional adverts on 
websites you visit.

Add exceptions for automatic installation of Add-ons

• Click the hamburger/menu button at the top-right corner 

• Select 'Options'  > 'Privacy & Security' > 'Security'

• Click 'Exceptions' beside the 'Warn me when sites try to install add-ons' checkbox
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The exceptions dialog will open:

• Enter the url of the website for which you want to allow add-ons.

• Click 'Allow'. Regardless of whether the checkbox 'Warn me when sites try to install add-ons' is checked or 
not, the add-ons from this site will be allowed for automatic installation.

The website will be added to the exceptions list with the 'Allow' status.

• To remove a website from the exceptions list, 

• Click 'Exceptions' beside 'Warn me when sites try to install add-ons' .

• Select the website and click 'Remove Site'.

• To remove all the sites from the exception list, click 'Remove All Sites'.

• Click 'Save Changes'.

7.10. Manage Passwords

• Ice Dragon can securely remember your usernames and passwords and automatically enter them the next 
time you visit a site. 

• This can be a great time saver, but is not recommended for shared computers or public computers.

This page explains how the 'Remember' system works from a user point of view, before explaining how you can 
configure advanced password settings.

The following links provide more help on:

• The 'Remember Password' prompt 
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• Configure the 'Remember Password' option

• Configure Exceptions

• View and manage stored passwords

• Use a master password

The 'Remember Password' prompt

When you enter your username and password in a login page, IceDragon will offer to remember your credentials.

• For the browser to save your password, select 'Save'

• Don't Save - Select this option if you don't want to save the password right now but want to be asked again
the next time you visit.

• Never Save - Select this option if you do not want to save the password for the site. The password you 
entered will not be saved and the site will be added to the exception list (see below). IceDragon will not offer
to save your password the next time you visit the site.

Configure 'Remember Password' options

• Click the hamburger/menu button at the top-right corner

• Select 'Options' > 'Privacy & Security' > 'Browser Privacy' > 'Login & Passwords'

• 'Ask to save logins and passwords for websites' - Disable if you do not want IceDragon to auto-fill logins
and passwords.
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• Exceptions - Add websites for which IceDragon should not remember your username and password.

• Saved Logins - A list of all the websites for which IceDragon has saved the username/password. You 
can remove or import sites as required.

• 'Use a master password' - If enabled, IceDragon will require you enter a password before it will auto-
complete your username and password on a login page. 

Configure Exceptions

• Websites for which you chose never remember password at the prompt are added to exclusions. 

• The passwords for these sites will not be saved and the remember password prompt will not appear after 
logging in to these sites in future. 

• You can view and remove sites from the exclusion list as follows:

View exception logins

• Click the hamburger/menu button at the top-right  

• Select 'Options' > 'Privacy & Security' > 'Browser Privacy' > 'Login & Passwords'

• Click 'Exceptions' beside the 'Ask to save logins and passwords for websites' 

The 'Exceptions - Saved Logins' dialog will open:

• To remove a site from exceptions, select the site and click 'Remove Website'.

• To remove all sites from exceptions, click 'Remove All Websites'.

View and Manage Stored Passwords

• Click the hamburger/menu at the top-right then 

• Select 'Options'  > 'Privacy & Security' > 'Browser Privacy' > 'Login & Passwords'
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• Click 'Saved Logins' beside the 'Ask to save logins and passwords for websites' 

The 'Saved Logins' interface shows list of sites that have stored passwords associated with them. You can search 
the list for a specific username or website by entering it fully or partially in the search bar.

• To delete a stored password, select the website and click 'Remove'.

• To delete all stored passwords, click 'Remove All'.

• To import your login from another browser, click 'Import'.

• To view a password saved for the site, click 'Show Passwords' and enter the master password in the dialog.

• Click 'Hide Passwords' to conceal the password.

• Click 'Close' to exit the 'Saved Logins' interface.

Set a master password

• If you have asked IceDragon to remember your usernames and passwords, then they will be automatically 
entered whenever you visit the site. 

• While this is convenient, it can be a security risk if someone else uses your computer. They could visit the 
login page of one of your websites then automatically gain access to your account. 

The master password feature overcomes this by requiring you enter a password before IceDragon will auto-
populate your login credentials.

Important: Do not forget your master password. If you do, you will not be able to access your saved passwords.  

Specify a master password

• Click the hamburger/ menu button at the top-right corner

• Select 'Options' > 'Privacy & Security' > 'Browser Privacy' > 'Login & Passwords'

• Check the 'User a master password' box.

The 'Change Master Password' dialog will open: 
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• Enter a password to authenticate in the 'New password' box and then repeat it. Click 'OK' 

• Click 'OK' for the settings to tale effect.

• You can change your master password as frequently as you would like to ensure that it remains secret.

Change the master password

• Click the hamburger/ menu button at the top-right corner

•  Select  'Options' > 'Privacy & Security' > 'Browser Privacy' > 'Logins and Passwords'

• Click 'Change Master Password' beside the 'Use a master password'
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• Type your current password, then enter your new password and re-enter it in the 'Re-enter password' field.

• Click 'OK' in the confirmation dialog.

• Click 'OK' for the settings to rake effect.

In order to change your forgotten master password, reset it .

Warning note: All your saved usernames and passwords will be removed after resetting your master password.   

In the 'Location' bar, enter the following,

chrome://pippki/content/resetpassword.xul 
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• Click 'Reset'.

Remove the master password

• Click the hamburger/menu at the top-right corner

• Select 'Options' > 'Privacy & Security' > 'Browser Privacy' > 'Logins and Passwords'

• Uncheck 'Use a master password' 
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• Type you current password in the The 'Remove Master Password'

• Click 'Remove'

• In the warm dialog, click 'OK' to confirm your removal.

7.11. TLS/SSL Certificates and Secure Connections

• Whenever you make a secure connection to a website, the beginning of the URL will change from HTTP to 
HTTPS (with the ‘S’ standing for secure). 

• A padlock will also appear at the left of the address. This indicates that the page is using a TLS/SSL 
certificate to encrypt all communications between you and the site. 

• However, not every type of certificate should be trusted to the same degree.

There are three main types of certificate:

• Domain Validated (DV)

• Organization Validated (OV)

• Extended Validation (EV)

Domain Validated (DV) - These certificates have the lowest cost but do not identify owner of the website. DV certs 
are issued after the applicant has proven they control the domain for which the certificate is intended. Applicants can 
validate domain control using fast, online methods, such as responding to a challenge-response email. EV and OV 
similarly require domain control validation, but also require the applicant to supply business documentation to 
confirm their identity. 
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Organization Validation (OV) - These certificates include full business and company validation from a certificate 
authority using currently established and accepted manual vetting processes. Because of this requirement, these 
certificates provide significantly higher levels of trust and security than DV SSL certificates but are not validated to 
the stringent standards set by the CA/B forum and do not possess the ability to turn the address bar green in the 
latest browsers.

Extended Validation (EV) - EV certificates are validated to the strong guidelines set by the CA/B Forum, an 
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independent standards body consisting of major browser providers and certificate authorities. EV certificates are only
issued after in-depth background checks have been carried out on the applicant company. Because of this, EV 
certificates provide the highest levels of security and trust to end-users. To reflect this higher level of trust, IceDragon
shows a green indicator if a site has an EV certificate. The indicator contains the name and address of the company 
that owns the website, and the name of the CA who issued the certificate.

Trust between a person using a browser and the site they are visiting is only confirmed when two stages of validation
are complete:

1. Verification that the certificate applicant owns the domain name of the website.

2. Verification that the certificate applicant is a legitimate and legally accountable business.

Step 2) is carried out by a Certificate Authority (CA) such as Comodo or Symantec. A CA employs human operatives 
to carry out strict vetting of the applicant’s business and legal standing. Only once this layer of company validation 
has been completed can a website be truly ‘trusted’. 

Users can tell an EV certificate because the name of the company that owns the site is shown in green text next to 
the URL. You can also click the lock to view complete details. The following screenshot shows the certificate on 
instantssl.com, which is operated by Comodo.

7.12. Manage SSL Certificates and HTTPS Security

• Comodo IceDragon uses TLS/SSL certificates to encrypt data in transit between the browser and the 
website you are connected to. 

• For example, when you make a purchase online, the order form will be secured with a website SSL 
certificate. You can tell when you are on an encrypted connection because the website address will 
begin with https:// rather than http:// (with the 's' standing for secure).

• Other indicators include a padlock in the address bar and, in the case of Extended Validation certificates, 
the address bar itself will change color to green. The lock indicates that confidential information such as 
credit card details are securely encrypted and cannot be intercepted en-route by a thief.
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• Website SSL certificates also contain authentication information about the website owners, including the 

company name and physical address. This allows you to verify that the website you are connected to is 
owned and operated by a legitimate company. Please visit http://www.instantssl.com for more details. 

• Personal, client and email certificates are used to authenticate people, encrypt communications and 
digitally sign documents. For more details, please visit https://www.instantssl.com/ssl-certificate-
products/personal-authentication-certificate.html 

Manage personal and website certificates

• Click the hamburger/menu button at the top-right

• Select 'Options'  > 'Privacy & Security' > scroll to the 'Certificates' section

Websites usually request a personal certificate as part of a two-factor authentication scheme. The website requires 
you to enter your username/password as usual, plus present your personal certificate. 

• If you want IceDragon to select one automatically from its certificate store, choose 'Select one 
automatically'. 

• If you want to manually select the certificate yourself when a website asks for a personal certificate, select  
'Ask you every time'

• 'Query OCSP responder servers...' - If enabled, Ice Dragon will run an Online Certificate Status Protocol 
(OCSP) check of every SSL certificate it encounters. OCSP checks establish whether or not the certificate 
has been revoked or not. 

The 'Certificates' configuration settings enables you to:

• View and manage certificates

• Configure security modules that store certificates and passwords

View and manage certificates

• Click 'View Certificates' under 'Certificates'.

The 'Certificates Manager' window will be opened. The 'Certificates Manager' has the following tabs:

• Your Certificates

• People

• Servers

• Authorities

Your Certificates

The 'Your Certificates' area lists your personal/client/secure-email certificates.
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The dialog enables you to:

• Import your certificate from your local storage to your browser

• View the certificate details

• Backup your certificate(s)

• Delete expired or revoked certificates

Import your certificate 

You might have stored your personal authentication, client or secure-email certificate downloaded from a 
Certification Authority (CA) or the one provided by your Network Administrator in your computer. You can import and 
install the certificate into your browser through the 'Certificate Manager'.

To import your certificate

• Click 'Import' from the 'Certificate Manager' > 'Your Certificates' interface

• Browse to the location where you stored your certificate and click 'Open'

You will be prompted for entering the password you entered while storing the certificate in your computer. 

• Enter the password that was used while storing the certificate and click 'OK'

Your certificate will be imported to the certificate store of the browser.

View Certificate Details
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• To view the certificate, select the certificate and click 'View'. 

The general information and detailed information on the certificate will be shown under the respective tabs in 
'Certificate Viewer' dialog. 

Store a Backup of a certificate 

You can store a backup of your certificate(s) for safe-keeping. The backup enables you to re-install them if you have 
to uninstall and re-install the browser.

To backup a certificate 

• Select the certificate and click 'Backup...' 

• Navigate to a safe location in your local computer or your network and enter a file name

• Click 'Save'

You will be prompted to enter a password for the backup. Your certificate will be stored in the backup in an encrypted
form with this password. In order to restore your certificate, you need to enter this password.
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• Type a password and re-enter it for confirmation in respective fields. Choose the password as a mixture of 
alphanumeric characters, upper and lower case letters and special characters. The password quality meter 
shows the strength of the password you have chosen.

• Click 'OK'.

• To backup all you certificates at once, click 'Backup All...' and follow the same procedure.

Delete a certificate

• Select the certificate to be deleted and click 'Delete'.

• Click 'OK' in the confirmation dialog.

Note: If you delete your currently active certificate, you will not be able to use it for identifying yourself to the 
websites that require it. 

People

The 'People' tab lists other people's client and email certificates. You usually obtain these by receiving a signed email
from the person in question. These certificates are necessary if you want to encrypt messages/email you send to the
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contact. Likewise, they will need your certificate to encrypt messages they send to you.

The dialog enables you to:

• View the certificate details

• Import other person's certificate from your local storage to your browser

• Export a certificate 

• Delete expired or revoked certificates

View the Certificate

• To view the certificate, select the certificate and click 'View'.

The general information and detailed information on the certificate will be shown under respective tabs in 'Certificate 
Viewer' dialog similar to that of your certificate. Please see View the Details of the 'Certificate' in the previous 
section.

Import another person's certificate to your browser 

In addition to other people's certificate's certificates automatically stored in your browser, you can manually import 
some people's certificates with whom you may communicate through encrypted channel. For example, you can 
export your contact's certificate to your local storage and import into IceDragon browser.

The procedure is same as importing your own certificate. Please see Import your certificate in the previous 
section.

Export Other People's Certificates

You can export other people's certificate from IceDragon to a safe place, for safe keeping and for importing from 
other browsers or email clients.

To export a certificate

• Select the certificate

• Click 'Export' and navigate to a safe location in your computer or your network.

• Click 'Save'

Remove a Certificate

• Select the certificate and click 'Delete'.
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• Click 'OK' in the confirmation dialog.

Server Certificates

The 'Server Certificates' tab lists root certificates that are pre-embedded in IceDragon or have been imported by the 
user.

This interface allows you to:

• View the certificate details - The procedure is similar to view your own certificates. Please see View the 
Details of the Certificate for more details.

• Export Server Certificates - Export and save server certificate in a safe location for future use, example, 
for importing to other browsers or email clients.  The procedure is similar to exporting other people's 
certificates. Please see 'Export other people's certificates' for more details.

• Import Certificates from local storage - Import server certificates stored locally in your system or in your 
network into the browser. The procedure is similar to importing your own certificates. Please see 'Import 
your certificate ' for more details. 

• Delete certificates - Delete expired and unwanted certificates.  The procedure is similar to deleting other 
people's certificates. Please see 'Delete other people's certificates' for more details.

• Add Exception - Some of the websites may use a certificate that has not been issued by a trusted CA. If 
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you visit those websites, Comodo Ice Dragon will display a warning:

   

• If you trust the site, click 'Advanced' > 'Add Exception' and proceed with adding this site as an exception.

The 'Add Exceptions' interface allows you to add such trusted websites in advance, to be exempted from the security
check. 

• Click 'Add Exception' in the 'Servers' tab of the 'Certificate Manager' dialog to add a website manually.

• Type the url of the site to be exempted from the security check and click 'Get Certificate'.

The browser fetches the certificate, checks for its legitimacy and displays its status.

• If you trust the site, click 'Confirm Security Exception'. 

The website will be added to the exceptions and transactions through it will be allowed by the website even if the 
certificate is not trusted.  

Authorities

The 'Authorities' tab displays the root certificates of trusted CAs that are pre-embedded in Comodo IceDragon. 
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This interface allows you to:

• View the certificate details - The procedure is similar to viewing your own certificates. Please see View 
the Details of the Certificate for more details

• Configure Trust Settings - Configures the level up to which the other authorities' certificate and its issuer 
can be trusted.

• Select the certificate and click 'Edit Trust' in the 'Authorities' tab

The 'Edit CA certificate trust settings' dialog configures  Trust Settings on the CA that has issued this 
certificate.

• Select the entities that can be authenticated by this CA and click 'OK'.

• Import Certificates from local storage - Import server certificates stored locally in your system or in your 
network into the browser. The procedure is similar to importing your own certificates. Please see 'Import 
your certificate' for more details.

• Export Server Certificates - Export and save server certificate in a safe location for future use, example, 
for importing to other browsers or email clients. The procedure is similar to exporting other people's 
certificates. Please see 'Export other people's certificates' for more details.

• Delete or Distrust certificates - Delete expired and unwanted certificates.  The procedure is similar to 
deleting other people's certificates. Please see 'Delete other people's certificates' for more details.
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Configure Security Modules that store Certificates and Passwords

Comodo IceDragon contains built-in security modules to store your passwords and certificates securely. In addition 
for enhanced security, you can use external security devices like smart cards to store your certificates and 
passwords, and configure IceDragon to fetch your certificates and passwords from them.

Security modules 

A Security Module or a PKCS#11 module is a program  to manage encryption and decryption using the PKCS #11 
standard.  A PKCS #11 module can control a software security devices as well as hardware security devices like a 
smart card or token, in a reader inserted into a slot dedicated for the module

By default, Comodo IceDragon has two internal PKCS#11 security modules.

• NSS Internal PKCS #11 Module that controls two types of security devices: 

• Generic Crypto Services - A special software security device for all cryptographic operations required 
by the Netscape Internal PKCS #11 Module. 

• Software Security Device - A software security device for storing your certificates and passwords that 
cannot be stored on external security devices, including any CA certificates that you have installed in 
addition to default CA certificates that came with the browser. 

• Builtin Roots Module controls a special security device called the Built-in Object Token. 

• Builtin Object Token - A token that stores the default CA certificates that came with the browser. 

Manage Security Modules

• Click the hamburger/ 'Open Menu' button at the top-right

• Select 'Options'  > 'Privacy and Security' > in the 'Certificates' section, click 'Security Devices' button

This dialog enables you to:

• View the details of existing security modules

• Log-in to a security device for using cryptographic services

• Change master passwords for the security devices

• Add security devices

• Enable FIPS Mode

View details of a security module or a device

• Click on the module or the device
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• The details of the module or the device is displayed in the middle pane

Login to a security device

• Select the security device and click 'Log In'

• Enter the Master Password for the security device and click 'OK'

Note: You need to enter the Master Password for the browser to fetch the certificates and passwords. If you haven't
set a Master Password please see the instructions on 'To set or change Password'.

You will be logged-in to the security device so that the browser can access the certificates and the passwords stored 
by the security device.

• To logout of the security device, click 'Log Out'

Set or change master password

• Select the security device and click 'Change Password'
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• Enter your current password in the 'Current password' field. If you are setting the 'Master Password' for the 
fist time, leave this field blank

• Enter your new password, re-enter it for confirmation in the respective fields and click 'OK'.

Add a new security device

If you want to use an external security device like a smart card, you need to first install the module software following
the instructions that came with the security device. You may have to physically connect the device to the port 
specified in the instructions during installation. After installation:

• Click the hamburger/menu button at the top-right

• Select 'Options' > 'Privacy & Security' > scroll to the 'Certificates' then click 'Security Devices' button 

• Click the 'Load' in the 'Device Manager' interface

• Enter a name for the new device in order for the browser to identify it in the 'Module Name' field. 

• Enter the path of the module file you installed with the device in the 'Module filename' field. 
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• Alternatively, click 'Browse' and navigate to the location in your hard drive where you have installed the 

module and click 'Open'

• Click 'OK'.

Your new module will be loaded. You can set a password and login to the device for the browser to access the 
certificates and passwords stored by the new device. 

•  To remove a module, select the module and click 'Unload'.

Enable FIPS Mode

Federal Information Processing Standards Publications (FIPS PUBS) 140-1 is a US government standard for 
implementations of cryptographic modules - hardware or software that encrypts and decrypts data or performs other 
cryptographic operations (such as creating or verifying digital signatures).

All the encryption and decryption processes of Comodo IceDragon can be configured to adhere to FIPS PUBS 140-1
through the Device Manager interface.

• Click the hamburger/menu button at the top-right

• Select 'Options'  > 'Privacy & Security' > in the 'Certificates', select 'Security Devices' 

• Click 'Enable FIPS'

7.13. Force Secure Connections

The 'Force Secure Connections' feature allows you to specify that all future connections to a particular site are made
over a secure HTTPS connection. You can also enforce HTTPS connectivity to sub-domains of the domain. 

When you visit a site over HTTPS, Comodo IceDragon will show a padlock icon on the *right* of the address bar.  

By default, the padlock is gray, meaning secure connections are not yet enforced. No additional actions will be 
performed if the page is loaded again.

• Click the ellipsis on the address bar to select the padlock icon to enforce secure connections:
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• The address bar padlock will turn green, meaning secure connections are enforced for this session and all 
future visits

• All information exchanged between you and this website will be encrypted using the strongest available 
algorithms

• Click 'Force HTTPS on all subdomains' box if you want secure connections throughout the domain then 
'Done'

• If you wish to disable forced secure connections, click 'Don't force HTTPS'. 

Example usage

This feature is particularly useful for websites that do not, by default, use secure connections. For example, 
www.stylight.com. Note: the address is plain HTTP instead of HTTPS - the 'S' stands for secure:

It's possible your credentials may still be posted to HTTPS once you click the 'Sign in' button, but the absence of a 
certificate on this page means you cannot verify the authenticity of the website. Furthermore, loading the sign-in 
page over HTTP also means you cannot verify the page's integrity - it may have been modified by a 3rd party before 
it loaded in your browser.                                                                                             

With a HTTPS connection, you can click the lock on the left of the address bar to view the website's SSL certificate. 
Apart from encrypting the information you submit and ensuring page integrity, the certificate also contains critical 
website identity information which allows you to verify that you are connected to the genuine stylight website.

To force secure connections on the stylight page:

• You first have to physically change www.stylight.com to https://www.stylight.com 

• Do this by placing your mouse cursor in the IceDragon address bar and typing 'https://' before 
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www.stylight.com so the full URL says https://www.stylight.com 

• Enable 'Enforce Secure Connections' padlock in the navigation bar drop-down to enforce secure 
connections

• All future visits to the Stylight will be automatically conducted over a secure, encrypted connection: 
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7.14. Website Security Indicators

• IceDragon security indicators are shown in the website address bar and tell you about the safety of the 
connection between you and the website you are visiting. 

• Transport Layer Security (TLS) and Secure Sockets Layer (SSL) are protocols which encrypt the 
connection between your internet browser and the web site you are visiting.

• All data passed over an SSL/TLS connection is encrypted, so it cannot be deciphered or understood by 
anybody who intercepts the communication. This prevents sensitive data like credit card numbers and 
passwords from being stolen by hackers.

• A website can implement encryption by installing an SSL/TLS certificate on their web server. Websites 
protected with an SSL/TLS certificate will show a lock icon in the browser address bar.

The following table show the different types of icons you will see in the Ice Dragon address bar:

Icon Description

• The connection to the site is insecure. It does not have a TLS/SSL certificate installed.

• The owner of the website has not been verified. 

• Do not submit confidential information or enter your username password to an insecure site.

• The green lock appears when IceDragon establishes a secure connection to a web site. Your 
connection to the site is encrypted.

• The address of the site will begin with 'https://' (e.g. https://example.com)

• If the site uses an Extended Validation SSL (EV SSL) certificate, the organization's name will 
appear next to the icon with green text.

• The page contains some insecure content. Even if a site has a certificate installed, you will see 
this error if the page loads images or other content from an insecure site.

• The page hosts dangerous content or has an invalid certificate.

View the security Site Setting menu and Global Default information

• Click on the icon at the left of the URL in the address bar to view  the identity information from the drop-
down 
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The 'Control Central' pane displays the current connection to the site. 

• Click the right arrow on the Control Center to view the identity information of a certificate, the website's 
owner, and change settings for the site that you are currently visit.

• Content blocking indicates whether or not a page contains elements that track you. See Block Websites 
From Tracking Your Browsing Activities for more detailed information.

• Permissions indicates any permissions you have set to the website. You can remove permission from the 
Control Center.

• You can also manage items available from the 'Permissions' under the 'Privacy & security' section. See
View and Manage Permission Settings for more details.

7.15. Disable Accessibility Indicator

The Ice Dragon accessibility service is designed to improve how websites are rendered for physically impaired 
users. If the service is enabled, it allows 3rd party applications to inspect, monitor, visualize, and alter web page 
content. 

Access the accessibility indicator 

• Click the hamburger/menu button at top-right

• Select 'Options'  > 'Privacy & Security' > 'Permissions'
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• Prevent accessibility services from accessing your browser - Enable this checkbox if you do not wish 
to extend these privileges to accessibility services. You may want to do this if you do not have any 
physically impaired users that use your Ice Dragon installation.

7.16. Configure IceDragon Performance and Browsing 
Settings

• IceDragon lets you tweak certain hardware settings to ensure the fastest browser performance without 
placing undue burden on system resources.

• Hardware acceleration, for example, can improve playback in YouTube and 3D Earth. 

Access the performance settings

• Click the hamburger/menu at the top-right

• Click 'Options' > 'General'  > Scroll to the 'Performance' section

Comodo IceDragon User Guide | © 2020 Comodo Security Solutions Inc. |  All rights reserved                                                                    116



Comodo IceDragon - User Guide

• Use recommended performance settings automatically setups your browser with computer settings.

• Use hardware acceleration when available (requires Dragon restart)' improves the rendering of 3D 
graphics in-browser

• Content process limit - Set the content process limit to between 1 and 8. Default = 4 

• Use auto autoscrolling - If selected, you can click the center mouse button on a web page to enable auto-
scrolling. You can then move the page up or down by simply moving your mouse. Note - make sure to click 
on an 'empty' area of the page. Middle-clicking on a link will open the linked page in a new tab.

• Use smooth scrolling - Makes the page to scroll up or down smoothly when you press the 'Page Up' or 
'Page Down' Keys. This option is useful when reading lengthy pages as it makes it easier to resume from 
where you left off.

• Show a touch keyboard when necessary - Allows Ice Dragon to detect touchscreen devices. An on-
screen keyboard will appear when entering text on a touchscreen device.

Disable touch screen detection

• Type: about:config in the address bar 

• Confirm that you will be careful in the warning message

• Enter ui.osk.detect_physical_keyboard in the text box. It will be set to false

• Always use the cursor keys to navigate within pages - Enables 'Caret browsing' within the webpage - 
displays a blinking text selection cursor that can be moved using the arrow keys in your key board. The 
cursor enables you to select a piece of text from the webpage to your clipboard directly, point to links, move 
from field from field and so on, using the keyboard. 
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• Alternatively, press F7 from your keyboard.

• Click 'Yes'

• Search for text when you start typing - Completes searches quicker by starting your search immediately 
when you start typing. Search results will be shown in real-time under the search box. 

• Recommend Extensions as you browse - If enabled, Ice Dragon will periodically suggest extensions you 
might find useful. For example, if you regularly visit sports websites, Ice Dragon may suggest a dedicated 
extension which collects the latest scores.

7.17. Network Proxy Settings
The 'Network Proxy' area lets you configure how IceDragon should connect to the internet. For example, your 
organization or internet service provider (ISP) may require you to connect to the internet through a proxy server.

You may consider using a proxy for the following reasons to:

• Anonymize your connection to the internet

• Speed up internet access

• Implement access policy on a network (for example, to block undesirable websites)

• Audit internet usage

• Scan traffic for malware prior to it entering or leaving the internal network

Set up a proxy connection 

• Click the hamburger/menu at the top-right

• Click 'Options' > 'General' 

• Scroll to the 'Network Settings' section:

• Click 'Settings'. The 'Connection Settings' dialog will open:
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• No proxy - Select if you don't want to use a proxy. 

• Auto-detect proxy settings for this network - If enabled, IceDragon will automatically detect the 
proxy settings for your network. 

• Use system proxy settings - If selected, you can configure proxy settings for your operating system. 

• Manual proxy configuration - If selected, allows you to set more than one proxy server.  Each proxy 
requires a hostname and a port number. 

• Checkbox 'Use this proxy server for all protocols' for the same proxy name and port number 
used for all protocols

• No Proxy For - List of hostnames or IP addresses that will not be proxied. Use <local> to bypass 
proxying for all hostnames which do not contain periods. 

• Automatic proxy configuration URL - If selected, determines to run proxy server automatically. Enter
the URL and click 'OK' to save changes and load the proxy configuration. 

• Reload: Load the currently available proxy configuration. 

• Check-box 'Do not prompt for authentication if password is saved' to set your proxy credentials to 
enter the proxy's username ans password.

• Check 'Proxy DNS when using SOCKS v5' box to enable remote DNS when use SOCKet Secure v5.

• Click 'OK' for the settings to take effect.
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8.  Downloads
This section explains how to download a file from the internet, change default download location, and view/clear 
download history.

Click the following links to find out more:

• Download a File

• Change Download Location

• View download history

• Clear download history

8.1.Download a File
When you start downloading a file from the internet, Comodo IceDragon displays the progress of the download in the
navigation toolbar (click the downward pointing arrow to view downloads). 

It also scans for viruses to prevent malware downloads. 

The downloads window displays information about each download, including file name, file size, time remaining 
before the download is complete, where the file was downloaded from, and the time or date of the download.

• To view the three most recently downloaded items, click the download button in the navigation toolbar

• To view all downloads, click 'Show All Downloads'. This will open the 'Library' interface and a list of all 
downloaded apps or files
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• To search for a particular download, type its name in the search box at the top of the interface

From here you can:

• Pause: Pauses any downloads currently in progress. Right-click the download and select 'Pause'. To 
continue downloading files, right-click the file then select 'Resume'

• Cancel: Cancels the download. Right-click the file and select 'Cancel' button

• Open the file: Double-clicks on the entry to open the file

• Open the file's folder: Right-click on a download and select 'Open Containing Folder' to view the folder 
that contains the file. See Change Download Location to specify other location.

• Go To Download Page: Right-click on the file and select 'Go to download page' to open the URL the file 
was downloaded from  

• Remove the file's entry: If you do not wish to keep a record of a particular download, right-click on the 
download and select 'Remove From History'. This will not delete the file itself

• Retry: If for any reason a download does not complete, use the 'Retry' curve arrow next to the file entry and
IceDragon will restart the download

•  Clear Downloads: Clears the whole list. This will not delete the downloaded files
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• Copy Download Link: Copies the download URL to clipboard.

Further reading related to the topic of this page:

• Change Download Location 

• View Download History

• Clear Download History

8.2.Change Download Location
By default, Comodo IceDragon saves all downloaded files to C:\Users\<user name>\Downloads. You can change 
this location or change settings so that you are asked for the location every time you start the download.

• Click the hamburger/ menu button at the top-right corner

• Click 'Options' > Select 'General' > 'Files and Applications'

• Under the 'Downloads' section, choose how you want to save files:

• Save files to - IceDragon automatically saves all downloads to the specified folder. If you want to 
download the application in a location other than the default location, click 'Browse'.

•  Always ask me where to save files - IceDragon asks you to select a folder for every download you 
wish to save

Further reading related to the topic of this page:

• Download a File

• View Download History

• Clear Download History

8.3.View Download History
You can view a list of items you have downloaded by clicking hamburger menu > 'Library' > 'Downloads' > 'Show 
download folder'.

View your download history

• Open the 'Library' interface by clicking the 'Download' button then select 'Show All Downloads'

• Click on a file to open it

• Click 'Remove From History' to remove a specific download from the list.

• Click 'Open Containing Folder' to see the location of the file in your computer. Please note that this will 
not work if the file has been moved.

• Click 'Go to Download Page' opens the URL from which the file was downloaded.

• Click 'Copy Download Link' to copy the URL from which the file was downloaded.

• Click 'Clear Downloads' to remove all downloads from the list. This will not delete the files themselves.
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• Enter the name of a download in the search box to find a specific item.

• Use the shortcut keys 'CTRL+J to open the downloads page.

Further reading related to the topic of this page:

• Download a File

• Change Download Location

• Clear Download History

8.4.Clear Download History
Click the following links for more help:

• Remove specific items 

• Clear history automatically 

• Clear history manually 

• Remove a single website 

Remove specific items from download history

• Click the 'Download' button then click 'Show All Downloads'  

• In the 'Library' interface right-click the item and select 'Remove From History' 

Clear history automatically

• Click the hamburger/ menu at the top-right 

• Click 'Options' > 'Privacy & Security' > 'History' section

• Select the 'IceDragon will' drop-down

• Remember history - Keeps a record of the pages you have visited, uses the text you have entered into the
search bar or into form fields, accepts cookies from sites until they expire

• Never remember history - Keeps no record of your browsing history,  will not remember text you enter into
form fields or the search bar, deletes cookies when you close IceDragon

• Use custom settings for history:
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• Always use private browsing mode - CID will not remember any new history the next time it starts.

• Remember my browsing and download history - CID keeps a list of the pages you have visited 
and a list of files you gave downloaded.

• Remember search and form history - The text you enter into form fields or the search bar will be
remembered. For more information, see Form Autofill topic.

• Clear history when IceDragon closes - Saves items that will be deleted when you close 
IceDragon.

• Check the box 'Clear history when IceDragon closes' > 'Settings' button next to it to manage 
what items are deleted

• The 'Settings for Clearing History' dialog will open:

• Select items that have to be automatically cleared each time you quit.

• Click 'OK'.

Clear download history manually 

• Click the hamburger/menu button at the top-right corner 

• Select 'Library' > 'History' > Click the 'Clear Recent History'

OR
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• Click 'Clear History...' next to 'Always use private browsing mode'

• Select the period for which you want to delete the download history from the 'Time range to clear' drop-
down box

• Click 'Details' arrow to select the type of information will get cleared

• Click the 'Clear Now' button to delete history for the selected period and type of information. Note: Any 
downloaded files will remain on your computer. This action just clears out your web data.

Remove a single website from the download history

This option deletes all history items (browsing and download history, cookies, cache, active logins, passwords, saved
form data, exceptions for cookies, images, pop-ups).

• Click the 'Download' > 'Show All Downloads' > click 'History' from the left panel

• Search the website you want to remove from your history by typing its name in the 'Search History' field in 
the top-right corner.

• Right-click on the site you want to remove, scroll down the 'Forget About This Site'
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Further reading related to the topic of this page:

• Download a File

• Change Download Location

• View download history

9. Introduction to Add-ons
Add-ons, extensions and plug-ins help expand the basic feature set of Comodo IceDragon with additional 
capabilities. 

There are thousands of add-ons available, adding a wide variety of functions to IceDragon. For example, you can get
add-ons to:

• Play certain video formats

• Handle more file types

• Translate web pages

• Change the IceDragon theme

• Block adverts

• Access your favorite shopping websites

• Use animated mouse pointers

• Quickly update your Facebook profile 
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• ...and much more

Access the add-ons interface

• Click the hamburger button at the top-right > Select 'Add-ons'

OR

• Click  the 'Extensions & Themes' at bottom-left in the 'Options'

Comodo IceDragon enables you to install three types of Add-ons.

• Extensions - These add new features or modify existing features. Examples include extensions to block 
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advertisements, to download videos from websites, to add features from other browsers and to integrate 
IceDragon with websites like Facebook.

• Themes - Change the look of overall look of the browser including buttons, menus and other browser 
elements. 'Personas' decorate the menu bar and tab strip with a background image.

• Plugins - Add support for different kinds of internet content. This includes patented formats like Flash, 
QuickTime, and Silverlight that are used for video, audio, online games, presentations.

Click the links below for more help:

• Download and Install Add-ons

• Install Add-ons from local storage

• Configure updates for add-ons

9.1.Download, Install and Configure Add-ons

• Click the hamburger button at top-right

• Select 'Add-ons' to open the 'Get Add-ons' screen 

• Click 'Find more add-ons' at the bottom of the page to visit the Mozilla add-ons page.

• You can search for a particular add-on or browse through the add-on categories. 

• Each add-on comes with a brief description and you can also read reviews and comments from fellow 
users. 
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• Once you have chosen your add-on, click 'Add to Firefox' then click 'Add' at the prompt. All Firefox 

extensions are compatible with IceDragon.

• The add-on will be downloaded and a notification of the successful installation will be displayed.

• Some add-ons may require your browser to be restarted for the installation to take effect. If it prompts you, 
click 'Restart Now'. 

9.1.1. Install Add-ons from Local Storage

If you have a local copy of an add-on installer, you can install it as follows:

• Click the hamburger button and select 'Add-ons'

• Click 'Extensions' on the left then click the gear icon on the right

• Select 'Install Add-on From File' from the options.

• Navigate to the location of the .xpi file you want to install

• Click 'Open'

• The add-on will be installed. If required, restart the browser to enable the add-on.  

9.1.2. Configure Updates to Add-ons

Ice Dragon can automatically check for and install updates for add-ons.

Configure updates

• Click the hamburger button at the top-right > select 'Add-ons'.

The' Add-Ons Manager' page will open in a new tab:

• Click the gear icon on the upper-right of the screen

• Click 'Check for Updates' to manually update your add-ons

• Click 'View Recent Updates' to see your most recently updated add-ons

• Enable 'Update Add-ons Automatically'.
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9.2.Manage Extensions

View installed extensions

• Click the hamburger button at top-right

• Select 'Add-ons'

• Click 'Extensions' on the left to view a list of all installed extensions.
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Most extensions allow you to configure and customize them as per your requirements.

• Click 'Options' to configure an extension, then edit preferences in the resulting dialog

• Click the 'Disable' button to turn an extension off

• Click the 'Remove' button to uninstall an extension.

9.3.Customize the Appearance of IceDragon

Why not get creative? Personas and themes let you change the entire look and feel of Comodo IceDragon. 

Available through the add-on manager interface, there are two main ways to customize IceDragon's appearance: 

• 'Personas' - Lightweight themes that let you customize the menu bar and tabs with background images 

• 'Themes' - Customize the whole browser window

Click the links below for more help:

• Download and install Personas and Themes

• Manage Personas and Themes

Download and install Personas and Themes

• Click the hamburger button at top-right

• Select 'Add-ons'.

• Click 'Find more add-ons' at the bottom to view the Firefox add-ons website.

• Click 'Themes' to view recently added and popular themes. 

• Use the 'Categories' to narrow your search

• Select the theme > click '+ Install Theme' to add it to IceDragon

• Click 'See more featured themes' to browse available themes

• Once you find a theme that you like, click on it to go to its download page.

Manage Personas and Themes

You can easily choose which persona or theme you want by clicking the 'Themes' link in Get Add-ons tab.

• Click '+Install Theme' to use a Theme or Persona, Personas will be applied immediately.

• The theme pug-in will be added to the menu and you need to click 'OK!'

• To restore the browser to default Theme, click 'Disable' in the row of currently applied Persona or Theme.

• To remove a persona or theme permanently, click 'Remove' on its row. 
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9.4.Manage Plugins

• Plug-ins are a type of add-on that allow IceDragon to handle content that it does not natively support. 

• Examples include patented formats for documents, video, audio, online games, presentations and so 
on. 

• Plugins to handle these formats are usually supplied by third-parties.

Popular plug-ins include:

• Adobe Flash

• Windows Media Player

• Java

• Quicktime

• Adobe Reader

• Silverlight

• Adobe Shockwave    

View installed plug-ins

• Click the hamburger button at top-right

• Select 'Add-ons'

• Click 'Plugins' on the left-hand side.

• Click the 'Learn More' to find out more about a plugin. 

• Select 'Never Activate' from the drop-down beside the plugin to stop the plugin from running.
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10. Tools and Other Features
• Comodo IceDragon has a number of built-in tools for specialist tasks. For example, the web page scanning 

tool, spell checker and so on. 

• You can also add as many tools as you like to the browser. See Install Add-ons for more details. 

Click the following links for more help features:

• Customize applications for opening different file types

• Search within page content 

• Form autofill 

• Keyboard and mouse shortcuts for Comodo IceDragon 

• Manage IceDragon in safe mode

• Set up IceDragon sync information

• View Digital Rights Management 

• Improve IceDragon Performance Settings 

• Comodo Online Security Extension

• View Task Manager

10.1. Customize Applications for Opening Different File 
Types

• Comodo IceDragon ships with several plug-ins to handle the different types files you may encounter online. 

• File types include audio files, video files, play lists, presentations and so on.

• You can add additional plug-ins from third-parties and configure which app should be used to handle a 
particular type of content.

Customize applications

• Click the hamburger button at the top-right corner.

• Click 'General' > scroll down to 'Files and Applications' 

• Select 'Applications' to view a list of internet content types and their associated plug-in or application:
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• Locate the content type you wish to modify in the 'Content Type' column.

• Click the drop-down in the 'Action' column to review or change the application IceDragon should use to 
open the content. Plug-ins have the blue building block icon next to them:

• Always Ask - Select if you want to choose the application each type you download the file type.
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• Save File -  Automatically save files of that content type.

• Application Details - View more information about the application prior to making a decision.

• Use Other - Specify a different application to open files of that content type. This will open a list of 
installed applications for you to choose from: 

• Select the application from the 'Select Helper Application' dialog and click 'OK'. 

• Click the 'Browse...' button to locate you application if it is not listed in the dialog.

Remove a custom application from the list in the drop-down

• Click the 'Action' drop-down and select 'Application Details':

• This will open a list of applications that are capable of opening the content type. Select the application 
you no longer wish to use and click 'Remove'. 
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• Click 'OK'.

10.2. Search within Page Content

The 'Find' features lets you search for a specific word or phrase in the web-page you are viewing. You can also 
configure the browser to launch an auto-search when you start typing a keyword or phrase.

Click the following links for more help with:

• Search using the 'Find' feature

• Launch auto-search

Search using the 'Find' feature

• Click the hamburger button at the top-right corner

• Click 'Find' or press Ctrl+F on your keyboard

• Type your keyword/phrase in the search field at the bottom-left of the window

The first occurrence of the keyword in the page will be shown highlighted in green. 
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• To search for successive occurrences, click 'Next'

• To highlight all occurrences, click 'Highlight all'

• Select 'Match case' to search for instances of the keyword that use the same case (upper and lower case) 
as the characters you enter. 

Launch Auto-search

To start an auto-search for the browser when you start typing a keyword, you need to configure the security settings 
accordingly.

• Click the hamburger button at the top-right corner

• Click 'Options' > select 'General' tab

• Check the 'Search for text when you start typing' box under the 'Browsing'.

10.3. Form Autofill

Comodo IceDragon can save the information you enter into order forms and login screens. When you visit the same 
form in future, just click on a blank field to see all the entries you made previously.

The following links explain more about form auto-fill:

• Delete all stored form entries

• Delete individual entries

• Configure form history 

Delete all stored form entries

• Click the hamburger button at top-right
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• Select 'Library' > 'History'

OR

• Select 'Options' > 'Privacy & Security' > 'Browser Privacy'

• Click 'Clear History' in the 'History' section

• Click the 'Details' arrow to select the type of information to clear

• Make sure 'Form & Search History' is selected

• Time range to clear - Select how far back in time you want to delete

• Click 'Clear Now'

Delete individual entries

You can remove auto-fill from specific pages or fields while keeping it active on others. This can be useful on shared 
computers.

• Visit the web-page from which you want to remove saved form entries

• Click on a field that has auto-fill suggestions. All previous entries will be displayed in a drop-down

• Use the up and down arrows on your keyboard to highlight the entry you want to remove and press 'Delete'

• Repeat the process if you need to delete multiple entries.

Configure the browser for form entries 

You can configure IceDragon to whether or not to remember the form entries as per your choice
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• Click the hamburger button at the top-right 

• Select 'Options' > 'Select 'Privacy & Security' > 'History'

• In the 'IceDragon will' drop-down, select 'Use custom settings for history'

• Select or deselect 'Remember search and form history' as required

10.4. Keyboard and Mouse Shortcuts 

You can access and execute many IceDragon features and commands through keyboard and mouse shortcuts. 

Click the links below to jump to the section you would like to learn more about:

• Mouse Shortcuts

• Keyboard Shortcuts

• Navigate Through Webpages

• View, Print and Save Current Page

• Edit Options

• Search Options 

• Windows and Tabs

• View History

• Bookmark Options

• Tools

• Miscellaneous

• Audio/Video Shortcuts

• PDF Viewer Shortcuts

Mouse Shortcuts

Command Shortcut

Back Shift+Scroll Down

Forward Shift+Scroll up

Zoom In Ctrl+Scroll up

Zoom Out Ctrl+Scroll down

Close Tab Middle-click on Tab

Open link in new Tab Middle-click on Link

New Tab Double-Click on Tab Bar

Open in Background tab* Ctrl+Left-click link

Middle-click link

Open in Foreground tab* Ctrl+Shift+Left-click

Shift+Middle-click

Open in New Window Shift+Left-click link
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Copy Tab or Bookmark Ctrl+Drag tab

Reload (override cache) Shift+Reload button

 Save Page As Alt+Left-click

 Scroll line by line Alt+Scroll 

* 'These shortcuts will work only if  'When I open a link in a new tab, switch to it immediately' is enabled in 'Options' >
'General' > 'Tabs'.

Keyboard Shortcuts

Click the links below to jump to the section you would like to learn more about:

• Navigate Through Webpages

• View , Print and Save Current Page

• Edit Options

• Search Options 

• Windows and Tabs

• View History

• Bookmark Options

• Tools

• Miscellaneous

• Audio/Video Shortcuts

• PDF Viewer Shortcuts

Navigate Through Webpages

Command Shortcut

Back Alt + left arrow

Backspace

Forward Alt + right arrow

Shift + Backspace

Home  Alt  + Home

Open file Ctrl + O

Reload F5

Ctrl + R

Reload (Override cache) Ctrl + F5

Ctrl + Shift + R

Stop loading Esc

View, Print and Save Current Page
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Command Shortcut

Go to Bottom of Page End

Go to Top of Page Home

Move to Next Frame F6

Move to Previous Frame Shift + F6

Print Ctrl + P

Save Page As Ctrl + S

Find Ctrl + F

Zoom In Ctrl + +

Zoom Out Ctrl + -

Zoom Reset Ctrl + 0

Edit Options

Command Shortcut

Copy Ctrl + C

Cut Ctrl + X

Delete Del

Paste Ctrl + V

Paste (as plain text) Ctrl + Shift + V 

Redo Ctrl + Y

Select All Ctrl + A

Undo Ctrl + Z

Search Options

Command Shortcut

Find within page Ctrl + F

Find Again F3

Ctrl + G

Find Previous Shift + F3

Ctrl + Shift + G

Quick Find within link-text only '

Quick Find /

Close the Find or Quick Find bar Esc  (When Find and Quick Find bar is active)

Comodo IceDragon User Guide | © 2020 Comodo Security Solutions Inc. |  All rights reserved                                                                    141



Comodo IceDragon - User Guide
Search bar - Easily choose your favorite search engine Ctrl + K

Select or Manage Search Engines Alt + Up arrow

Alt + Down arrow

F4 

(When Search bar is active)

Windows and Tabs

Command Shortcut

Close Tab Ctrl + W

Ctrl + F4

These shortcuts will not work for Extensions and Add-
Ons tabs

Close Window Ctrl + Shift + W

Alt + F4

Move Foreground Tab to Left Ctrl + Left arrow

Ctrl + Up arrow

Move Foreground Tab to Right Ctrl + Right arrow

Ctrl + Down arrow

Move Foreground Tab to first position Ctrl + Home

Move Foreground Tab to last position Ctrl + End

Mute/Unmute Audio Ctrl + M 

New Tab Ctrl + T

New Window Ctrl + N

Next Tab Ctrl + Tab

Ctrl + Page Down

Open Address in New Tab Alt + Enter

Previous Tab Ctrl + Shift + Tab

Ctrl + Page Up

Undo Close Tab Ctrl + Shift + T

Undo Close Window Ctrl + Shift + N

Select Tab 1 to 8 Ctrl + 1 to 8

Select Last Tab Ctrl + 9

Tab Groups View Ctrl + Shift + E

Close Tab Groups View Esc

Next Tab Group Ctrl + `
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Previous Tab Group Ctrl + Shift + `

View History

Command Shortcut

History sidebar Ctrl + H

Library window (History) Ctrl + Shift + H

Clear browsing, search and download history Ctrl + Shift + Del 

Bookmark Options

Command Shortcut

Bookmark All Tabs Ctrl + Shift + D

Bookmark This Page Ctrl + D

Bookmarks sidebar Ctrl + B

Ctrl + I

Library window (Bookmarks) Ctrl + Shift + B

Tools

Command Shortcut

Downloads Ctrl + J

Add-ons Ctrl + Shift + A

Toggle Developer Tools F12

Web Console Ctrl + Shift + K

Inspector Ctrl + Shift + I

Debugger Ctrl + Shift + S 

Profiler Shift + F5 

Scratchpad Shift + F4

Style Editor Shift + F7

Network Ctrl + Shift + Q 

Developer Toolbar Shift + F2 

Responsive Design View Ctrl + Shift + M 

Page Source Ctrl + U

Error Console Ctrl + Shift + J
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Toggle Private Browsing - Browse the web without 
storing history, form entries and so on 

Ctrl + Shift + P

Remove recent browsing, search and download history Ctrl + Shift + Del

Miscellaneous

Command Shortcut

Complete .com Address Ctrl + Enter

Complete .net Address Shift + Enter

Complete .org Address Ctrl + Shift + Enter

Delete Selected Autocomplete Entry Del

Toggle Full Screen F11

Toggle Menu Bar activation (when hidden) Alt 

F10

Toggle Reader Mode Ctrl +Alt + R

Show/Hide Add-on Bar Ctrl + /

Caret Browsing F7

Select Location Bar Alt + D

Ctrl + L

Audio and Video Shortcuts

Command Shortcut

Toggle Play / Pause Space bar

Decrease volume Down Arrow

Increase volume Up Arrow

Mute audio Ctrl + Down Arrow

Unmute audio Ctrl + Up Arrow

Seek back 15 seconds Left Arrow

Seek back 10 % Ctrl + Left Arrow

Seek forward 15 seconds Right Arrow

Seek forward 10 % Ctrl + Right Arrow

Seek to the beginning Home

Seek to the end End
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PDF Viewer Shortcuts

Command Shortcut

Next page  N 

J

Right  Arrow  

Previous page P 

K 

Left Arrow 

Zoom in Ctrl + +

Zoom out Ctrl + - 

Automatic Zoom Ctrl + 0 

Rotate the document clockwise R 

Rotate counterclockwise Shift + R 

Switch to Presentation Mode Ctrl + Alt + P 

Toggle Hand Tool H

Activate the Page Number input box Ctrl + Alt + G 

10.5. Manage IceDragon in Safe Mode

Safe mode lets you troubleshoot issues with all add-ons disabled. This is useful if you are experiencing issues with 
IceDragon. You can enable add-ons one at a time until the problem add-on is found.

• Click the hamburger button at the top-right corner 

• Select 'Help' on the bottom of the menu

• Select 'Restart with Add-ons Disabled':
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• Click 'Restart' in the confirmation dialog.

• Click 'Start in Safe Mode' to temporarily disable all add-ons, extensions, themes, language packs and 
services.
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• Re-enable your add-ons:

• Click the hamburger menu > 'Add-ons'

OR

• Click the hamburger menu > 'Help' > 'Restart with Add-ons Enabled'.

10.6. Set up Comodo IceDragon Sync Information

• Synchronizing IceDragon with your Firefox account means you can use your Ice Dragon settings on any 
computer you use.

• Synchronizing will copy your bookmarks, browsing history, preferences, passwords, form data, add-ons and
the last twenty five websites you visited.

Set up synchronization 

• Click the hamburger button at top-right

• Click 'Sign in to Sync'

OR

• Select 'Options' then 'Firefox Account'

• Click 'Don't have an account? Get Started' if you do not already have an account.
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• Enter your email and password in the text box and click 'Sign in'.

• Click the 'Verify Your Account' message to confirm your sign-in.

• You will receive a confirmation mail to your account email address. Click the link in the mail to verify 
your sign-in. 

• Click 'Confirm sign-in'. The IceDragon will start sync immediately.

• After successfully logging in, the sync settings page will show all items currently synced with your 
account. 

• Please review these settings and deselect items that you do not wish to sync.
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Manage IceDragon Sync information

• Click the hamburger button at the top-right > 'Sign in to Sync'. 

OR

• Click 'Options' > 'Firefox Account'.

• Click 'Sign in...'

• The general interface lets you enable or disable synchronization

• Click 'Disconnect' in the Firefox account page. Note: your Google account will retain data that has already 
been uploaded BUT will not update with any further changes you make.

• You can also select whether to remove sync data or private data from the 'Disconnect Sync' dialog or both.
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• Click the 'Manage Account' link to change your account appearance and password and preferences.
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• Select items you want to sync across all devices

The 'Device Name' area lets you view and change the name of the device you synced. 

• Click 'Change Device Name' to rename a device, then click 'Save'

Enable Two-Step Authentication

• Enable the 'Two Step Authentication' by entering scanning the qr code and entering the security code 
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generated on your phone in the respective code field.

• Click 'Confirm'

Device & Apps 

This option displays the devices that are having the IceDragon application installed. If you have not installed
you can download the application from this option.

• Click Download against the device type on which you want to install IceDragon

• Click Disconnect if you have your IceDragon account signed in any of your devices and before that 
select the reason disconnecting

• Click 'Refresh' to see if there is any change status of the devices signed in

• Click 'Done' to save changes

Communication Preferences 

This option allows you to receive communication on policy changes, accounts functionality, promotional 
emails and so on.

• Click 'Change'  and then 'Subscribe' to subscribe for communications

Сhange a password 

• Click the hamburger button at the top-right

• Click 'Options'> 'Firefox Account'

• Click the 'Manage Account' link 

• Click the 'Change' link beside the 'Password'.

• Type your an old password, then re-type it again and click 'Change'.

Delete an account

• Click the hamburger button at the top-right.

• Click 'Options'> 'Firefox Account'

• Click the 'Manage Account' and select 'Delete account' button.

• Click the 'Email preferences' link to go to the 'Manage your Email Preferences' center. It helps you set 
communication between you and subscribers

• Click 'Save Preferences'

Reset IceDragon sync every time I close IceDragon

• Click the hamburger button at the top-right 

• Click 'Options' then the 'Privacy and Security' tab.

• In the 'History' > IceDragon will:' select 'Use custom settings for history'

• Uncheck 'Clear history when IceDragon closes'

10.7. View Digital Rights Management  

Digital rights management (DRM) allows online video and audio services to protect the content they provide from 
piracy. 

IceDragon implements HTML5 playback of DRM content by first decrypting it with a 'Content Decryption Module' 
(CDM). IceDragon currently supports Adobe Primetime and Google Widevine CDM systems.

If you opt-out of DRM playback, then all downloaded CDMs will be deleted so you will not be able to play DRM 
content in future.

Disable DRM playback

• Click the hamburger button at the top-right

• Click 'Options' > 'General' 
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• Go to the 'Digital Rights Management (DRM) Content'

• Deselect the 'Play DRM-controlled content' checkbox

• If sites requires this type of DRM to operate properly, turn DRM playback on again.

10.8. Comodo Online Security Extension

Comodo Online Security (COS) is a website filtering extension that protects you from harmful websites, hackers, 
malware and more.

• Click the app icon at the top-right of the interface: 

Click the COS icon to reveal the follow options:

• Online Security Pro - Enable or disable the COS web-filter. (Default = Enabled) 
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• Home icon - Open the COS settings page:

• Report this page - Submit the URL of the site you currently visiting to Comodo for analysis.

• You should do this if you think it might be hosting malware, or might be a fake/phishing website. 
Comodo will test the site and add it to our black list if we confirm it as malicious.

• Click anywhere on the stripe to open the reporting page at 
https://www.comodo.com/home/internet-security/submit.php   

• The URL is pre-populated, so you just need to enter your email address and any comments you 
feel would be helpful (optional).

• Edit Exclusion List - COS generates an alert whenever it detects a harmful website. If you choose 
'Continue Anyway' at the alert then the site is added to the exclusions list. This means COS  will not 
flag it as malicious on future visits. Click anywhere on the stripe to view/modify web sites on the 
exclusion list.

• Check History - View a log of sites caught by COS, and the action taken by you.

• Rate This Extension - Estimate the COS extension. 

• Notifications - Shows news about COS and allows you to rate the product 

• About - Links to product pages, release notes and more.

See help for learning more about Comodo Online Security.

10.9. View Task Manager

The task manager lets you see how much memory is used by each IceDragon extension or tab.

• Click the hamburger button at top-right

• Click 'More' > 'Task Manager'  

Each tab or extension is shown on a different row: 

Comodo IceDragon User Guide | © 2020 Comodo Security Solutions Inc. |  All rights reserved                                                                    154

http://help.comodo.com/topic-450-1-930-12683-Introduction-to-Comodo-Online-Security.html
https://www.comodo.com/home/internet-security/submit.php


Comodo IceDragon - User Guide

Name - Displays extensions, tabs are currently running in the browser.

Type - Show whether or not items running are Tab or an Add-on.

Energy impact - How much drain the item places on your power source/battery. This is most relevant for mobile 
devices and laptops running on battery. You can close energy intensive items to conserve battery life.

Memory - How much RAM is taken up by the process. Closing memory intensive items can improve the 
performance of your device.

• Place your mouse over an item to view more details.

• Click the cross mark beside a tab row to close it.
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• Click the arrow mark beside an add-on row to open the extensions page in a new tab. You can disable or 

remove the extension from the extensions page.

Tip – You can also open the task manager by entering 'about:performance' in the address bar.

11. Web Developer Tools
Comodo IceDragon has a number of built-in tools that allow developers to inspect and test website

code. You can use the tools to debug code, run java scripts, view and change styles, find java script related

errors and much more. 

Click the links below for more help to use developer tools:
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• Open the Tools console 

• Inspect Page Elements

• Use the Web Console

• Remove Inconsistencies with HTML, CSS and Javascript

• View and Run Experimental Style Sheets on a Webpage

• Improve Web Page/Web Application Performance

• Memory Tool

• Network Monitoring 

• Storage 

• Accessories 

• Use the Developer Toolbar

• Use the WebIDE

• Browser Console

• Responsive Design View

• Eyedropper

• Run Experimental Java Scripts on Page

• View Page Source

• Add More Web Development Tools

• Service Worker

• Connect Remote Device

• Add More Web Development Tools

• Work Offline

11.1. Open the Tools Console 

Access the console interface

• Click the hamburger at the top-right 

• Select 'Web Developer' > 'Toggle Tools'

• Developer Tool - Options - Click the 'cog' icon on the right to set overall preferences:
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• Default Developer Tools - Enable or disable tools using the check-boxes.

• Available Toolbox Buttons - Choose which tools are displayed on the toolbar.

• Theme - Switch between light and dark themes.

• Inspector 

• Show browser styles - Determines whether or not the style applied by the browser will be 
displayed in the Inspector's Rules view

• Default color unit: drop down - Select the colors will be presented in the inspector. Available: 

• Hex 

• HSL(A) 

• RGB(A) 

• Color Names

• Web Console - Enable timestamps - If enabled, the console clears the output when you navigate to a 
new page.

• Style Editor - View and manage original sources and auto-complete CSS

• Screenshot Behavior - Define how Ice Dragon should handle screenshots.

• Editor Preferences - Defines which items will be used in developer tools 

• Detect indentation: Auto-indent new lines based on the current indentation 

• Autoclose brackets 

• Indent using spaces 

• Tab size = 2 (By Default)

• Keybindings: drop down - Select CodeMirror keybindings or keybindings: 

• Vim 

• Emacs 

• Sublime Text 

• Advanced settings

• Enable Source Maps - Maps your browser inspector's line numbers to the original source.

• Show Gecko platform data - Display Gecko platform symbols

• Disable HTTP Cache (when toolbox is open) - Allows you to disable session caching

• Disable JavaScript - Loads the current tab with JavaScript disabled

• Enable Service Workers over HTTP (when toolbox is open) - Allows you to service worker 
registrations from insecure web sites 

• Enable browser chrome and add-on debugging - Allows you to use developer tools in the 
context of the browser itself

• Enable remote debugging - Allows you to debug code running remotely in a different process or 
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on a different device

• Restart your browser for the settings to take effect.

• Inspector - Analyze the layout of a web page and find/fix web page issues. It allows developers to see 
which elements in the source files (including server-side code) have produced the HTML markup to be 
rendered in the browser. Page Inspector also lets you modify CSS properties and DOM element attributes 
to see the changes reflected immediately in the browser.  

• Web Console - Logged information and other error messages. Allows developers to upload/download files 
to/from server, edit text files directly on a server and much more. 

• Debugger - Finds errors in other programs. A debugger allows a web developers to stop a program at any 
point and examine and change the values of variables.

• Style Editor -  Allows developers to edit a style sheet to apply a style of your own choice to required 
elements.

• Performance -  Allows developers to find and eliminate bottlenecks in your JavaScript code. 

• Memory - Take a snapshot of the current page memory. 

• Network - List all network requests made while loading the page. 

• Other tools on the web developer toolbar are available:

• 'Select an iframe as the currently targeted document'. You can enable/disable it from the developer 
settings by clicking the cog icon at far top right. Lists all nested frames in the file and in the main 
document.

• Toggle split console - Displays an extra console underneath the web developer tools interface.

• Responsive Design Mode - Makes it easy to see how your designs will look on different sized screens
such as mobile phones or tablets. Use the resize handle at the lower right of the content area to 
change the size of the content area. 

• Storage - The storage inspector lets you inspect various types of storage that a web page can use. 

• Accessibility - Assess what information is open to assistive technologies on the current page.

• Dock to side of browser window / Dock to bottom of browser window -  Move and pin the panel to the 
side or top of the browser as per your preference.

• Show in separate window - Opens a separate web developer tools. 

• Click on the 'X' at the far right to close the tool bar. 

11.2. Inspect Page Elements
The 'Inspector' tool lets web developers analyze the layout and structure of a web page. 

To inspect a page

• Open the web-page you want to assess

• Click the hamburger button at top-right 

• Select 'Web Developer' > 'Inspector'

OR 

• Right-click on the page and select 'Inspect Element' from the context sensitive menu. You can right-click on 
specific items on the page to open the inspector at the relevant place.
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• Move your mouse cursor over page content to view information about it in the inspector.

• Click on a page element if you want to work on it.

The 'Inspector' consists of two parts: HTML pane and CSS pane.

All parent elements are on the the left and child elements on the right. 

• The left side pane is HTML pane - The top-level element in the hierarchy of all nested elements, is at the 
left of the toolbar. 

• Allows you to view the HTML code of the selected element.

• Use the arrow keys in the left and right to navigate to the elements in the tool bar.

• The right side pane is for CSS and divided into 5 elements: 

• Rules - Show all the rules that apply to the selected elements. The most recently applied styles are 
listed first. Styles are grouped by source. The 'inline' group lists styles applied using the HTML style 
attribute.  

• Layout - Apply a grid overlay while inspecting the element.

• Flex Container – You can analyze the CSS Flexbox layout using IceDragon developer tools, find 
Flexbox containers on a page and modify them if required. 
• Use the switch to toggle the overlay between on and off. 

• Click the word 'flex' in the HTML pane to view the overlay when the mouse is away from the 
container 

• 'CSS pane' > 'Rules' – A small Flexbox icon next to the word 'flex' is available in any instance 
of 'display:flex'. Details of flexbox's child elements are shown when you click the icon. 

• Grid – Shows the number of columns into which the page is divided.
• Box Model - Shows the total space taken by the element on the page. It provides information 

about the layout of the currently selected element. The outside numbers show the amount padding
on each side of the element. 

• Computed - CSS for the specific element. 

• Animations - Animations to specific element.

• Fonts - Displays all the fonts in use by the selected element. 
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11.3. Use the Web Console

• The web console is a very useful tool for web developers which displays logged information and other error 
messages. 

• It also allows developers to check Javascript and acts as a debugging tool for web applications or web 
sites.

To access Web Console

• Click the hamburger at the top-right 

• Select 'Web Developer' > 'Web Console'.

• Use the 'Position' drop-down menu beside the box to place the Web Console above or below.

• Use the 'Filter output' box to search for particular item(s) in the list.

The Web Console displays messages about Network requests, CSS, JavaScript, Logs.

• Errors / Warnings - View all errors related to the current page. This includes HTML/CSS, javascript  and 
other warnings and messages. This is useful for web developers to check the pages that they have 
developed.

• Logs - These are outputs of JavaScript code executed on the console object in IceDragon.

• Network Request - Displays messages about network requests generated by your web browser. Click on 
network request log to view full its details such as request headers and response headers.

• CSS Messages - IceDragon generates these messages for CSS errors that occurred while loading a web 
page.

• JavaScript Messages - IceDragon generates these messages for JavaScript errors that occurred while 
rendering a JavaScript code. 

• Security Messages - IceDragon generates these messages for security warnings and errors that occurred 
during runtime.  

• XHR (xmlHttpRequest) - Shows data which has been transferred via HTTP. Uses for XML and Json. 

Messages that are generated multiple times are listed only once with an indication in the right displaying how many 
times the message was output in the Web Console.

You can choose what information should be displayed in the log area by selecting the respective item, that is, 
Network, CSS, JS, Security and Logging. You can further filter them from the drop-down menu to display messages 
about errors, warnings, info and log.

Below the log information area, a command line box allows you to execute JavaScript in real-time.

11.4. Remove Inconsistencies with HTML, CSS and 
Javascript

The debugger feature lets you analyze a web page's code line by line.
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To open debugger element tool

• Click the hamburger button at the top-right 

• Select 'Web Developer' then 'Debugger'

The debugger toolbar consists of:

• Pause/Resume - Halts or re-starts execution of the script you're debugging. 

• Step Over  - Steps across the current line of JavaScript code. 

• Step Into  - Steps into the function call on the current line of JavaScript code. 

• Step Out  - Runs the script until the current function exits. 

• Script Chooser  - This pop-up menu lets you select one of the running scripts in order to read its code, set 
breakpoints, and so forth. 

• Script Filter - The script filter (which doubles as a search box) lets you type a string to filter what scripts 
should appear in the Script Chooser. 

• Expand Panes - Expands or contracts the window to show or hide the sidebar panels. 

• Debugger Options - Pops-up a menu to configure the debugger. 

• Auto Prettify Minified Sources - If enabled, the debugger will automatically detect minified JS files 
and pretty-print them. 

• Pause on Exceptions - If enabled, execution of script will automatically pause whenever a JavaScript 
exception is thrown. 

• Ignore Caught Exceptions - If enabled, the debugger will automatically pause the execution of the 
script whenever a JavaScript exception is thrown. 

• Show Panes on Startup - If enabled, the debugger's two sidebar panes are visible when you first start
the debugger; by default, they are not. 

• Show Only Enumerable Properties - If enabled, allows you to filter the displayed list of variables after
the "Filter variables" search box to will be added the variables panel.

• Show Variables Filter Box - If enabled, do not display non-enumerable JavaScript properties 

• Show Original Sources  -  If enabled, allows you to use source maps to see the original source for 
code.

• Automatically Back Box Minified Sources -  If enabled, URLs with 'min.js' at the end will 
automatically be black boxed.

11.5. View and Run Style Sheets on a Web-page
• The style editor lets web-devs preview different page designs 'in-browser' before final deployment. 

• The editor also lets web-devs view a list of cascading style sheets (css) used in the current web-page. You 
can also save style sheets and import CSS to a page.

Click the links below for more help:

• View and edit style sheets in a webpage
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• Apply your style sheet to a webpage

To view style sheets used in the current web-page

• Click the hamburger/ 'Open Menu' at the top-right 

• Select 'Web Developer' > 'Style Editor'

The list of external and inline style sheets used for the webpage will be displayed in the left hand side pane and the 
rules defined in the style sheet selected from the LHS pane will be displayed on the right.

• To view the elements and styles defined for the elements in a style sheet, click on the style sheet listed in 
the left hand side navigation pane.

• To switch and preview the page with and without the application of a selected style sheet, click on the 'eye' 
icon beside the style sheet name in the LHS pane.

• To edit and experiment with styles, find the style rule applied to the desired element from the right hand side
pane and change the parameters as you wish. The changes will be immediately reflected in the webpage 
viewed. But these changes are temporary and will be lost when the page is reloaded.       

Tip: To identify the rule applied to a desired element, right-click on the element and select 'Inspect element' from 
the context sensitive menu. The lower pane in the window will display the 'div id' of the element. Search for the 'div 
id' in the style editor window by pressing Ctrl+F from the keyboard and entering the div id in the 'Find...' dialog 

To save a style sheet

• Select the style sheet from the LHS pane and click 'Save' link beside it

• Navigate to the location in your computer and enter a file name with .css extension in the 'Save as' dialog.

 
Apply a style sheet to a web-page

You can create your own style sheet for element(s) in a page and apply to them and have a preview. This is useful 
for web-developers to experiment of different style sheets for different elements before deciding the final style.

To apply an external style sheet

• Click 'Import', navigate to the location in your system where you have saved the .css file and click 'Open'

The style sheet will be imported and the style rules will be applied to the elements defined in the sheet immediately 
for a preview. 

11.6. Improve Web Page/Web Application Performance
• The performance tool lets developers optimize their code by testing the performance of a page within a set 

timeline. 

• On executing the code, the performance samples the state of the JS engine and records the code stacks at 
various time points. 
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• The tool then calculates the time spent by the browser to execute each stack and displays a statistical 

report. The report allows web devs to analyze and identify bottlenecks in the code.  

To run the Performance

• Click the hamburger at the top-right 

• Select 'Web Developer' > 'Performance'

• Execute your code in IceDragon and click 'Start Recording Performance' to commence the sample.

• Leave the profile to record the samples for required time period and click the 'Stop' button to stop the 
recording.

The 'Performance' will compile the results and display the report.

Understand the Report

The recording left hand pane of the report displays a list of captured profiles which can be loaded at any time. The 
right hand pane displays the currently loaded profile.
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• Click the 'clock' icon at the top-left of interface and repeat recording the samples and generate several 

profile reports.

• Click the 'Import' and navigate the folder to upload the profiles

• Click 'Clear' to remove all profiles.

• 'Invert Call Tree' checkbox - If checkboxed, the profiler report will,

• make a list of all stack frames with a Self Cost greater than zero: that is, stack frames which were 
actually execute when the sample was taken 

• order the list by the number of samples taken while in that stack frame 

• for each entry in the list, show the call stack backwards to the top-level function. 

The profile contains four main sections provides:

• breadcrumb trail

• frame rate timeline

• timeline for platform code execution

• detailed output of the JavaScript sampling profiler

Breadcrumb trail

The upper half of the loaded profile displays a time verses call stack size bar-graph of the profile. The call stack 
represents the amount of active functions at the time when the sample was taken.

You can analyze the response for the stacks for a specific time range too. Selecting a portion of the graph, by 
dragging the mouse cursor displays a new tab above the graph indicating the selected portion. Clicking the new tab 
opens the enlarged view of the selected portion.

To click and drag in the frame rate timeline or the sampling profiler timeline, will

• highlight the section of the timeline

• show samples that were recorded in that section 
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• appear "+" in the toolbar at the top. Click the '+' to view the highlighted expanded section. You will see a 

separate breadcrumb nail the toolbar at the top.   

You can switch between the complete profile and the section using the breadcrumbs, zoom in on a subsection within 
the section.  

Frame rate timeline

This item allows you to view the browser's responsiveness within the period covered by the profile. The x-axis is time
over the profile period and contains three annotations: the target frame rate (always 60 frames per second), the 
average frame rate, and the lowest frame rate. 

Timeline for platform code execution 

Category Description

Network Sending and processing network requests and responses. 

JIT JavaScript code compilation.

GC Garbage collection. 

Inputs & events Events such as mouse or DOM events. 

Styles Parsing CSS. 

Graphics Includes handling reflows and repaints as well as WebGL. 

Storage Most often this is IndexedDB. 

Gecko Indicates items that doesn't fit into any of the other categories. 

Hover over the color key for a current category will fade all other categories.

Detailed output of the JavaScript sampling profiler

The lower half display the details of the profile.
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The  'Total Time (ms)' display the break down view of the stacks that contained specific active functions and their 
share in total number of stacks in percentage in the first column, the number of stacks called by the functions in the 
second column and a tree structure view of the functions in the third column. 

The 'Total Cost' indicates the number of samples to be taken in which the corresponding "Function" 
appeared in the call stack.  

The 'Running Time' indicates the total number of samples executed within the recording time followed by 
the percentage of stacks that executed the active functions. 

The 'Self Cost' indicates the number of stacks that were called while executing the active functions, and not
the stacks that called the function. 

The 'Self Time (ms)' indicates the amount of time spent executing the function, exclusive of any functions 
called by this function in the percentage of stacks that executed the active functions. 

The 'Samples' indicates the number of samples to be taken in which the corresponding "Function" 
appeared in the call stack. 

The 'Function' displays the function name, source file, line number and domain that served the file. To 
debug a specific function, hover the mouse cursor over the function and click on the right arrow that 
appears at the end of the line.

11.7. Memory Tool

The 'Memory' tool lets you visualize how web-page elements use memory. Memory allocation is represented as a 
tree of nested rectangles.

To access the memory interface

• Click the hamburger button at top-right 

• Select 'Web Developer' > 'Memory' 

• Click the 'Take snapshot' button or click the camera icon at top-right

• Click 'Save' link to save the snapshot. Navigate to the locate to save the entry with the extension 
.fxsnapshot.

• Click 'X' next to entry to delete a snapshot.

• Click 'Import' to load the snapshot from the extension .fxsnapshot file.

• Click 'Compare snapshot'.

Comodo IceDragon User Guide | © 2020 Comodo Security Solutions Inc. |  All rights reserved                                                                    167



Comodo IceDragon - User Guide
• Select the snapshot to use as basis then the snapshot to compare.

You also can store information about the subroutines of a computer program and allows you to view results in 
different ways along as group your data 

• Record call stacks 

• View: Tree Map, Dominators, or Aggregate

• Group by: Type, Call Stack or Inverted Call Stack

11.8. Network Monitoring
• The 'Network Monitoring' tool lets developers dynamically view network activity on a site. 

• For example you can start debugging a page in the web console, then switch to the network monitor to 
see network activity - all without reloading the page.

View page source

• Click the hamburger button at the top-right 

• Select 'Web Developer' > 'Network' 

• Click the stopwatch icon to run the performance analysis tool. 

The 'Network' tab loads the site twice. First with an empty browser cache, then again with a primed cache. This 
simulates the initial visit and a subsequent visit to the site.
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Results are summarized in the table and as a pie chart. 

• Click 'Back' to return to the network monitoring list

The network table contains the following columns:

• Status - The HTTP status code returned. Hover over the icon to see the exact code. Green color-coded 
icon - success (2XX codes), orange - redirection (3XX), or red - errors (4XX and 5XX). 

• Method: Shows the HTTP request method. 

• File: Shows the basename of the file requested. 

• Domain - Shows the domain of the path requested. 

• Cause - Reason the network request appeared. (XHR request, <img>, script, script requesting an image, 
etc. )

• Type - Shows Content-type of the response. 

• Transferred - Displays the number of bytes transferred to load the resource. 

• Size - Shows the size of the response. 

• Timeline - Displays a timeline for the different parts of each request. 

Each column can be sorted by ascending or descending.

The toolbar will be displayed at the top of the pane and allows you to switch between different pages:

• Headers - Provides information about the request: URL, status code, the HTTP request and sent response 
headers. 

The filter header field allows you to filter the headers. 

• Cookies - Provides full details of any cookies sent with the request or response. 

• Params - Displays the GET parameters and POST data of a request. 

• Response - Displays the complete content of the response. Depending of the type of response, it will be 
displayed in HTML, JS, or CSS as text, JSON as an object, an image will be shown as a preview. 

• Timings - Provides detailed timeline bar for the request showing how the total wait time is split into the 
various stages. 

The developers can also sort their certain type of files by HTML, by JS, by XHR, by Fonts, by Images, by Media or 
by Flash type.

• Click the buttons in the network toolbar to filter the list by type. This is also allows you to find out the total 
size and download time for a particular type of file.
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11.9. Storage
The Storage Inspector lets you inspect various types of storage that a web page can use. 

To open the developer toolbar 

• Click the hamburger button at the top-right 

• Select 'Web Developer' > 'Storage Inspector'.

Currently it can be used to inspect the following storage types:

• Cache Storage - any DOM caches created using the Cache API.

• Cookies - All the cookies created by the page or any iframes inside of the page. Cookies created as a 
part of response of network calls are also listed, but only for calls that happened while the tool is open.

• IndexedDB - All IndexedDB databases created by the page or any iframes inside the page, their Object
Stores and the items stored in these Object Stores.

• Local Storage - All local storage items created by the page or any iframes inside the page.

• Session Storage - All session storage items created by the page or any iframes inside the page.

11.10. Accessibility
Accessibility is the practice of making your websites usable by as many people as possible. 

This means ensuring not to lock anyone out of accessing information because of any disability they may have, or 
any other personal circumstances such as the device they are using, the speed of their network connection, or their 
geographic location.
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• To expose information to people with visual disabilities the accessibility APIs available inside web browsers,
renders information on what roles the different elements on your page play (e.g., are they just text, or are 
they buttons, links, form elements, etc.?).

• Semantic DOM elements have roles assigned to them by default that hint at what their purpose is. 

• Sometimes, however, you need to use some non-semantic markup (e.g., <div>s) to build a complex 
custom control, and the control won't have a default role that reflects its purpose. In such a situation, 
you can use WAI-ARIA role attributes to provide your own roles.

• Roles and other information exposed by browser accessibility APIs are presented in a hierarchical structure 
called the accessibility tree. 

• This is a bit like the DOM tree, except that it contains a more limited set of elements and slightly 
different information about them.

• Assistive technologies like screenreaders use this information to find out what's on a web page, tell their 
users what's there, and enable them to interact with the page. 

• The Accessibility Inspector also uses this information to provide valuable accessibility debugging 
capabilities in the DevTools. 

11.11. Use the WebIDE
The WebIDE allows developers to manage runtimes and develop through the Firefox simulator or a real Firefox OS 
device.

The WebIDE provides three steps to run and debug the application:

• Set up a runtime

• Create an app or open an existing app

• Install the app on the runtime

Open WebIDE 

• Click the hamburger at the top-right 

• Select 'Web Developer' > 'WebIDE'

• Alternatively, click the 'Customize' button from the menu on the bottom-right

• Select the WebIDE  icon and dock it at the toolbar

• Click 'Done' to save the changes.
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• The sidebar on the left displays existing apps or lets you to create an app

• The sidebar on the right allows you to select a runtime or set a new runtime.

Set up a runtime

You can manage the runtime on the right of the sidebar. Runtimes are grouped into four types:

• USB devices - Displays OS devices connected over USB.

• WI-FI DEVICES - Displays OS devices connected over Wi-Fi

• OTHER - Allows WebIDE to connect to host and port to runtime remotely.
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Add a new application

• Click the of the three options:

• Create a new app

• Open a packaged app

• Open a hosted app

• To remove a project, click the 'Project' menu > 'Remove Project'.

11.12. Browser Toolbox and Browser Content Toolbox
• The browser toolbox allows you to debug add-ons and the browser's own JavaScript code. In contrast, the 

normal toolbox only allows you to debug webpages.. 

• The browser toolbox's context is the entire browser rather than just single page on a single tab.

• Click the hamburger button at the top-right 

• Select 'Web Developer' > 'Browser Toolbox'.

The browser toolbox will prompt you to enable or cancel the incoming request to remote debug your browser.
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Click 'OK' to enable the remote connection.

• Enable browser toolbox, by clicking the 'Enable browser chrome  and add-on debugging toolboxes' and 
'Enable remote debugging'.

Target a specific window

In the toolbox, click the drop-down in the toolbar enabling any of the other windows.
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Debugging pop-ups

It is hard to debug pop-ups because the browser hides them as soon as you click outside them. 

• To disable this behavior, click the toolbox menu and select Disable popup auto-hide

11.13. Browser Console
The 'Browser Console' tool is advanced logging & debugging features that is executed in the context of IceDragon 
itself.

• Click the hamburger button at the top-right 

• Select 'Web Developer' > 'Browser Console'.

From here you can:

• View all JavaScript errors 

• View logs in the browser 

• Log any object directly to the console 

• Provides helper console
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11.14. Responsive Design Mode
'Responsive Design View' helps web devs to view and navigate designs on different screen sizes without changing 
the overall size of their browser window. 

To open responsive design view 

• Click the hamburger button at the top-right 

• Select 'Web Developer' > 'Responsive Design Mode'.

11.15. Eyedropper
The 'Eyedropper' tool lets web developers select colors in the current page. Hover the magnifying glass over the 
page and you will see the color value for the current pixel you have selected.

• Click the hamburger at the top-right 

• Select 'Web Developer' > 'Eyedropper'
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Use the eyedropper

• Select a color from the page and copy it to the clipboard 

OR

• Change a color value in the Inspector's Rules view 

11.16. Run Experimental Java Scripts on Page
The 'Scratchpad' tool allows you to run experimental Java Script code on a page. 

• You can try out various ideas and execute them on the web page before final implementation. 

• Some of the uses of 'Scratchpad' include testing new code, debugging, and to run saved reusable java 
script code.

Open the scratchpad tool

• Click the hamburger button at the top-right 

• Select 'Web Developer'> 'Scratchpad'.

The 'Scratchpad' editor will open. This contains some brief information about how to use it.
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After you have written the code in the Scratchpad, select it and right-click to execute or from the menu bar select 
'Execute'. You have three choices to output the code:

• Open File - Opens JavaScript files.

• Save / Save As - Saves JavaScript code snippets.  

• Run - Executes the code in the page.

• Inspect - In addition to executing the code in the page, an object inspector will be displayed that will help 
you to analyze the returned value.

• Display - After executing the code in the page, the results are inserted in the Scratchpad window as a 
comment. This will help you to keep track of the changes made in the page.

• Pretty Print - Allows you to print a code.

11.17. View Page Source
Comodo IceDragon lets you view the source code of the web-page you are viewing. This is useful for web devs to 
analyze the code and style rules while developing their own pages.

View the page source

• Click the hamburger button at top-right 

• Select 'Web Developer' > 'Page Source'

• The page source will open in a new tab:
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11.18. Service Workers
Ice Dragon service workers enable sites and services to interact with the browser without having to be open in it. 
They are scripts that work in the background. 

• The sections will be updated automatically as workers get registered.
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To view the service worker

• Click the hamburger button at the top-right 

• Select 'Web Developer'> 'Service Worker'

Open Addons to start debugging addons

The 'Add-ons' page lists all bootstrapped add-ons that are currently installed.

• Click the 'Add-ons' tab 

• Checkbox 'Enable add-on debugging' to load an add-on temporarily from disk 
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• Navigate to the directory to upload the add-on file

• Select it in directory and click 'Open'. 

Note: Addon will be available until you restart your browser.

• Click 'Debug' link to accept an incoming connection. 

• Click 'OK' to start the debugger in a separate window. 

Open Tabs to start debugging currently opened pages

• Click the 'Add-ons' tab > 'Tabs'  

• Select the page you want to debug and click 'Debug' button next to it. 
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Open Workers to start debugging workers

• Click the 'Add-ons' tab > 'Workers'

• The 'Workers' tab allows you to debug 'Service workers', Shared Workers and Other Workers.
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• Select the page you want to debug and click 'Debug' button next to it.

• To send a push notification, run a service worker. You will see two buttons next to it: 'Debug' and 'Push'. 

Tip:The 'Service worker' are not available as follows:

• If service set to false in about:config

• If private browsing mode is run

• If you set 'Never Remember History or Always use private browsing mode in the the 'History' section.

11.19. Connect Remote Device
• IceDragon lets you remotely debug code that is running in another browser.

Enable remote debugging

• Click the hamburger button at the top-right 

• Select 'Web Developer'> 'Web Console'

• Click '…' at the top-right of the console

• Scroll to 'Advanced settings' then select 'Enable remote debugging':

Connect to a remote device

• Click the hamburger menu > 'Web Developer' > 'Connect' 

• Enter the name and port of the remote host

• Click 'Connect' to confirm your choice.

Comodo IceDragon User Guide | © 2020 Comodo Security Solutions Inc. |  All rights reserved                                                                    183



Comodo IceDragon - User Guide

11.20. Add More Web Development Tools
To add more web development tools

• Click the hamburger button at the top-right corner 

• Select 'Web Developer' > 'Get More Tools' 

• You will be taken to a Mozilla page from which you can download web-dev add-ons 

• See Install Add-ons if you need help to install add-ons.

11.21. Work Offline
In 'Offline Mode' you are not connected to the internet but are still able to view cached and saved web pages. 

You can:

• View cached and saved web pages.

• Open locally saved files and images

• Configure Ice Dragon

You cannot: 

• Access the internet 

• Send/receive mail

• Download new files

Enable offline mode:
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• Click the hamburger button at the top-right corner 

• Select 'More' > 'Work Offline'

12.  Troubleshooting
This section explains how to resolve problems that might arise when you are using Comodo IceDragon. 

• Error: ''Your connection is not secure"

12.1. Error: ''Your connection is not secure''
IceDragon may show this message when there are problems with a website's TLS/SSL certificate. You are advised 
not to visit the site in question, especially if you plan to submit confidential details such as login information or 
personal data.

To create an exception for the site

• When the error appears, click the 'Add Exception' button at the bottom of the warning:
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The 'Add Exception' dialog will open.
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• The 'Get Certificate' button allows you to inspect the certificate in detail

• Check the 'Permanently store this exception' box to trust the certificate on all future visits

• Click 'View' to open the certificate view

• Click 'Confirm Security Exception' to apply your choice.

13. Report a Bug
Comodo continually updates its products and intends to keep them bug-free. If you find any bug or have questions, 
please submit a bug report post them in the Feedback section of the Comodo IceDragon forum at:

http://forums.comodo.com/bug-reports-cid-b284.0/

 If you haven’t done so already, please create an account before posting.

Comodo IceDragon User Guide | © 2020 Comodo Security Solutions Inc. |  All rights reserved                                                                    187

http://forums.comodo.com/bug-reports-cid-b284.0/


Comodo IceDragon - User Guide

Comodo Security Solutions
Comodo Security Solutions is a global innovator of cybersecurity solutions, protecting critical information across the 
digital landscape. Comodo provides complete, end-to-end security solutions across the boundary, internal network 
and endpoint with innovative technologies solving the most advanced malware threats. With over 80 million 
installations of its threat prevention products, Comodo provides an extensive suite of endpoint, website and network 
security products for MSPs, enterprises and consumers.

Continual innovation and a commitment to reversing the growth of zero-day malware, ransomware, data-breaches 
and internet-crime distinguish Comodo Security Solutions as a vital player in today's enterprise and home security 
markets.

About Comodo Cybersecurity
In a world where preventing all cyberattacks is impossible, Comodo Cybersecurity delivers an innovative 
cybersecurity platform that renders threats useless, across the LAN, web and cloud. The Comodo Cybersecurity 
platform enables customers to protect their systems and data against even military-grade threats, including zero-day 
attacks. Based in Clifton, New Jersey, Comodo Cybersecurity has a 20-year history of protecting the most sensitive 
data for both businesses and consumers globally. For more information, visit comodo.com or our blog. You can also 
follow us on Twitter (@ComodoDesktop) or LinkedIn.

1255 Broad Street 

Clifton, NJ 07013

United States 

Tel : +1.877.712.1309

Tel : +1.888.551.1531

https://www.comodo.com

Email: EnterpriseSolutions@Comodo.com
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